We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Another odd Omega not booting problem

  • Received my Omega package about 2 weeks ago. On powering up (following the Getting started Tut) got no LED on the Omega. Thinking some one else had been there and done that came to the forum and found several similar posts. Seems my Omega has a pre-production image. That said, not having the Ethernet board, built my own following posts elsewhere on the forum and then things get weird. On booting (not to Uboot) am able to configure eth0 and can ping from my network to and from the Omega. If I drop to Uboot am unable to get networking to work at all, have tried over LAN and direct to PC. I know my wiring is OK as I can establish a connection if I don't drop to Uboot. Also, have seen several posts by others describing using httpd in Uboot, if I try I get "Unknown command", but httpd seems to function on allowing a full boot...
    Any suggestions/help would be greatly appreciated.

  • @Harvey-Golob Can you copy and paste the output of your serial terminal when you try to start httpd from uboot?

  • @Boken-Lin Output of httpd in uboot:

    U-Boot 1.1.4 (Aug 28 2015 - 16:51:26)
    AP121 (ar9331) U-boot
    DRAM:  64 MB
    Top of RAM usable for U-Boot at: 84000000
    Reserving 140k for U-Boot at: 83fdc000
    Reserving 192k for malloc() at: 83fac000
    Reserving 44 Bytes for Board Info at: 83fabfd4
    Reserving 36 Bytes for Global Data at: 83fabfb0
    Reserving 128k for boot params() at: 83f8bfb0
    Stack Pointer at: 83f8bf98
    Now running in RAM - U-Boot at: 83fdc000
    Flash Manuf Id 0xef, DeviceId0 0x40, DeviceId1 0x18
    flash size 16777216, sector count = 256
    Flash: 16 MB
    Using default environment
    In:    serial
    Out:   serial
    Err:   serial
    Net:   ag7240_enet_initialize...
    No valid address in Flash. Using fixed address
    No valid address in Flash. Using fixed address
    : cfg1 0x5 cfg2 0x7114
    eth0: 00:03:7f:09:0b:ad
    eth0 up
    : cfg1 0xf cfg2 0x7214
    eth1: 00:03:7f:09:0b:ad
    ATHRS26: resetting s26
    ATHRS26: s26 reset done
    eth1 up
    eth0, eth1
    Hit any key to stop autoboot:  0
    ar7240> httpd
    Unknown command 'httpd' - try 'help'

  • @Harvey-Golob That's so strange... Can you give us the output of help?

    Also, are you using Windows or Mac or Linux? We will need you to host a tftp server on your computer. Let me know if you know how to do that. If not we can show you how to do it.

  • @Boken-Lin help listing:

    ar7240> help
    reset   - Perform RESET of the CPU
    ?       - alias for 'help'
    boot    - boot default, i.e., run 'bootcmd'
    bootd   - boot default, i.e., run 'bootcmd'
    bootm   - boot application image from memory
    cp      - memory copy
    erase   - erase FLASH memory
    help    - print online help
    md      - memory display
    mm      - memory modify (auto-incrementing)
    mtest   - simple RAM test
    mw      - memory write (fill)
    nm      - memory modify (constant address)
    ping    - send ICMP ECHO_REQUEST to network host
    printenv- print environment variables
    progmac - Set ethernet MAC addresses
    run     - run commands in an environment variable
    setenv  - set environment variables
    tftpboot- boot image via network using TFTP protocol
    version - print monitor version

    Running Win 7. Have setup TFTP Turbo4 and was going to attempt tftpboot of the latest firmware but can't seem to get the ethernet link working in uboot. Maybe I'm missing something?

  • @Harvey-Golob Can you try the following?

    setenv ipaddr   
    setenv serverip
    tftp 0x80000000 uboot.bin
    erase 0x9f000000 +0x10000
    cp.b 0x80000000 0x9f000000 0x10000

    The uboot binary can be downloaded here: https://s3-us-west-2.amazonaws.com/onion-downloads/openwrt/uboot_for_omega_final.bin.

  • @Boken-Lin I'm doing this over my LAN so tftp server is at When running tftp get this:

    ar7240> setenv ipaddr
    ar7240> setenv serverip
    ar7240> tftp 0x800000000 uboot.bin
    dup 1 speed 10
    Using eth0 device
    TFTP from server; our IP address is
    Filename 'uboot.bin'.
    Load address: 0x0
    Loading: *
    TFTP error: 'Cannot open file '.\tftp_root\uboot.bin'. (The system cannot find the file specified.)' (1)
    Starting again
    eth1 link down

    When setting IP on the Omega in Uboot have not been able to ping from either end, yet when Omega boots to Linux can ping from both sides of the connection...

  • @Harvey-Golob When you say you are doing it over LAN do you mean you are connecting the Omega to your router and trying to flash the Omega from your computer, which is also connected to your router?

  • @Boken-Lin Yes.

  • @Harvey-Golob Is there anyway you can try Omega to computer direct? Uboot is a very small program, so it doesn't have the dhcp stack built in. Your router typically assigns IP via DHCP. Even though with the setenv command you are setting the static ip of the Omega to, it might not be recognized by the router (because the Omega in uboot isn't responding to the router with dhcp protocol).

  • @Boken-Lin I was wondering if something like that might be the case. Will setup a laptop with the Tftp server and try...

  • @Harvey-Golob Ok. Keep me posted.

  • @Boken-Lin It's ALIVE....., thanks for the help, I had moved the connection to the laptop yesterday but didn't try tftp on the laptop.
    Reflashed Uboot and httpd to load the latest Omega firmware an its up and running. Now to tackle wifisetup😓

  • Was going to say make sure your host firewall is turned off on windows as that is generally the biggest problem when hosting stuff on a windows desktop! (Windows firewall normally, obviously turn it back on after, alternitively create a rule to allow ping and tftp through)

  • @Boken-Lin Omega seems to run as expected except no wifi, have gone over another post related to no wifi and can't get any response from Omega as far as wifi set up. The following is what I get.

    BusyBox v1.23.2 (2015-12-09 19:09:31 UTC) built-in shell (ash)
       ____       _             ____
      / __ \___  (_)__  ___    / __ \__ _  ___ ___ ____ _
     / /_/ / _ \/ / _ \/ _ \  / /_/ /  ' \/ -_) _ `/ _ `/
     \____/_//_/_/\___/_//_/  \____/_/_/_/\__/\_, /\_,_/
     W H A T  W I L L  Y O U  I N V E N T ? /___/
       Ω-ware: 0.0.5 b238
    root@Omega-6CF0:/# wifi
    root@Omega-6CF0:/# ifconfig -a
    eth0      Link encap:Ethernet  HWaddr B6:F4:3C:BE:6C:F0
              BROADCAST MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:0 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    lo        Link encap:Local Loopback
              inet addr:  Mask:
              inet6 addr: ::1/128 Scope:Host
              UP LOOPBACK RUNNING  MTU:65536  Metric:1
              RX packets:240 errors:0 dropped:0 overruns:0 frame:0
              TX packets:240 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:0
              RX bytes:16992 (16.5 KiB)  TX bytes:16992 (16.5 KiB)
    root@Omega-6CF0:/# wifisetup -ssid linksys -auth none -password ""
    > Connecting to linksys network using intf 1...
    > Checking wwan device status...
    > wwan is not up!!
    > Disabling network on iface 1 ...
    > Done!

    The last post to https://community.onion.io/topic/135/omega-can-t-connect-to-wifi didn't seem to have resolved similar issues. Any other suggestions?

  • @Harvey-Golob If you run a hotspot on your phone, are you able to detect it via the wifisetup command?

  • @Harvey-Golob I think I figured out the issue. You also need to flash the ART partition on the Omega. Can you start up httpd from your uboot again, and at the bottom, there should be a link to flash ART. the ART partition binary can be found here: https://s3-us-west-2.amazonaws.com/onion-downloads/openwrt/art_for_omega.bin.

  • @Boken-Lin Flashed ART just now, no change. Also tried hotspot suggestion, scan from Omega still fails. ifconfig only shows lo and eth0. Headed to work now, will check back end of day.

  • @Harvey-Golob You will need to do a factory reset after flashing the ART partition. On first boot, the Omega will read from the ART partition and setup its WiFi.

    Sorry about the confusion!

  • @Boken-Lin Finally got back to this, started Omega, did factory reset and still no wifi. Just to be sure dropped to Uboot and started httpd and tried to reflash ART. Then did factory reset and no change.

Looks like your connection to Community was lost, please wait while we try to reconnect.