We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

First boot, can't find access point...

  • @Erik-Leisch said:

    Anyone have this issue when they first got theirs?

    Yes i got a similar problem. I had to change the ID from my Home WIFi. It was on ID13 and I had to lower to ID9. Otherwise i could not see the Wifi from my home. Just the neighbors WIFI appeared.

    With my smartphone and a Wifi Analyzer i could localize the ID's and changed them in the WIFI settings on the router.

    As mentioned from @Lazar-Demin without WiFi connection the AP (of Omega) is deactivated and not appears.

  • @Luciano-S. thanks for the reply! I can't even scan for wireless networks. Each time I do, it returns "no wireless networks found, try again later..." Any thoughts?

  • @Erik-Leisch said:

    @Luciano-S. I can't even scan for wireless networks. Each time I do, it returns "no wireless networks found, try again later..."

    Did you understand what i wrote? From point of view of the Omega i could also not see my network. Till i found out, that my network uses a frequency where the Omega not can catch the signal (ID higher 9).

    I had to change this on my wifi router! Just after that i could see a network.

    What is your WiFi routers brand/model? Are you still using the manufacturers firmware?

  • @Luciano-S. yes, the problem is there are 20+ wireless networks in range of the omega. If the omega can't find a single SSID, there has got to be a different problem.

  • Sounds very strange. What channel does the Onion Omega AP use? https://en.wikipedia.org/wiki/List_of_WLAN_channels ..

    That's the only thing I can see. If Onion Omega Wi-fi uses a channel your router don't check.

    EDIT: And if there are only 5GHZ wi-fi networks around you, your Onion Omega will probably not detect those. But it's very rare that everyone is on the 5GHZ range hehe. And if your router is on the 5GHZ range, I don't know if it can find the 2.4GHZ ones. This is stuff that probably can be googled.

    Thinking of it.. is your wi-fi router on the 5GHZ range?

    EDIT2: Some errors here, this is stuff I don't know too much about. Of course when you scan with your PC it is your wifi-chip that does the job.. šŸ™‚

  • @Lazar-Demin said:

    @Erik-Leisch Ok I see the issue now... Attempting to connect to a wireless network unsuccessfully will disable the AP network!

    As @Lazar-Demin said, no wifi no AP!

    What happens when you connect via serial and type in wifi then wifisetup? Does your wifi then still get no connection?

  • @Luciano-S. Yes, correct. When connected over serial, I have done the following with the respective results:

    1. action: wifisetup > selection 1 (scan for wifi networks)
      result: ERROR: no networks detected... try again in a little while

    2. action: wifisetup > selection 2 (type network info)

    [ 325.520000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
    [ 325.790000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    Checking wwan device status...
    wwan is not up!!
    Checking internet connection...
    ERROR: request timeout, internet connection not successful
    Disabling network on iface 1 ...
    root@Omega-220D:/# [ 364.680000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 364.750000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

    1. action: edited wireless config file (located at /etc/config/wireless) to try and broadcast AP
      result: no AP broadcast

    Maybe I have defective hardware?

  • also, I've tried the sequence where first I type wifi then wifisetup

  • @Erik-Leisch said:

    also, I've tried the sequence where first I type wifi then wifisetup

    What was the output? Any error messages?
    Wifi starts the WIFI network adapter and with wifisetup you can choose your wifi-network and put the password in.

    @Erik-Leisch said:

    Maybe I have defective hardware?

    Make a ticket > https://onion.freshdesk.com/support/home

  • @Erik-Leisch looks like the same commands on my omega run just fine, you have done all that you can do sounds like replacement time.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.