@EERoarEE if you prevent the mt wifi module from loading then wifi should not be enabled. Try editing /etc/modules.d/52-mt7628 and comment out mt-wifi