We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

How to physically disable Wifi on Omega2+



  • I'm trying to physically disable the RF on my Omega2+. I removed the SMT antenna, 0 ohm resistor, and the external antenna UFL jack as well, yet the Wifi signal still persists on power up. I'm not understanding how this is still possible, is the Omega2 using the trace coming out of the IC as the antenna as well or is something else going on? Any thoughts on how to fully disable this?



  • @EERoarEE You could disable the network process and test if you still have RF signals

    /etc/init.d/network stop



  • @jossvall that does seem to disable it however, I am looking for a more permanent solution so that it never goes on.



  • @EERoarEE you could unboot network at system boot:

    rm /etc/rc.d/S20network

    Note: keep in mind that this will remove the symbolic link from the network boot, and it will not restart the network unless you re-create that symbolic link. use that command at your own risk.

    I think you could also add a script at the end of the boot, so that it deactivates it at the end of loading all the programs.

    You could also add a task to the cron that is responsible for downloading that process.



  • @EERoarEE if you prevent the mt wifi module from loading then wifi should not be enabled. Try editing /etc/modules.d/52-mt7628 and comment out mt-wifi



Looks like your connection to Community was lost, please wait while we try to reconnect.