I believe you can turn indexing off by going to:
/etc/config/uhttpd

and changing option no_dirlists '0' to option no_dirlists '1'

If the directive doesn't exist.... add it.