We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[SOLVED] Omega can't connect to WiFi

  • hi @Boken-Lin ! I finally had time to try out your suggestions.
    so here's the output of /etc/config/wireless.

    /etc/config/network delivers:

    I hope it helps! I'm trying another network right now, to avoid problems with the network authentication. I only need the wifi-password now and no additional network-passwords etc 😉

  • Hi @Nito-Weber in /etc/config/wireless, can you change

    config wifi-iface
    	option device 'radio0'
    	option network 'wlan'
    	option mode 'Router'
    	option encryption 'psk2'
    	option ssid 'SitecomA3A738'
    	option key '15066589'

    to the following:

    config wifi-iface
    	option device 'radio0'
    	option network 'wwan'
    	option mode 'sta'
    	option encryption 'psk2'
    	option ssid 'SitecomA3A738'
    	option key '15066589'

    Save the file, and issue wifi command.

  • That block is there twice:

    i'll delete one of them.

  • Hi,

    Had the same problem, the Omega didn't recognize my home network too.

    Then I saw the Wi-Fi configuration with the option 'US' enabled. This option disables the channels 12 & 13, which are not allowed in the US (or only with power restrictions). They're allowed in Germany, where I live, and my router is using channel 13, so I changed the option to 'DE, and voila, the Omega immediately found my home Wi-Fi network and connected to it without any further problems.


    ~ HD ~

  • Thank you @Hans-Dieter-Stich ! I did the same as you did, but that was the output again... as always:


    how can i enable radio0 ?

  • Hi @Nito-Weber, can you run the following commands:

    uci set wireless.radio0.disabled=0
    uci commit

  • @Boken-Lin i did it and that was the output:

    i tryed ping google.com and it worked and now i can finally run oupgrade !!!! thank you so much @Boken-Lin , we made it! ❤ 👍

  • @Nito-Weber Awesome!

  • @Boken-Lin
    I have tried eveything listed above and still no luck in connecting to my Wifi.
    If I setup a hotspot on my ohone I am able to connect and have done the firware upgrade but still am not able to connect to my wifi.
    I have an Arduino YUN that connected first time without any problems.

    My wifi is running WPA2 with aes. This is the first device that I have had problems connecting to my WiFi.

    Any help would be much appreciated.

  • Hi @Ian-Carr, Does your Omega able to serve an access point? Can you connect to the Omega via serial terminal, and copy and paste the output on the terminal when you try to connect with the wifisetup command?


  • @Boken-Lin Here is the output from wifisetup.

    Onion Omega Wifi Setup

    Select from the following:

    1. Scan for Wifi networks
    2. Type network info
      q) Exit

    Selection: 1
    Scanning for wifi networks...

    Select Wifi network:

    1. EnergyCybernetics2
    2. EnergyCybernetics2

    Selection: 1
    Network: EnergyCybernetics2
    Authentication type: psk2
    Enter password: **********

    Connecting to EnergyCybernetics2 network using intf 0...
    [ 227.080000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 228.560000] wlan0: authenticate with 4c:5e:0c:36:0a:bd
    [ 228.580000] wlan0: send auth to 4c:5e:0c:36:0a:bd (try 1/3)
    [ 228.580000] wlan0: authenticated
    [ 228.600000] wlan0: associate with 4c:5e:0c:36:0a:bd (try 1/3)
    [ 228.610000] wlan0: RX AssocResp from 4c:5e:0c:36:0a:bd (capab=0x431 status=0 aid=1)
    [ 228.620000] wlan0: associated
    [ 228.620000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 233.610000] wlan0: deauthenticated from 4c:5e:0c:36:0a:bd (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    Checking wwan device status...
    wwan is not up!!
    Checking internet connection...
    [ 244.490000] wlan0: authenticate with 4c:5e:0c:36:0a:e1
    [ 244.510000] wlan0: direct probe to 4c:5e:0c:36:0a:e1 (try 1/3)
    [ 244.720000] wlan0: direct probe to 4c:5e:0c:36:0a:e1 (try 2/3)
    [ 244.930000] wlan0: direct probe to 4c:5e:0c:36:0a:e1 (try 3/3)
    [ 245.140000] wlan0: authentication with 4c:5e:0c:36:0a:e1 timed out
    [ 245.930000] wlan0: authenticate with 4c:5e:0c:36:0a:bd
    [ 245.950000] wlan0: send auth to 4c:5e:0c:36:0a:bd (try 1/3)
    [ 245.950000] wlan0: authenticated
    [ 245.980000] wlan0: associate with 4c:5e:0c:36:0a:bd (try 1/3)
    [ 245.990000] wlan0: RX AssocResp from 4c:5e:0c:36:0a:bd (capab=0x431 status=0 aid=1)
    [ 245.990000] wlan0: associated
    [ 250.990000] wlan0: deauthenticated from 4c:5e:0c:36:0a:bd (Reason: 15=4WAY_HANDSHAKE_TIMEOUT)
    ERROR: request timeout, internet connection not successful
    Disabling network on iface 0 ...
    root@Omega-09C5:/# [ 271.910000] wlan0: authenticate with 4c:5e:0c:36:0a:bd
    [ 271.930000] wlan0: send auth to 4c:5e:0c:36:0a:bd (try 1/3)
    [ 271.930000] wlan0: authenticated
    [ 271.960000] wlan0: associate with 4c:5e:0c:36:0a:bd (try 1/3)
    [ 271.970000] wlan0: RX AssocResp from 4c:5e:0c:36:0a:bd (capab=0x431 status=0 aid=8)
    [ 271.970000] wlan0: associated
    [ 271.980000] wlan0: deauthenticating from 4c:5e:0c:36:0a:bd by local choice (Reason: 3=DEAUTH_LEAVING )


  • @Nito-Weber , might be a good idea to remove in your firs post the [resolved] from the title. So we can continue using it for the same problem with the experiences you made.

  • I installed build omega-v0.0.6-b279 from http://repo.onion.io/omega/images/
    using the method discribed in https://community.onion.io/topic/358/factory-reset-not-working/2

    The wifi setup worked first time and is running great.

  • @Nito-Weber ... Most dorm networks have 801.2x security which requires additional configuration (EAP/AUTH Type etc). This cannot be done on the omega because it ships with 'wpad-mini' by default. If you still would like to use it in your dorm then try the method in this post:


    @Boken-Lin & @Lazar-Demin - if I may suggest why not make 'wpad' the default rather than the 'wpad-mini'. I believe it will solve most of the connectivity issues. Of course it will eat up a few kb more space but it could be worth it.

  • @Boken-Lin Hi, I changed my wireless configuration to your config. After that I received "Invalid mode". Now I can't see any wifi from the onion. Can I hard reset it, without ssh to it? I hope I don't bricked it 😞

  • My WIFI is at WEP. Omega2 does not connect to this AP, but when I tired my hotspot on my nexues 5 (which is WPA2) it connected. Any help from any one is much appreciated.

  • @Gayan-Priyanatha Same problem for me. At a customer site they are using WiFi with WEP and a code like 429a2936580b72330486c13973. Trying to configure this yields the following result:

     root@Omega-5857:~# wifisetup add -ssid Visitors -encr WEP -password     429a2936580b72330486c13973
    > Restarting wifimanager for changes to take effect
    root@Omega-5857:~# wifisetup list
        "results": [
        "ssid": "xxxxxxxxxxxxx",
        "encryption": "WPA2PSK",
        "password": "yyyyyyyyyyyyyyyy" 
        "ssid": "Visitors",
        "encryption": "WEP",
        "password": "1" 

  • @Nito-Weber I'm using WPA-TKIP and can't connect unless I go Open. I understand AES works. Is this just as good as TKIP?

  • @Gayan-Priyanatha @Peter-Lelie If it's at all possible, you should consider setting your wifi router to WPA2-AES instead of WEP (very vulnerable).
    @Don-DeGregori TKIP was deprecated in the 2012. Same advice to you!

  • @Gayan-Priyanatha Have you tried this?

Looks like your connection to Community was lost, please wait while we try to reconnect.