We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

GPS expansion stopping Omega2 from booting

  • Hi!

    When I plug in my GPS expansion into the power dock USB port and turn on the Omega2, it doesn't boot.

    Nothing happens except that the blue LED on the GPS expansion as well as the blue power LED on the power dock blinks with a very low light.

    I'm powering the dock with a 2400 mA charger and it works great without the GPS expansion connected.

    Has anyone else experienced anything similar? Is my GPS expansion faulty?

  • Maybe you have an "intelligent" charger which provides 2400 mA for some dedicated devices only.

    For example: The Best Multiport USB Wall Charger

    Anker uses technology it calls “Power IQ” to regulate the power output from many of its accessories, including the Anker PowerPort 4. According to the company, Power IQ “dynamically detects and adapts to your device’s unique charging protocol enabling it to charge at full speed.” Put simply, circuitry in the charger is able to tell whether you’re plugging in a smartphone, tablet, or other device, and whether it’s Android, iOS, or something else; it’s then able to deliver the appropriate amount of current for the fastest charging speed. This is one reason why you don’t need to worry about finding the “right” port on the charger for full-speed charging; each port adapts on the fly depending on what’s plugged in. (Some other chargers use similar circuitry—this kind of feature isn’t unique to Anker, though we’ve had good luck with it on Anker products.)

    You should try a good power supply - say 5V more than 1A - instead of that USB charger.

  • @György-Farkas I've tried several charges and I get the same result everytime, as soon as I plug in the GPS expansion the Omega2 LED turns off and the blue power LEDs start blinking with really low light.

    The chargers I use output between 2.3 and 2.4 A at 5V so that should be more than sufficient.

  • I don't have a fix but I am having the same issue, I opened a ticket with support and waiting for feedback.

  • You have probably already done this, but turn off the power, plug in the GPS expansion, then turn on the power again.

    I have had the GPS expansion do this before when I was running off a battery plugged into the power-dock. I had to have the GPS expansion already plugged in before powering up the device.

  • I have tried that with no luck. I am able to get it working properly using just a 3.7v 1200mah lipo. Once i plug in the mini usb the onion dies.

  • @Mike-Shaver That kinda tells me the mini-usb cable/plug is not supplying enough power. Do you have different cable and brick that will supply more?

Looks like your connection to Community was lost, please wait while we try to reconnect.