We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

New Omega2+ can't find wifi APs

  • Hi guys!

    I found some other related issues on here, but none that solve my issue. Trying to set up my new Onion2+, the wifi scan does not pick up my Apple Time Capsule. As suggested in another post, I've tried setting the channel of both the Onion and the Time Capsule to 9, which unfortunately didn't help.

    Running wifisetup results in the following:

    root@Omega-433B:/# wifisetup
    Onion Omega Wifi Setup
    Select from the following:
    1) Scan for Wifi networks
    2) Type network info
    q) Exit
    Selection: 1
    Scanning for wifi networks...
    [  588.994143] br-wlan: port 2(ra0) entered disabled state
    [  590.036322] EEPROM:Read from [factory] offset 0x0,length 0x400.
    [  590.244994] br-wlan: port 2(ra0) entered forwarding state
    [  590.250523] br-wlan: port 2(ra0) entered forwarding state
    [  592.241029] br-wlan: port 2(ra0) entered forwarding state
    setting apcli
    > ERROR: Scan failed, try again
    > ERROR: specified ssid not in the database

    My /etc/config/wireless looks like this:

    root@Omega-433B:/# cat /etc/config/wireless
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel '9'
            option txpower '100'
            option ht '20'
            option country 'ZA'
            option disabled '0'
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ApCliEnable '1'
            option ApCliSsid 'yourwifissid'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEncrypType 'AES'
            option ApCliPassWord 'yourpassword'
            option ssid 'Omega-433B'

    Not really sure how to troubleshoot this. Any ideas?

  • How are you powering the Omega?

  • @Brad-Buskey I have tried the USB port on my mac (so I could use screen to connect to the Onion), as well as a 2amp external USB power supply.

    I have also tried using one of my first gen Onions, and it successfully connects to the wifi.

  • I have managed to get it using the AP - I needed to manually type in my SSID in the web setup UI as the AP doesn't show up when scanning for networks using the UI. Probably due to the Scan failed error shown above.

  • Similar problem here: my Omega 2+ can see my router, but refuses to connect. Doesn't give any error message, but the router doesn't register any connection attempt.

    It's powered through a standard USB cell phone charger.


Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.