We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+: Kernel failure

  • Hello guys!

    I have encountered a serious problem with my Omega2+.
    At the beginning it has worked. I got through the installation process and have successfully set up the Omega with the Webinterface. The Webinterface worked and I installed Python3 full version.

    I restarted the Omega but the graphical interface of the Omega was gone. Instead it listed the directory of the Omega in the browser.

    Then I tried to reinstall the firmware over the console in the network that was hosted by the Omega (omega2p-v0.1.10-b163.bin ) found here. The console told me the firmware was installed successfully and the Omega will restart.

    Since then, it always crashes during boot due to a kernel failure. You can find the stacktrace on Pastebin:

    I found out that Build163 is a build with problems. So I tried B160, B161, B162 and B163 again, installed with a USB flash drive. I also tried a factory reset, but the error is still there and the system is not booting up.

    I would really appreciate any help. Thank you!

  • @Evil-Robot
    Try to USB install omega2p-v0.1.10-b160.bin one more time.

    MD5 checksum:
    56467a9cccab0778971586034beec570 *Omega2.bin

    It should work.
    Good luck!

  • @György-Farkas Thank you for your help!

    It seems that I just forgot to rename the file. It works now.

  • I am currently in a similar situation: everything worked perfectly like a month ago, but when I tried to bot it again earlier today, I could only see the console directory as webpage.

    When I tried to update the firmware, it failed to boot with a "kernel failure".
    Afterwards I tried reflashing from usb with various firmware versions, resulting in a "Bad Magic Number" error on boot...

    Console output

    What would be the best course of action here? Or is my Omega now permanently bricked?

  • @William-Thenaers
    According to your log file it was probably an omega-v0.1.5-b128.bin image:

    FAT: 6815899 Bytes read

    You have got an Omega2+ so you should install an omega2p-*.bin image, for example:

    MD5 checksum:
    56467a9cccab0778971586034beec570 *Omega2.bin

    FAT: 7078055 Bytes read

    Good luck!

  • @György-Farkas That's the thing, I tried various images, every one of which gave the same error log.

    The omega-v0.1.5-b128.bin was the last one I tried prior to posting here.

    I already tried the omega2p-v0.1.10-b160.bin image (and checked the hash to make sure), with the same result.

    I will try again when I'm free though.

    Edit: still the same result after trying again but with different "magic number":

    ## Booting image at bc050000 ...
    Bad Magic Number,032DA956

Looks like your connection to Community was lost, please wait while we try to reconnect.