We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

OMEGA 2+ not working after initial setup

  • Hi,
    Ive finally received my new OMEGA 2+ board plus everything else. I was able to go through the initial setup using the power dock, all seem to have worked fine, setup the wifi, did the firmware update, and did the reboot. The next day, nothing seems to work, the light on the OMEGA 2+ doesn’t come on; it’s making a high pitch noise. Im still using the power dock. I tried to power it with the MINI dock, it still doesn’t power up, no light comes on, on the OMEGA 2+, and the MINI dock gets extremely hot. I tried the same with the breadboard dock and get the same result, no lights on the OMEGA 2+ and the breadboard dock get extremely hot. Tried De-Brick the Omega with Ethernet Expansion procedure, with no success.
    If I purchase a new OMEGA 2+ with INDIEGOGO, do you know how long it would take before I would get a new one.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.