We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Error with exroot with pivot-root

  • I followed the instructions here: https://wiki.onion.io/Tutorials/Using-USB-Storage-as-Rootfs
    I started step 2 and plugged in my usb storage device and the omega recognized it and installed /dev/sda
    I then followed the next step of the instructions:
    mkdir /mnt/sda1
    mount /dev/sda1 /mnt/sda1
    Then it just stopped saying that the disk was full. My USB storage device is a 256GB ADATA 2.5" SATA to USB drive.

    I turned off the omega and turned it back on but now it wont load (amber light stays flashing). When I connect it to my laptop these are the last few line I see in the console:

    /etc/preinit: line 1: cat: not found
    /etc/preinit: line 1: cat: not found
    /etc/preinit: line 1: grep: not found
    [   81.880000] random: nonblocking pool is initialized

    The amber light never comes solid. My questions are:
    How can I reset my omega?
    In my description above...should I have chosen sda or sda2 ? what does it mean that in my case it installed 3 sda instead of just sda1 like in the example?
    Is my usb storage drive compatible?

    If anyone can help it it will be greatly appreciated!

  • @Didier-Dorelien To reset the Omega you simply need to hold down on the reset button for about 30 seconds. It should reset it back to the default firmware you have installed.

    The reason that it installs two partitions (/dev/sda1 and /dev/sda2) is that your drive was partitioned into two virtual disks. Did you format your drive to ext4?

  • @Boken-Lin I held the reset button down for at least a min and nothing happens....same error when i try to restart it. I tried a different dock but same thing. I'm assuming the reset button is the one next to the power switch on the main expansion board. Is there another way to reset to factory defaults? I tried multiple times and it's not reseting.
    I also didn't format the drive to ext4...are there instructions on how to do that?

  • @Didier-Dorelien Oh shoot... If you tried to do pivot-root without formatting the drive to ext4, then the drive won't be able to read the content of your drive, and therefore it restarts. The only way to restore the Omega now would be to use Ethernet expansion to reflash the flash memory. Do you happen to order an ethernet expansion?

  • @Boken-Lin Yes I do happen to have an Ethernet expansion. Please let me know what to do in order to make it work + format my drive to ext4.

  • @Didier-Dorelien Please take a look at our tutorial here: https://wiki.onion.io/Tutorials/Reflash-The-Firmware-With-Ethernet-Expansion. To format the drive in ext4, you will need another computer running Linux. Plug the USB key to the computer, and run the following commands:

    sudo umount /dev/sda1
    sudo mkfs.ext4 /dev/sda1

    This will put your /dev/sda1 into ext4.

  • @Boken-Lin I followed the instruction to de-brick the omega and I got to the end of step 5 where I successfully connected the omega to my MAC's ethernet port and I got the message that the http server is ready at The problem is that when I go to nothing happens. It says unable to access network.
    Regarding ext4 formatting...do I need a linux machine? Can I do it from a MAC or using a VM?

  • @Didier-Dorelien You need to disconnect your other networks. I.e., disable your Wifi while doing the re-flashing procedure. Most routers set their own subnet to 192.168.1.*, so to get the computer to recognize the Omega, you should turn these interfaces off.

    For formatting in ext4, you should can use a VM on a mac.

  • @Boken-Lin Ok I'll try that. Thanks for the help!

  • @Didier-Dorelien No problem! Please let me know if it works or if you have any other questions.

Looks like your connection to Community was lost, please wait while we try to reconnect.