We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Cannot satisfy dependencies for kmod-usb-net-rndis

  • I am connecting a Huawei ME906s modem to the Omega 2+ but the usb0 did not show up.

    I uncommented the lede repos in /etc/opkg/distfeeds.conf, ran opkg update, tried to install kmod-usb-net-rndis but got the following error messages:

    Collected errors:

    • satisfy_dependencies_for: Cannot satisfy the following dependencies for kmod-usb-net-rndis:
    • kernel (= 4.9.37-1-03997cbe2f6251de7784529eabe01f20) * kernel (= 4.9.37-1-03997cbe2f6251de7784529eabe01f20) * kernel (= 4.9.37-1-03997cbe2f6251de7784529eabe01f20) * kernel (= 4.9.37-1-03997cbe2f6251de7784529eabe01f20) *

    I ran uname -r and got kernel version 4.4.46.

    Does it mean the kmod-usb-net-rndis module is not available for the 4.4.46 version? What can I do to install the package?

  • This is a known issue if you search the forums. kmods cannot be installed on Onion firmware as Onion has not published sources, except for a few kmods they have compiled themselves.

    If you want to install other kmods you need to install a stock LEDE firmware (or the customized one from WereCatf). The problem there is that WiFi driver is still being developed resulting in slowness and reliability issues.

  • Please update us when solving the issue. I am facing the same problem too!

  • I just ran into the same problem when following the instructions to format an external sd card. Kind of strange they would provide the instructions on how to install when its not available.

  • @Michael-Smorto please refer to http://community.onion.io/topic/2252/cant-install-kmod-usb-storage-extras to see the Updates on what I am doing to solve it and update us when you fix this please.

  • Since I am running on Widows 10 laptop I found a simple work around to formatting the SD card to ext4. I found a link in a post to a Windows tool called Mini Tool Partition Wizard. Its a free download for personal use. I formatted the SD card to ext4 using this tool and the rest of the instructions worked. Only problem i had was with vi. Seems a little flaky. Used the edited in the Windows console and that fixed that problem. Seemed a lot easier approach than changing build options etc.

  • I am also interested in installing rndis.
    In the repository there are older versions of the kernel modules for the current kernel but they didn't work for me yet, some of them loaded correctly but something always fails so far. You can try to install them with - -
    I also tried to compile my own firmware but since that is just lede without the onion customizations this is not really what I want to use.
    Maybe the current packages where built for the firmware version 163? It seems that there where 161-163 versions available but they where very unstable. Maybe they deleted them but the compiled packages staid in their repository?

    If I have more time I will try again to get the older packages from the repositories working. You can open the onion core repository in a browser to see the different versions from the packages and then search for them with ctrl+f. The installated opkg version doesn't seem to support installing different versions.
    As a hint: opkg install with url did also not work for me, Wget + opkg install package.ipk did work and most modules even loaded. I got the virtual CD drive listed in dmesg after installing some kernel modules which wasn't the case before but I didn't get rndis to work.

    I even tried to upgrade everything including the kernel but that resulted in more Lede stuff, the onion repositories where replaced by Lede repositories and the banner also was the Lede one (I only used omega repositories). I also got even more depency errors. The Kernel didn't seem to be upgradable since it stayed at the old version.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.