We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Onion doesn't keep installed software after reboot

  • Hi,
    I am using the Onion2+,
    firmware version 0.1.10 b160,
    and an Arduino dock.

    I installed python and it worked fine, but after rebooting the device
    python is not found, this is true also for other stuff like the onion-console-base
    so after rebooting, i get this directory list screen ­čś×
    tried to use 'halt' command before rebooting as was suggested here for another problem,
    but halt does not seem to do any thing,
    also tried halt -f, with no success

    please help
    Thank you

  • It's true that halt doesn't work, even with the -f option. But you don't need it. I think the problem is that your Omega is using tmpfs storage instead of flash storage on the device. I think a reset will fix this issue.

    Can you show the output of the command:

    df -h

  • that's df -h output:
    Filesystem Size Used Available Use% Mounted on
    /dev/root 5.5M 5.5M 0 100% /rom
    tmpfs 61.4M 76.0K 61.3M 0% /tmp
    /dev/mtdblock6 25.1M 816.0K 24.3M 3% /overlay
    overlayfs:/overlay 25.1M 816.0K 24.3M 3% /
    tmpfs 512.0K 0 512.0K 0% /dev

    how do i do the rest?

    thank you

  • @Michael-Lustig
    df output of an Omega2+ 0.1.10-b160 in factory clean state after Factory Reset:

    root@Omega-5BE1:~# df
    Filesystem           1K-blocks      Used Available Use% Mounted on
    /dev/root                 5632      5632         0 100% /rom
    tmpfs                    62872        84     62788   0% /tmp
    /dev/mtdblock6           25664       764     24900   3% /overlay
    overlayfs:/overlay       25664       764     24900   3% /
    tmpfs                      512         0       512   0% /dev
    root@Omega-5BE1:~# df -h
    Filesystem                Size      Used Available Use% Mounted on
    /dev/root                 5.5M      5.5M         0 100% /rom
    tmpfs                    61.4M     84.0K     61.3M   0% /tmp
    /dev/mtdblock6           25.1M    764.0K     24.3M   3% /overlay
    overlayfs:/overlay       25.1M    764.0K     24.3M   3% /
    tmpfs                   512.0K         0    512.0K   0% /dev

    Maybe you performed a factory reset/restore accidentally by a too long Reset press.
    You should repeat the First Time Setup and install the previously installed package(s) again.

    Good luck!

  • @Michael-Lustig Mh it looks clean. Like @Gy├Ârgy-Farkas said, maybe you have accidentally triggered a reset.

  • @Gy├Ârgy-Farkas

    Seems we are finally there, thank you,
    but it wasn't an easy ride,
    I did the factory reset,
    and then in the console it did wifisetup,
    it found my network but did not connect,
    in the omega-xxxx.local/ i got again the annoying directory listing,
    so i downloaded the latest image file copied to the onion and did 'sysupgrade -n'
    and this did the trick, at least for now ­čÖé

    thanks again

  • @Michael-Lustig I am also facing the similar issue with my Omega2,
    Will be doing the same steps as you did and see if the issue resolves for me. Thanks for a detailed solution

  • I had similar issues with files and installed software not persisting after reboots (which I had to do by manually pulling the power since the reboot command was ignored). After disabling the wifimanager my issue went away

    /etc/init.d/wifimanager stop
    /etc/init.d/wifimanager disable

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.