We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

power dock 2 not charging

  • I have a power dock 2 and a 3.7v 1800mAh battery connected to said power dock. When I insert the micro usb the battery level lights go all green for a brief moment and then off. I left it charging all night. The battery won't charge. Any ideas? Maybe recommend battery part #?
    Every thing else works.

  • What is the Amp rating of your power source? Perhaps it is insufficient to both power the Omega2 and charge the battery simultaneously?

    I have a 2000mAh battery connected and have noticed on my power dock2 that the charge lights do not illuminate when I connect a 500mA charger, even though the Omega2+ is still running (amber led is on). However the charge lights light up fine and show different charging stages when I connect my 2A charger.

    In their docs, Onion recommend a minimum 500mA power supply to power just the Omega2, so it may well be that a more powerful charger is required for the Power Docks when a battery is attached. They don't say this is so, but I have seen some odd behaviour when I have the battery + the 500mA charger connected, but I'm also doing some powering on & off of the radio so I can't yet isolate my odd behaviour to the charger power with any certainty, but I do have my suspicions...

    You might try removing the Omega2 from the dock (or powering it off?) and then try charging the battery on its own.

    Of course it could just be that your battery is faulty. Is it showing any signs of swelling? If so, you should dispose of it safely. Are you certain it's a LiPo (may be a dumb question, but you never know šŸ˜‰ )?

    Did the battery come with a charger of its own and if so, have you tried charging the battery using that?

  • I have the omega2+ turned off. It's a brand new battery. I guess I'll try and get another battery.

  • I had a similar problem, the battery would not charge at all. It worked fine until I drained the battery completely, after that the power dock would no longer charge the battery. Just as a quick experiment I connected the battery to one of my adafruit feather boards and let it charge the battery for 15 minutes, after this it worked fine again and was charged by the power dock.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.