We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

What is the stable firmware version for omega2?

  • I installed the latest version 0.1.10-b160 via usb flash drive. But it has lots of bugs, I can’t to execute oupgrade and opkg update, always getting the problem something like “cannot connect to repo.onion.io”. wget brings the problem too with some library, always stucked in “segmentation failed” error (use console for logging). Tried previous version the same problems. Wifi is set, can ping some web sites and connect via ssh

  • @Ilya-Mordasov b160 is pretty much the most recent and stable firmware available to the general public, unless you can work out how to successfully build your own firmware, or convince Onion to build a newer one for you.

    All my O2+'s are on that revision and I have not observed any problems executing oupgrade/opkg update.

    Possibly you have a buggy device?

    I'd suggest that you open a ticket with Onion on their helpdesk and see if they can help you there. Posting here is unlikely to get their attention.

    If you do resolve it via the helpdesk, please do help the community by posting some feedback here. The helpdesk is a closed loop between Onion and customer and we do not learn anything here from problems that are resolved there unless customer's provide us with feedback on their experiences.

  • Thanks for your reply. I thought the same that 0.1.10 is more stable that previous, looked at changelog. But at first, I stucked in issue when I have to set internet connection via browser. Not always I see my ssid in the available networks list and usually type it manually. Even after that when I’m pressing configure it can freeze in this half-state. I’d prefer to set it using wifisetup over ssh or console.

    Also I tried to use lede repos instead of onion’s, but with it I got error relocating errors for wget and missed libencrypt.so

    Traceroute shows that I have access to the internet.

    But to be honest, I use my own extension board, but I’m not sure this is the reason. If I had the problem with it my o2 wouldn’t work. And o2 gets 3.3v of power and enough current

    Yep, I created ticket on onion’s helpdesk and sent them logs.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.