We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

1 wire temperature sensor not connecting

  • I've followed the tutorial, and can get a connection for maybe 1 minute before it drops out again. Shows 00-e00000000000 or similar as device id (different each time). I have 4 * 1k ohm resistors in a line on the breadboard. Could incorrect resistor value be causing this ? But then I put a single 10k resistor on board, with same result.

    Just using the command line terminal and sensor on gpio 19 (https://docs.onion.io/omega2-docs/communicating-with-1w-devices.html)

    Any idea of the problem here ?

  • @Neil-Stelling Which dock are you using?
    The original power-dock has a GND pin where the expansion dock and power-dock2 have a GPIO19.

    Otherwise, perhaps a photo of the setup might give a clue?

  • Expansion dock. Tried it on Pin 1 with same result. A ghost detection of sensor at 00-e0000000000 or similar, followed by disappearance a minute later.


  • @Neil-Stelling I think I see your problem, flip the sensor around so that the flat side faces away from the resistor and jumper wires. When looking at the flat side, the LHS pin is GND.

  • Flipped it over, but similar result. Shows either 2 or 3 devices, even though one plugged in...

    Could the wrong resistor cause this ? I think I have 10k in that picture, but have also tries 4 * 1k lined up together. Don't have a 4k7


  • @Neil-Stelling
    Hmm, not sure if 10k is too much. The project book says "We used 5.1k but anything between 4 and 6k will work just as well." I think 4 x 1k in series would fall within those boundaries.
    I suspect I used a 1k when I played with this, but don't recall that 100%. No, I just checked and it was a 5.1k.

    Is your f/w above b151? Docs say "Note that you need to be on firmware b151 or higher!".

    Also, the docs reference "/sys/devices/w1_bus_master1" - note the 1 on the end, which differs from your directory.

    Have you worked through the docs at: Communicating with One-Wire Devices?

  • Now it won't even restart unless I pull out the wires ! I put 4 * 1k resistors in a row. It is master1 (pic cutoff last digit)

    Yes, I have worked thro the docs.

    The omega seemed to have great potential. But my first impressions are that it is too bug-ridden to be fit for any commercial purpose. Am I wrong ?

  • @Neil-Stelling
    No, I don't think it is too bug ridden. šŸ˜‰ There are things that work quite well, but some items just need special attention. One of which you just found out.

    Using GPIO1 will interfere with the boot process: Important & Special GPIOs

    I'd suggest going back to the 4 x 1k in series, but switch to using GPIO19. After that, if everything else looks right, then perhaps your sensor is faulty? Swap it out if you can, otherwise try something else like the DHT22 if you have one. Note: it uses one pin for humidity and temp, but is not one-wire protocol compatible.

  • Gave it one more try, going back to gpio19 with 4 * 1k in series, and.... it worked !! Thanks for all your help. Still also looking at the Raspberry Pi zero w , but do like this Omega if it works properly where needed. Now will progress with getting the temperature readings into the cloud...

  • @Neil-Stelling Cool, enjoy. šŸ˜„

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.