We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ ZeroMQ

  • Dear Onioneers!

    I just got 10 new Omegas2 for my project šŸ˜„ I am beginner, but I am following tutorials and project vol 1 and my knowledge increases. But, there is a limit to how much one can learn this way and now I need your guidance.

    I have to implement ZeroMQ message broker. I found link on onion git:

    There is Makefile file and patch file.
    I downloaded them on one of my almost fresh Omegas (to /root/zeromq/).
    make Makefile gave me error:
    make: not found
    (face into the wall).

    Ok, so I thought that make is from gcc, so I tried to install gcc. After extending my space:
    https://docs.onion.io/omega2-docs/using-a-microsd-card.html +
    i installed gcc, make and debugger and make example project compilation in C, it worked fine.

    Now, make Makefile gives me something like that:
    Makefile:31: /package.mk: No such file or directory
    make: *** No rule to make target '/package.mk'. Stop.

    I opened in Nano this Makefile. This error references to this:
    include $(INCLUDE_DIR)/package.mk

    As I see correctly, my Omega does not know what is $(INCLUDE_DIR) or INCLUDE_DIR or what should it be.

    I only installed python (with pySerial, minimalModbus and pip), nano, gcc, git and some packages for microSD.

    Do I miss something important? Or maybe I did something wrong?
    Could anyone send me some directions, what to do? šŸ™‚

    Best regards,

Looks like your connection to Community was lost, please wait while we try to reconnect.