We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

routing table won't change



  • I'm using device firmware 0.2.0 b192

    route -n shows
    Destination Gateway Genmask Flags Metric Ref Use Iface
    193.0.1.0 0.0.0.0 255.255.255.0 U 0 0 0 apcli0
    no internet

    so i did a:
    route add default gw 193.0.1.39
    and wala it works
    obviously this only fixes it up to the next reboot.

    i have tried the following network config file:
    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd1d:48c4:7633::/48'

    config interface 'wwan'
    option ifname 'apcli0'
    option proto 'static'
    option ipaddr '193.0.1.144'
    option netmask '255.255.255.0'
    option dns '193.0.1.93'
    option gateway '193.0.1.39'

    How do I make the route add perminent????



  • I guess put it in rc.local and call it a day. It'd be nice if onion would fix it.



  • @steve-burk I like Steve's suggestion for your own problem as it will absolutely work, but in the hope of making things needlessly complex, this is what I'd do:

    1. Create a shell script that is comprised of the commands you need to provision the route.
    2. In your installation script (you have one, don't you? ;^), check rc.local for a reference to the script. Insert a call to rc.local if it's not in there.
    3. Also in your install script, copy the route provisioning script to somewhere sensible, such as /usr/bin/. This directory is in the path and need not be "spelled out" in rc.local.

    Perhaps you could write a script that takes routes as a command line parameter. As such you could easily call the command multiple times from rc.local to configure multiple routes or perhaps better yet, pass along not a route but a config file path that contains the routes you desire. If the latter, you just mod the route config file and reboot - voila!

    If you're dabbling, this suggestion is overkill. If you're trending toward production, this is a bit more important and ought to be considered. Your mileage may vary.

    --Bill



Looks like your connection to Community was lost, please wait while we try to reconnect.