We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Can't access my Onion Omega2+ over Wifi

  • Can anyone here help me figure out how to resolve these issues?

    • I am only able to connect to the device via SSH when I'm connected to the Onion's Wifi hotspot.

    • I used to be able to access the Onion's web interface using it's unique hostname (ie: http://omega-XXXX.local/) .. but am now no longer able to do that. Now the only thing that works is using the IP address .. and I am only able to do so while I'm connected to the Onion's Wifi hotspot.

    -- Yvan

  • Run this command:

    root@Omega-FDF5:~# ifconfig
    apcli0    Link encap:Ethernet  HWaddr 42:A3:6B:00:FD:F5  
              inet addr:  Bcast:  Mask:
              inet6 addr: fe80::40a3:6bff:fe00:fdf5/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:7213843 errors:0 dropped:1169961 overruns:0 frame:0
              TX packets:3765474 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000 
              RX bytes:1338841957 (1.2 GiB)  TX bytes:254803958 (242.9 MiB)

    This will show network configuration info for several devices. I copy/pasted only through device 'apcli0', which coincidentally is the first to pop up in the output. There are several devices that follow that are not in this example.

    Note the second and third lines - they show IPv4 and IPv6 addresses and other parameters relevant to the protocol. You are interested in 'inet addr' (IPv4) and not the following line for IPv6.

    The IPv6 line will always be there. The prior IPv4 line is sometimes missing. The example shows a fully configured and connected IPv4 interface with IP=

    Do you have the IPv4 line?

    take care!

  • @Yvan-Gagnon As you have already known according to the official Onion Omega2 Documentation:

    Your computer may need some additional programs to access the Omega through a browser:

    • If you are using Windows, install Apple’s Bonjour Service
    • If you are using OS X, you’re all set to go
    • If you are using Linux, the Zeroconf services should already be installed and you will be good to go

    Please read the answers for this question How can I resolve .local addresses in Windows?
    and the 'Linked Qs & As' too.

    Good luck!

  • I too am having the same problem as Yvan. Have tried uninstalling and reinstalling Bonjour as suggested. Still not working

  • @Gary-Kenny; I can now access via host name (http://omega-XXXX.local/) but my Omega is not visible on the cloud via device manager.

  • William -- to answer your question -- yes -- I do see the IPv4 line when I run ifconfig via the command line while logged in via SSH.

    Good news -- I followed all of the instructions in this thread, and the device is now accessible via the hostname while I'm connected to my home Wifi network. I had to do all of the following:

    1. Uninstall Bonjour using Add/Remove programs
    2. Reboot the PC
    3. Add the registry entry that's described at the link that Gyorgy provided:
    4. Reboot the PC
    5. Download and Re-install the Bonjour print service:
    6. Reboot the PC

    After I followed all of these steps, I am now able to access the Onion's web interface (and also connect via SSH) while connected to my home's Wifi network.

    Thanks guys!

    • Yvan

  • @Gary-Kenny Device Manager is notoriously unreliable. The problem may very well (likely) not be at your end.


  • Here you are a simple, clear tutorial from Adafruit:
    Bonjour (Zeroconf) Networking for Windows and Linux >> Microsoft Windows

    iTunes installer https://www.apple.com/itunes/download/

    I've just helped one of my friends to install a part of 'iTunes' on a DELL N5010 notebook (Windows 10 Home x64).
    We downloaded the 'iTunes64Setup.exe' installer - unpacked it with Total Commander 7.55a - and installed only the 'Bonjour64.msi' file successfully.

    Windows 10 PC - PuTTY - Connection type: SSH - Host Name root@omega-xxxx.local or root@Omega-XXXX.local (not case sensitive) - it's an Omega2+ FW 0.2.0 b194.

    (It seems Bonjour64 works perfectly although I rarely use MS Windows.)

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.