We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

External wifi card with omega

  • @Boken-Lin -- Even after I was able to assign the ip address, broadcast, and netmask to the omega, it errors out when executing the following wget:

    wget https://raw.githubusercontent.com/OnionIoT/wifisetup/master/wifisetup.sh

    So I had to download manually through my Ubuntu VM, then transfer the two files via python SimpleHTTPServer.

    Here's the result of running wifisetup.sh:

     root@OpenWrt:/tmp2# ./wifisetup.sh
     Onion Omega Wifi Setup
     Select from the following:
     1) Scan for Wifi networks
     2) Type network info
     q) Exit
     Selection: 1
     Scanning for wifi networks...
     Command failed: Not found
     Failed to parse message data
     WARNING: Variable 'results' does not exist or is not an array/object
     ERROR: no networks detected... try again in a little while

    And here's the result of running oupgrade.sh (after running opkg update):

    root@OpenWrt:/tmp2# ./oupgrade.sh
    ./oupgrade.sh: .: line 4: can't open '/usr/lib/onion/lib.sh'

    If this issue persists, maybe I can help write up a tutorial on how to manually install the base/factory files into the omega without flashing (if that's even possible). It seems that there are some foundational files and folders/directories missing in the OpenWRT baseline that is in my omega.

    Not sure why even the factory reset is not working.

    If all else fails, can I send my omega back for replacement?

  • @Enrico-Bermudez That is quite weird. Are you sure you downloaded the firmware from http://repo.onion.io/omega/images/omega-v0.0.5-b258.bin? This firmware should have all the packages pre-installed.

  • @Boken-Lin -- I'm 100% sure. And after various attempts of sysupgrades from a new .bin file from my cross compile environmnt, my omega still wouldn't get flashed. Then my last flash of was actually a fresh image from the repo site: v0.0.5-b259.bin.

    After it went through the flash process, the LED on the omega turned off and it stayed off -- I assume the system just stopped. So I powercycled the dock using the on/off switch. I saw a lot of lines that generated the same errors that says "jffs2: jffs2_scan_eraseblock(): Magic bitmask 0x1985 not found at 0x00ea003c: 0x0f56 instead"

    See the final screen below:
    Screenshot from 2015-12-30 20:56:50.png

    It looks like there's finally a critical failure of some kind and the only thing I could get into at this point is the portion where I hit any key to stop the autobooting (I assume that the U-Boot for the Onion Omega.

  • @Enrico-Bermudez Oh no, seems like you unplugged the Omega when it is still reflashing, sometimes it can take quite a while to finish erasing the memory.

    Do you have an ethernet expansion to debrick the Omega?

  • Yes, I do. Not sure that's what happened...I left the omega for at least an hour while it was reflashing. But when I came back to it, the LED was off and nothing was happening on the screen.

  • @Enrico-Bermudez Do you have the console log while the Omega is flashing? It should output the status of the firmware upgrade.

  • @Boken-Lin -- I wish I took a snapshot of the log. I didn't, unfortunately. I just remember that when I finally got back to my setup, the omega's orange light was completely off, and the screen was either blanked out or just frozen. (Normally, after a reflash and reboot, I have to hit carriage return to get back to the omega's terminal prompt....but this time, it didn't do anything and the omega was completely off.)

    Any estimate on when that tutorial to un-brick the omega will come out?

    Thanks for your responsiveness!

  • @Boken-Lin -- It worked!
    Interesting event though after I reflashed the omega. I downloaded another image in a folder on the root directory...and forgetting that I didn't expand the rootfs with pivot-overlay, I filled up the storage. When I rebooted the omega and went back to delete the .bin image file, it kept telling me that it's a read-only file system and that I can't delete any file or folder. Even with a "rm -rf <directory_name>", the omega kept telling me that the file system is read only.
    I fixed it by pressing the factory reset button -- which is also a good test that it's now working again.

    Thanks for helping me through this issue. I learned so much from this event.

  • @Enrico-Bermudez Awesome! Do wifisetup and oupgrade work now as well?

  • @Boken-Lin -- Yes, both oupgrade and wifisetup work. One minor thing on oupgrade: It rightfully identified that b259 is in the device, but it says the latest firmware is b251 -- and that I have the latest firmware anyway.

  • @Enrico-Bermudez That's because b259 is a development release. b251 is still the latest stable release.

  • @Boken-Lin Oh I see.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.