We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Can't Connect to Wifi

  • Hey guys,

    My omega can't seem to connect to the wifi. When I try to use the web setup it always states "Unable to connect to SSID please try again", then when I try again it stays stagnant. I tried connecting by SSH but all I get is the following:

    Network: SSID
    Authentication type: WPA2PSK
    Enter Password: "password"

    restarting wifi manager for changes to take effect

    It boots me out of SSH and then nothing happens. No internet connection.

    At first I thought it was my omega, since I had it for a long time sitting in on a shelf, so I bought another one. The new one also had the same issue. I tried using a mobile hotspot on my phone, and it worked once, but it got stuck at the firmware upgrade and when I power cycled, it no longer wanted to connect.

    I've tried to go through all the forums but nothing seems to work.

    Do you guys have any suggestions?

  • Do you have either an Expansion Dock or Breadboard Dock? If so you can connect to serial port 0 and the command line.

    Using an Expansion Dock is trivial as you cable up from a computer USB port to the Micro-USB-B connector on the dock. I'll provide additional config info if you'd go down that path.

    Use of the Breadboard Dock is more involved as you'd need a USB-to-LVTTL serial converter.


  • I have been using the expansion dock. So far I've been using SSH to connect to the Omega.

  • @Manny-Rodriguez I have a sneaking suspicion what this is. You were executing an upgrade from 0.1.6(??) to 0.2.??. Well, the MAC addresses changed across that upgrade. If that would be an issue for you (I can't tell yet by the explanation so far) then you'd need to determine the new MAC address and use it appropriately. I'll elaborate later if we determined that would help.

    A sure fire way to fix this is run wifisetup again, but you'll need to get inside the device via the serial console accessible via the aforementioned USB port.

    take care!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.