We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

My IPFS Journey

  • Hi All,

    I have been trying to get IPFS (the JavaScript implementation of IPFS, JS-IPFS) running on my Omega2+, just to see if I could do it.

    I have reached a point where I could use some advice. Note: I have pretty much no idea what I am doing.

    I tried to just install it (the project is here: https://github.com/ipfs/js-ipfs) with npm.

    First issue: out of memory:

    [ 709.942633] Out of memory: Kill process 1648 (npm) score 504 or sacrifice child

    So I made a swap file so I could continue the install, and I had success, sort of:

    root@Omega-6CD5:/# npm install ipfs --global
    WARN engine ipfs@0.33.1: wanted: {"node":">=6.0.0","npm":">=3.0.0"} (current: {"node":"4.3.1","npm":"2.14.12"})

    OK, so apparently js-ipfs needs nodejs of 6 or higher, and an updated npm as well.

    This is where I really don't know what I am doing. I figured I would follow instructions on cross-compiling and make a binary of a newer nodejs myself. I am using a Mac, so I installed Docker, and pulled the omega2-source, but when I ran "make" I got this:

    make -r world: build failed. Please re-run make with -j1 V=s to see what's going on
    /root/source/include/toplevel.mk:198: recipe for target 'world' failed
    make: *** [world] Error 1

    So, now I have no idea what to do next. If I understand correctly, I need to complete this step before I can attempt to cross-compile newer versions of nodejs and npm. At this point I am just following instructions I have found on the web like a trained monkey.

Looks like your connection to Community was lost, please wait while we try to reconnect.