We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Unable to communicate with omega 2+

  • I'm using omega 2+ with Arduino dock, I cannot see the access point of omega , i tried to connect it with putty but it failed to show up however the led status was solid. pls help. Thanks in advance.

  • @mallareddy-mettu Can you describe your process? Provide a URL if you are following the O2+ instructions for bringing up a unit.


  • @William-Scott I followed the omega 2+ manual as provided. I tried to communicate with omega via command line but silicon labs cp210x shows error "code 10: device cannot be started"

  • @mallareddy-mettu Although you have a real issue with cp210x, I suggest a different approach to resolve your O2+ connection issue. Use a laptop or other mobile device to search for available WiFi networks. Connect to the WiFi network with SSID the same name as your device. This will indeed be the access point WiFi network. The use some tool (I use PuTTy on Windows) to ssh into your device at the well published IP, user name and password. This approach won't use the extra software needed to follow the published approach and therefore is "likely" less error prone.

    Back to the cp210x issue....no clue. I'd try to uninstall and install new and give it another go. Otherwise copy/paste the verbatim error message to a web search engine.

    I hope this helps!

  • @mallareddy-mettu There is no CP2102 USB-to-Serial chip on the Arduino Dock 2.

    Can you see your Omega-ABCD among the WiFi APs on your PC?
    Connect to the Omega’s WiFi Network - the default password is: 12345678
    Official Onion Omega2 Documentation SSH on a Windows Device
    PuTTY 'Host Name (or IP address)'
    root@omega-ABCD.local or root@ - the default password is: onioneer

    Do you have a CP2102 USB-to-Serial module / cable and want to communicate with your Omega2 via serial line?
    Connect it to your PC, run PuTTY, select Serial connection and fill in the appropriate serial port info.
    First of all try to do a simple loopback test: connect TX to RX and type something. Can you see the typed characters on the screen?
    If your PuTTY Configuration is correct then this is definitely not an Omega2 problem. It can be some CP2102 Windows driver issue, maybe you have a fake CP2102 chip, etc. (Google is your friend 😉

    Good luck!

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.