We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2 Pro Upgrade Issue

  • Dear all. When I tried to upgrade my very own Omega2Pro the following error occurs:
    { "upgrade": true, "build_mismatch": false, "image": { "binary": "omega2pro-v0.3.1-b211.bin", "url": "http://repo.onioniot.com/omega2/images/omega2pro-v0.3.1-b211.bin", "local": "/tmp/omega2pro-v0.3.1-b211.bin", "size": "9699511" }, "device": { "version": "0.3.0", "major": 0, "minor": 3, "revision": 0, "build": 204 }, "repo": { "version": "0.3.1", "major": 0, "minor": 3, "revision": 1, "build": 211 } }
    /usr/bin/oupgrade: local: line 378: not in a function
    I m not able to update the formware. Any ideas? by the way, when will the update documentation for the pro avalable?


  • Solution provided in this post: Error when setting up Omega2 Pro [with solution] 7 days ago by Emma Humphries worked for me.

  • correct already solved thanks.....

  • This solution did not fix the problem in my case.
    The problem was that there was an extra line "379" which must have had one of those un-allowed line endings or the carriage return on line "378". This was causing the /usr/bin/oupgrade: local: line 378: not in a function error.
    Deleted the extra blank line and all was fixed.

Looks like your connection to Community was lost, please wait while we try to reconnect.