We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Help with mqtt and AWS

  • Following the advice here:

    I have the certificate, policy and end point defined I believe correctly.

    I did the setup step and copied the certificate and private key files to the Omega2+.

    I run:
    mosquitto_pub -t $aws/things/Omega-1F93/shadow/update -m '{"state": {"desired": {"temperature": 1 }}}' -q 1

    But the shadow properties do not get updated.

    There is no error. If I add the -d option to the mosquitto_pub command I see:

    Client mosqpub|4788-Omega-1F93 sending CONNECT
    Client mosqpub|4788-Omega-1F93 received CONNACK (0)
    Client mosqpub|4788-Omega-1F93 sending PUBLISH (d0, q1, r0, m1, '$aws/things/Omega-1F93/shadow/update', ... (43 bytes))
    Client mosqpub|4788-Omega-1F93 received PUBACK (Mid: 1)
    Client mosqpub|4788-Omega-1F93 sending DISCONNECT

    Do I need to start over because I have updated the firmware on the Omega 2+.?

    I am using certificate and policy files from Feb. 2018 when this guide worked for me.

    Suggestions appreciated.

  • Found the answer in another thread started at the end of January 2019 from @Francisco-Suarez

    Replace the current obsolete root CA file.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.