We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Boto3 python3 fail

  • I'm trying to use pip3 to install boto3 to my omega2+ however I'm getting the following install error from pip3 when trying to install the package.

    I have installed python3-light package no problems. Other packages I needed so far have installed no problem just seem to be hitting a roadblock with getting boto3 to install. Has anyone got boto3 to work on their omega2?

    pip3 install boto3
    Collecting boto3
    Using cached https://files.pythonhosted.org/packages/c7/b1/34db0f2db2d4f54e278ae32cb563aa4e278b1dd62a55672d691a3ceab4e9/boto3-1.9.219-py2.py3-none-any.whl
    Collecting jmespath<1.0.0,>=0.7.1 (from boto3)
    Using cached https://files.pythonhosted.org/packages/83/94/7179c3832a6d45b266ddb2aac329e101367fbdb11f425f13771d27f225bb/jmespath-0.9.4-py2.py3-none-any.whl
    Collecting botocore<1.13.0,>=1.12.219 (from boto3)
    Traceback (most recent call last):
    File "/usr/lib/python3.6/site-packages/pip/basecommand.py", line 214, in main
    status = self.run(options, args)
    File "/usr/lib/python3.6/site-packages/pip/commands/install.py", line 299, in run
    File "/usr/lib/python3.6/site-packages/pip/req/req_set.py", line 370, in prepare_files
    File "/usr/lib/python3.6/site-packages/pip/req/req_set.py", line 587, in _prepare_file
    session=self.session, hashes=hashes)
    File "/usr/lib/python3.6/site-packages/pip/download.py", line 810, in unpack_url
    File "/usr/lib/python3.6/site-packages/pip/download.py", line 649, in unpack_http_url
    File "/usr/lib/python3.6/site-packages/pip/download.py", line 842, in _download_http_url
    File "/usr/lib/python3.6/site-packages/pip/_vendor/requests/sessions.py", line 487, in get
    return self.request('GET', url, **kwargs)
    File "/usr/lib/python3.6/site-packages/pip/download.py", line 378, in request
    return super(PipSession, self).request(method, url, *args, **kwargs)
    File "/usr/lib/python3.6/site-packages/pip/_vendor/requests/sessions.py", line 475, in request
    resp = self.send(prep, **send_kwargs)
    File "/usr/lib/python3.6/site-packages/pip/_vendor/requests/sessions.py", line 585, in send
    r = adapter.send(request, **kwargs)
    File "/usr/lib/python3.6/site-packages/pip/_vendor/cachecontrol/adapter.py", line 36, in send
    cached_response = self.controller.cached_request(request)
    File "/usr/lib/python3.6/site-packages/pip/_vendor/cachecontrol/controller.py", line 111, in cached_request
    resp = self.serializer.loads(request, cache_data)
    File "/usr/lib/python3.6/site-packages/pip/_vendor/cachecontrol/serialize.py", line 114, in loads
    return getattr(self, "_loads_v{0}".format(ver))(request, data)
    File "/usr/lib/python3.6/site-packages/pip/_vendor/cachecontrol/serialize.py", line 170, in _loads_v2
    cached = json.loads(zlib.decompress(data).decode("utf8"))
    zlib.error: Error -5 while decompressing data: incomplete or truncated stream


  • Out of the blue I tried again from home and it seemed to have worked...

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.