We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

/bin/ash: pip: not found

  • Hi, pip, python and so on are installed, but I can't use pip

    /# opkg list-installed | grep -i python
    python-pip-conf - 0.1-1
    python3 - 3.6.9-3
    python3-asyncio - 3.6.9-3
    python3-base - 3.6.9-3
    python3-cgi - 3.6.9-3
    python3-cgitb - 3.6.9-3
    python3-codecs - 3.6.9-3
    python3-ctypes - 3.6.9-3
    python3-dbm - 3.6.9-3
    python3-decimal - 3.6.9-3
    python3-distutils - 3.6.9-3
    python3-email - 3.6.9-3
    python3-gdbm - 3.6.9-3
    python3-light - 3.6.9-3
    python3-logging - 3.6.9-3
    python3-lzma - 3.6.9-3
    python3-multiprocessing - 3.6.9-3
    python3-ncurses - 3.6.9-3
    python3-openssl - 3.6.9-3
    python3-pip - 18.1-1
    python3-pydoc - 3.6.9-3
    python3-setuptools - 40.6.2-1
    python3-sqlite3 - 3.6.9-3
    python3-unittest - 3.6.9-3
    python3-xml - 3.6.9-3

    /# pip3 install virtualenv
    /bin/ash: pip3: not found

  • You have pip3 installed, but not pip. Use pip3 and you'll be good to go!


  • /# pip3 install virtualenv
    /bin/ash: pip3: not found

    :/# python3-pip install virtualenv
    /bin/ash: python3-pip: not found

  • As I press tab twice - pip3 and pip3.6 are in the list, but I still can't run them

  • pip3 is not working on Omega2 plus, pip3.6 as well. I don't know why. pip from python-pip package works fine.

  • @Doctor-Ulysses you can try opkg --force-reinstall pip3 this will usually fix a broken installation

  • @crispyoz opkg --force-reinstall python3-pip is not working

  • @Doctor-Ulysses what does it report? Does it seem to complete but pip still is not working? Does opkg report an error? Something else?

    You can also use opkg remove and then opkg install if you have an issue with a specific package.

    What does opkg info pip and opkg info pip3 report?

  • This is possibly a storage space problem. A bare bones O2+ doesn't have the storage space to accommodate python3, if I remember correctly(????). Run 'df -h' and 'free -h' to check on current mountings and free space, respectively.

    Has storage been upgraded?


  • @crispyoz It sends help page of opkg - the command is wrong. opkg info report nothing. I've already installed pip and it works. Thanks for your advice

  • @William-Scott
    Filesystem Size Used Available Use% Mounted on
    /dev/root 7.8M 7.8M 0 100% /rom
    tmpfs 61.0M 224.0K 60.8M 0% /tmp
    /dev/mmcblk0p1 14.5G 10.4G 3.3G 76% /overlay
    overlayfs:/overlay 14.5G 10.4G 3.3G 76% /
    tmpfs 512.0K 0 512.0K 0% /dev
    /dev/mmcblk0p1 14.5G 10.4G 3.3G 76% /mnt/mmcblk0p1
    /dev/mtdblock6 22.1M 740.0K 21.3M 3% /mnt/mtdblock6
    /dev/mtdblock7 512.0K 196.0K 316.0K 38% /mnt/mtdblock7

             total       used       free     shared    buffers     cached

    Mem: 124920 62028 62892 224 8664 28552
    -/+ buffers/cache: 24812 100108
    Swap: 0 0 0

    I'm getting fatal: write error: No space left on device while installing python packages for my program (with pip -v also) , even when I do have more than 3gb free memory on mounted sd card

    Even after I have deleted large folder - same "No space left" error.
    Filesystem Size Used Available Use% Mounted on
    /dev/root 7.8M 7.8M 0 100% /rom
    tmpfs 61.0M 284.0K 60.7M 0% /tmp
    /dev/mmcblk0p1 14.5G 599.4M 13.2G 4% /overlay
    overlayfs:/overlay 14.5G 599.4M 13.2G 4% /
    tmpfs 512.0K 0 512.0K 0% /dev
    /dev/mmcblk0p1 14.5G 599.4M 13.2G 4% /mnt/mmcblk0p1
    /dev/mtdblock6 22.1M 740.0K 21.3M 3% /mnt/mtdblock6
    /dev/mtdblock7 512.0K 196.0K 316.0K 38% /mnt/mtdblock7
    I'm booting from sd card, as it is written in tutorial btw. Maybe I should also use swap file?

  • @Doctor-Ulysses DEFINITELY add a swap file or create a partition for swap. Note the error message indicates running out of memory (RAM), not storage. You have plenty of storage. Converting 1g or 2G to swap would help immensely.

    Good luck.


  • So there is enough space now, but still there is same error with pip3. I have fully reinstalled python with deleting all the python files even from usr/lib folder - same ash error
    Was thinking, what pip disturbs pip3 and deleted everything what python is. After fresh installation of python3 and python3-pip - same error
    /# pip3 freeze
    /bin/ash: pip3: not found

  • @Doctor-Ulysses May be a silly question. You've created swap space presumably with a file. Is swap turned on? The 'free -h' command would tell you.


  • When starting with the O2+ in mid 2017 I discovered the shell was 'ash'. Had never heard of ash prior and quickly determined it was driving me crazy. As such I installed bash which many, many people have used for decades. It made me happier, but your mileage may vary.

    opkg update
    opkg install bash

    Then mod the /etc/passwd file to change 'ash' to 'bash'. The next time you log in you'll be running bash.

    The reason I pass this along is my murky recollection is that software installations were giving me fits with ash.


  • @William-Scott
    Swap: 2097148 23808 2073340

    sure it is on.

    So I have installed bash and changed passwd to

    still the same ash error

    after manually running bash and pip3 freeze after it i got
    bash: /usr/bin/pip3: /codebuild/output/src727/src/github.com/OnionIoT/source/staging_dir/hostpkg/bin/python3.6: bad interpreter: No such file or directory

    /# opkg install python3
    Package python3 (3.6.9-3) installed in root is up to date.
    /# opkg install python3-pip
    Package python3-pip (18.1-1) installed in root is up to date.

  • @William-Scott I think this is some Onion bug already

  • @Doctor-Ulysses Same 'ash' error or now a 'bash' error? If ash then a new login needs to occur to pick up the newly installed shell. I don't predict the new shell will fix the problems, but it sure gets some irritants out of the way.


  • @William-Scott

    @Doctor-Ulysses said in /bin/ash: pip: not found:

    bash: /usr/bin/pip3: /codebuild/output/src727/src/github.com/OnionIoT/source/staging_dir/hostpkg/bin/python3.6: bad interpreter: No such file or directory

Looks like your connection to Community was lost, please wait while we try to reconnect.