Omega2 LTE Wireless not working



  • Seems like the wifi has a problem on the Omega2LTE. I was finally able to get the wifi to work in a limited fashion by using the config files (network & wireless) from a working omega2 and changing the static IP and SSID.
    ssh never worked and ping(into) is as follows:
    64 bytes from 193.0.1.113: seq=313 ttl=64 time=479.438 ms
    64 bytes from 193.0.1.113: seq=649 ttl=64 time=1319.412 ms
    64 bytes from 193.0.1.113: seq=652 ttl=64 time=389.925 ms
    64 bytes from 193.0.1.113: seq=654 ttl=64 time=361.408 ms
    64 bytes from 193.0.1.113: seq=655 ttl=64 time=179.236 ms
    Omega2LTE ping(out):
    4 bytes from 193.0.1.203: seq=424 ttl=128 time=403.434 ms
    64 bytes from 193.0.1.203: seq=427 ttl=128 time=201.052 ms
    64 bytes from 193.0.1.203: seq=433 ttl=128 time=205.385 ms

    from a healthy omega2 ping(into):
    Reply from 193.0.1.147: bytes=32 time=17ms TTL=64
    Reply from 193.0.1.147: bytes=32 time=8ms TTL=64
    Reply from 193.0.1.147: bytes=32 time=5ms TTL=64
    from a healthy omega2 ping(out):
    64 bytes from 193.0.1.39: seq=2 ttl=64 time=10.286 ms
    64 bytes from 193.0.1.39: seq=3 ttl=64 time=33.200 ms
    64 bytes from 193.0.1.39: seq=4 ttl=64 time=94.230 ms
    64 bytes from 193.0.1.39: seq=5 ttl=64 time=24.188 ms
    wifi startup:
    oot@Omega-53E1:/mnt/mmcblk0p1/D7AD/config# wifi
    root@Omega-53E1:/mnt/mmcblk0p1/D7AD/config# [ 8806.901816]
    [ 8806.901816] _ _____ ___ ___ _________ ___ ____
    [ 8806.901816] | | /| / / _ | / _ / _ \ / / __ / _ / / V1.1
    [ 8806.901816] | |/ |/ / __ |/ , / / / // // / , / /
    [ 8806.901816] |
    /|
    /
    / |
    /
    /|
    // _/_//|/___/
    [ 8806.901816] Onion Enhanced MT7688 WiFi Driver
    [ 8806.901816]
    [ 8806.977516] DMA Scheduler Mode=0(LMAC)
    [ 8806.981392] efuse_probe: efuse = 10000012
    [ 8806.985507] 1. Phy Mode = 14
    [ 8807.157221] 2. Phy Mode = 14
    [ 8807.160233] 3. Phy Mode = 14
    [ 8807.163464] WTBL Segment 1 info:
    [ 8807.166828] MemBaseAddr/FID:0x28000/0
    [ 8807.170760] EntrySize/Cnt:32/128
    [ 8807.174210] WTBL Segment 2 info:
    [ 8807.177568] MemBaseAddr/FID:0x40000/0
    [ 8807.181477] EntrySize/Cnt:64/128
    [ 8807.184923] WTBL Segment 3 info:
    [ 8807.188279] MemBaseAddr/FID:0x42000/64
    [ 8807.192269] EntrySize/Cnt:64/128
    [ 8807.195726] WTBL Segment 4 info:
    [ 8807.199083] MemBaseAddr/FID:0x44000/128
    [ 8807.203156] EntrySize/Cnt:32/128
    [ 8817.295140] IPv6: ADDRCONF(NETDEV_UP): ra0: link is not ready
    [ 8817.301079] IPv6: ADDRCONF(NETDEV_CHANGE): ra0: link becomes ready
    [ 8854.309041] Interface apcli0 link up! (WPA2PSK AES)

    network and wireless file:
    root@Omega-53E1:/mnt/mmcblk0p1/D7AD/config# cat /etc/config/network

    config interface 'loopback'
    option ifname 'lo'
    option proto 'static'
    option ipaddr '127.0.0.1'
    option netmask '255.0.0.0'

    config globals 'globals'
    option ula_prefix 'fd1d:48c4:7633::/48'

    config interface 'wwan'
    option ifname 'apcli0'
    option proto 'static'
    option ipaddr '193.0.1.113'
    option netmask '255.255.255.0'
    option dns '193.0.1.93'
    option gw '193.0.1.39'
    option hostname 'Omega-53E1'

    root@Omega-53E1:/mnt/mmcblk0p1/D7AD/config# cat /etc/config/wireless

    config wifi-device 'radio0'
    option type 'ralink'
    option variant 'mt7628'
    option country 'US'
    option hwmode '11g'
    option htmode 'HT40'
    option channel 'auto'
    option disabled '0'
    option device_mode 'apsta'
    option op_mode 'preference'

    config wifi-iface 'ap'
    option device 'radio0'
    option mode 'ap'
    option network 'wlan'
    option ifname 'ra0'
    option encryption 'psk2'
    option key '12345678'
    option disabled '0'
    option ssid 'Omega-D7AD'

    config wifi-iface 'sta'
    option device 'radio0'
    option mode 'sta'
    option ifname 'apcli0'
    option encryption 'psk2'
    option network 'wwan'
    option disabled '0'
    option key 'Mp73939133'
    option ssid 'thebluebeaverE924'
    option led 'omega2:blue:wifi'

    config wifi-config
    option key 'Mp73939133'
    option ssid 'thebluebeaverE924'
    option encryption 'psk2'

    Any ideas on what the problem may be??????????????


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.