We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

No space for python-pip

  • Hi guys,
    All I need is python + python pip + rpyc, but it's not enough space even for this amount of software. In my case I can't USB storage so can I remove something to release some space by removing some kind of software? For example I don't need web server.

    Ω-ware: 0.0.5 b251

    root@Omega-282A:/# df -h
    Filesystem Size Used Available Use% Mounted on
    rootfs 8.1M 8.0M 136.0K 98% /
    /dev/root 6.8M 6.8M 0 100% /rom
    tmpfs 29.9M 84.0K 29.8M 0% /tmp
    /dev/mtdblock3 8.1M 8.0M 136.0K 98% /overlay
    overlayfs:/overlay 8.1M 8.0M 136.0K 98% /
    tmpfs 512.0K 0 512.0K 0% /dev

  • Just wondering why it is you can't use USB rootfs?

  • I'm working tiny device, no bigger than keychain. It's no space to fit dock inside.

  • Did you try python-light? I'm running ómega with python and a few bits and still 53% available.

  • @Pedro-Baco I would like to try it, but opkg remove python doesn't remove python ( so I can't try

  • Ok, so I did factory reset, then:
    opkg update
    opkg install python-light
    opkg install python-pip
    But still no luck, no space left and I can't continue

  • Hi @Vitalii-Topoliuk, How much space do you need in order to have what you require to run on the Omega and pip? The console is taking up quite a bit of space. So if you don't need the console, you can delete the /www directory and free up around 1.5M of space.

  • I think you need to try an avoid using python-pip unless you can get it to use a USB drive, @Vitalii-Topoliuk . if you're running out of space just installing python-pip, imagine how quickly you'll run out of space trying to install your python packages and all their dependencies on top of it.

    my bet would be on trying to use pure python scripts and upload a self-contained project that doesn't need installation or compilation. alternatively, I would try building it in a buildroot environment and transferring it to the omega with all the dependencies resolved.

    I've tried installing python-pip as well and ran out of space because it pulls in way too many dependencies. I wouldn't even know how to compute the space it's going to need, but i suspect it'll be much bigger than the available space on the omega, even with /www removed.

  • @Andrei-Railean thank you for your recommendation it makes sense and I will try when I will have more time. Also I tried to install python modules in old-scool way python setup.py install but there are was a lot of errors related read only file system. Unfortunately I'm out of my onion for now so can't paste output here.

  • @Andrei-Railean I have the same problem with nodejs. I have a USB stick, but when I try to install nodejs, I don't get a choice of where to put it, so the main storage fills up again.

    Can you please explain how to force installation of nodejs (and npm) to the usb


  • Just came here to see if anyone else was running our of room on the omega2 just by putting python-light on it and getting bumped when trying to add pip... I also tried python-base but needed to add to many dependencies for my application and even tried the setup.py from the package but it also required too many dependent packages so that also fell over and due to space required for other dependencies argh! I think the omega2 will find its useful place in the trash can tbh.

    omega2+ however so far works well because of the extra space.

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.