We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

How to Connect to the Omega’s Command Line

  • Hi
    I am on a Mac laptop running Mac Catalina
    The terminal provided by apple is updated to use zsh and no longer runs bash. When I entered the code given in the tutorial, it came back with:
    ssh: Could not resolve hostname omega-****.local: nodename nor servname provided, or not known
    I didn't get any other options.

    I also, can't see the omegas wifi network. I have completed the first time setup and could find it then. I also, couldn't connect my omega to the cloud.

    Help please

    Thank you

  • @Crazi-Tane Also, the **** is my omega code

  • @Crazi-Tane First time is always the toughest until it suddenly makes sense, so I'll give a simple explanation of the setup process.

    Omega Cloud is no longer in service because it is no longer required given the number of alternatives available so forget that.

    When you first plug in your Omega (which version do you have? 2, 2+, Pro?) the small orange LED flashes for a while as the device boots. Wait until it stops flashing then maybe a minute you should scan for the wifi SSID. Mac can take a while, I think it scans intermitently so you can speed things up by turning off wifi on your mac, wait maybe 30 seconds then turn wifi back on and wait until it finds your Omega's wifi. Once you are connected to the Omega's wifi you can ssh to Once you are connected to the console you can type ifconfig and look for the ip for the interface named apcli0, this is the ip assigned by your home wifi, so now you can connect your Mac back to your home wifi and ssh to that ip.

    Alternatively you can connect the USB to your mac and the other end to your Omega micro USB and use terminal app on your mac to connect to the Omega.

    Here is the link to the Omega doc which provides all the info you need on first time setup, resetting to factory, using the console etc. https://docs.onion.io/omega2-docs/

  • Thank you soo much crispyyoz.
    I will definitely try this and I am on omega 2+.
    Do I ssh to using the same syntax as I would have done ssh to the omega, so I would use ssh root@omega-
    Sorry, I am not very clever at this

    Thanks a ton

  • @Crazi-Tane First of all connect to Omega's WiFi Network (to Omega's Wifi AP: Omega-ABCD, default password 12345678) with your Mac.

    If the WiFi connection established you will be able to connect via ssh with one of these commands:
    ssh root@omega-ABCD.local or
    ssh root@
    The default password is: onioneer

  • @Crazi-Tane TThe reason i suggested to ssh to is because this requires not name lookup mechanism (DNS/Bonjour) we are just using the raw address. Then you should be prompted for a username (root) then you should be prompted for a password (onioneer).

    No need to apologise, we're all here to learn and share knowledge.

  • Thanks Gyorgy(sorry didn't have umlauts) and crispyyoz
    Unfortunately, I still can't find my omega's wifi signal. I have restarted my Mac, the wifi and the omega and none of these have worked.
    Crispyyoz, how can I use the terminal app to connect to omega if my Mac and the omega are connected by USB.
    Thanks a lot guys. I really appreciate all the help.

  • @Crazi-Tane
    From memory: when you connect via USB the computer should register the onion as a serial port.

    Just use the ssh as you would over a serial connection (? not familiar with the MAC way of doing this sorry).


  • @Crazi-Tane Your config: you have an Omega2+, its firmware unknown (and a host PC - a Mac).
    Do you have any Dock?

    boot, amber LED, etc.
    You can't find your Omega WiFi network - so most probably your Omega does not work at all.
    Please let us know what happens after Power On.

    You wrote previously:

    I also, can't see the omegas wifi network. I have completed the first time setup and could find it then.

    Do you remember what happened after?

    Serial Console
    Have you ever read the Documentation?
    Connecting via Serial -> Serial on a Mac Device

  • Gyorgy, I have an expansion dock. When I power it on, the orange light turns on and then starts flashing. After a while it stops flashing, so then I check the wifi and it isn't there.
    The first time, it took a bit longer to power on, but I found its wifi.

  • @Crazi-Tane I would try as factory reset then start again, I suspect you have got yourself tied in knots.

  • @Crazi-Tane Yes. Factory reset - long press the RESET BUTTON of Expansion Dock - is a good idea, give it a try.

    You wrote about the amber LED "... turns on and then starts flashing. After a while it stops flashing"
    And ... does it stay ON or OFF?

    Try to connect to the Serial Console. It's a very useful troubleshooting tool. Serial on a Mac Device

  • Thanks gyorgy, I will do both of the things that you suggested.
    The LED stays on.

  • @crispyoz Thanks crispyoz

  • Also guys, when I factory reset, will there be any thing to let me know that the omega has factory reset. Like a light or something?
    Thanks a lot

  • @Crazi-Tane when the Omega is performing a factory reset, the LED will flash rapidly while the restore of the factory firmware is being performed, then it will reboot and as it boots the LED will flicker as per a usual reboot process.

  • @Crazi-Tane The amber LED of your Omega2+ is ON - it's a good news.
    Press and hold down the RESET BUTTON as long as the LED starts blinking very quickly and hopefully it's performing a successful factory reset.
    After just over one (1) minute the amber LED remains ON and - a little bit later - you should find the Omega-ABCD WiFi AP.

    Good luck.

  • Thanks guys so much will try tonight

  • IT WORKED!!!!
    Thank you guys soo much for the help. I will try to send a little than you gift your way. 😉

  • @Crazi-Tane Good news!

Looks like your connection to Community was lost, please wait while we try to reconnect.