We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

No input over serial console [Solved]

  • Hi,

    I have an Omega2 Pro and I am trying to log into it through the serial console available in the USB port.

    I am using minicom, to access it from my main Linux computer and I can see the kernel booting messages and then a line telling me to press enter to activate the console, but it doesn't work. I don't get any output whatever I type.

    The configuration I am using is 8N1 at 115200 (that is the one that generates the right output, I have also tried others just in case the communication parameters were changed once the OS boots but without success).

    Is this the expected behavior? or should I consider some hardware problem between the USB-to-serial interface and the real serial port?

  • @Salvador-Fandiño Maybe your Minicom is misconfigured.

    press Ctrl-A O to get the [configuration] menu
    press Enter on Serial port setup
    press F to get F - Hardware Flow Control : No
    press Enter
    press Enter on Exit

    You should not press Enter when you see the 'Please press Enter to activate this console.' message.
    Be patient and press Enter only at the end of the boot process (ie. after the last message).
    For example this is the last message on my (well configured "fake") Omega2 Pro with v0.3.2 b233 FW:

    [   51.698617] Interface apcli0 link up! (WPA2PSK AES)

  • @György-Farkas , oh right, I forgot about hardware flow control... will try it once I get home.

    Thank you!

  • @György-Farkas you were right, hardware flow control was active and once I disabled it the console worked.

    Thanks again for your help!

Looks like your connection to Community was lost, please wait while we try to reconnect.