We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Editing/Updating the 'distfeeds.conf' file through Terminal.

  • @tjoseph1 I'm a software engineer so maybe one of the electronics gurus will pipe up on the best method. To my uneducated mind, it seems that all the hubs we tested didn't have enough juice to power each unit at peak consumption, which in my experience is when the wifi system comes up. I'm not sure what good any of the USB hubs with 10 and 12 ports actually are, if you plugged in multiple phones to charge them it'd take a month of Sundays.

  • @crispyoz :
    I am sorry, that I didn't mention "Powered USB Hub".. Only data goes to
    the computer. The supply to end devices is derived from an external PSU, connected to hub's power socket. I am using a 3A PS to feed power.

    If none of the hubs didn't have enough juice, that is scary. Have you happen to notice the peak consumption at the time of WiFi initialization by any chance?

  • @tjoseph1 I've not used an Omega2+ for a while, I am mainly using Omega2S+ on my custom board however Onion recommend 5v 2A, I am generally reading a maximum of 5v 2.1A

    But I did understand you were referring to USB hub with an external power supply, my experiences I referred to above were with USB hubs using external power supplies, the Omega is using the USB hub for both power and data.

  • @crispyoz :
    I would think we need a scope to see the ripples in the DC when the Wifi starts. That might be helpful to decide the corrective capactane for the custom board, I have in mind.

    Some powered USB hubs offer auto-chageover, ie, use PS power if one is present, use computer's USB power otherwise. I have returned a hub since the "auto" doesn't work, as expected.

    I have opened my crurrent hub and cut the two PS wires coming from the computer.

    The experience you shared is an eye opener..
    Thank you..

  • @tjoseph1 I'm anxiously awaiting your design šŸ™‚

  • @crispyoz :
    It is not me, my friend is into h/w design. He is running an IoT startup, does the h/w implementation side, including board design and product manufacturing, but not into programming. He is not familiar with Omega platform,well, so far.
    Btw, it's my job to program this.
    So, you know, I am concerned about both his as well my steps in this process.

  • @tjoseph1 I wish you and your colleague luck on this journey, it can be frustrating but if you have the attitude that every failure is an opportunity to learn, success is just around the corner. Share your knowledge and experience with the Omega community so we can all push each other forward.

  • @crispyoz :

    Thank you very much...!!
    The first thing is to get the stable power setup. Would try powering multiple Omegas from a single PS with the scope connected to DC. More than happy to share the experience.

  • @crispyoz :

    I tried with 3 omegas booting at the same time from an external PS feeding power to a powered USB hub. Only Omegas plus Docks (with their switches in ON position); nothing else. The "data" section of the hub is connected to a Linux workstation.

    All units were configured as STA, getting IP from a remote AP. (They all are APs themselves too, with IP

    I would pull the USB power-cable from the PS (the PS is always hot) and then insert is back. The other end of the cable is connected to the hub. Once the cable is inserted, all three would start booting. It takes a few seconds for ttyUSB0/1/2 to appear in the Linux system and their outputs to minicom.

    I did not notice any unit hanging.. Other than, sometimes one or two units would fail to acquire the IP address from the AP, may be because of the near simultaneous request?. Reconfigured the Omegas to acquire IP from different APs.

    No problems.. Also, used a lesser capacity PS (Apple A1400, rated 5V/1A).
    Still no problems..

    The USB power was about 5.12V under no load and 5.02V-4.99V under load.

    Pls see the video here:
    https://drive.google.com/file/d/1nrGuAQSY1XoJC86iTrtRMzCxPhrsQop3/view?usp=sharing (This is taken with the 1A PS)

    Appreciate any pointer to something that I missed..


  • @tjoseph1 I think best delete your post and make a new topic. Better for others.

  • @crispyoz :

    I had one incident where one Omega2+ failed to boot, hanging at WiFi. Added a new topic here:


    Thanks ..

Looks like your connection to Community was lost, please wait while we try to reconnect.