We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Cross Compiling on the Omega2

  • @MarshalllGG

    Sorry, I don't use docker either..

    To get to know compiling process in detail, would suggest the following book to anyone:
    Advanced C and C++ Compiling by Milan Stevanovic


  • @MarshalllGG Maybe you will find this easier if you use Apache Netbeans IDE, take a look at my article on setting up to use with the cross compiler:


  • @crispyoz
    Thank you,
    I'm trying to setup netbeans, but when I open 'tools' in the c/c++ I have a different screen:
    I Need to setup a ccls configuration (?)

    I tried Also a lot to crosscompile my c programs with the Onion's tutorial, but I noticed that also the c-cross-compile-example with gpioRead fails in compilation:

    makefile:9: recipe for target 'gpioRead' failed
    make *** [gpioRead] Error 127

    Do you know if cross compilation is the only method to use the OLED expansion C libraries?

  • @MarshalllGG I can't guess what your netbeans screen looks like so you need to post it.

    So we can see what the issue is with your cross-compiling post more of the output.

    My crystal ball is in the shop šŸ™‚

  • @crispyoz

    I'm sorry, here's my screen

    alt text

  • @MarshalllGG Looks like there is some problem with your plugin . Look in Tools Plugins and check you have the correct plugin installed per the attached screen.

  • Ye I found also this.

    Schermata del 2021-08-14 17-59-16.png

    In my netbeans I see this and then I search tools and I get the last screen I posted.

  • @MarshalllGG You need to activate "User Installed Plugins" it is currently inactive.

  • Okay @crispyoz thank you very much, I installed successfully Netbeans and seems to be working in the right way.
    I need some other tips also because it's the first time I use a tool like this (to compile simple programs I had only textedit and the terminal).

    Now I created my C project and in my source folder I have the main, for example a program to display "hello world" on the OLED screen of the omega.

    How can I link the oled C libraries in the cross-compilation with NetBeans? Do I have to download them or are stored in the usr/lib folder ?

    Thank you another time šŸ˜Š

  • @MarshalllGG Right click on your project, choose properties, then select Linker on the left and you can configure the path to your libraries in "Additional Library Directories" is you have the build system installed then this would be the path, source/staging_dir/target-mipsel_24kc_musl/usr/lib

    Then in the same screen "Libraries", then "Add Library File" and browse the file system to select source/staging_dir/target-mipsel_24kc_musl/usr/lib/libonionoledexp.so

  • @crispyoz

    Thank you I'm trying now but seems that the libonionoledexp isn't installed, this is the screen:
    Schermata del 2021-08-17 09-48-06.png

  • @MarshalllGG Take a look in make menuconfig and ensure you have selected Onion->Libraries->libonionoledexp, if it is not selected, select it then run make

  • Same problem
    Maybe do I need to compile another time the toolchain?

    Schermata del 2021-08-17 10-04-24.png
    Schermata del 2021-08-17 10-05-21.png

    also searching "oled" no matches found

  • @MarshalllGG From the main menu "Onion" then "Libraries"

  • @crispyoz
    Okay I did all these things and I tried to build the project:

    Schermata del 2021-08-17 16-07-49.png

    The libraries I included are:


  • @MarshalllGG In Project Properties, select "C Compiler" in the left side menu, then add to "include directories" source/staging_dir/target-mipsel_24kc_musl/usr/inlcude

  • Hey @crispyoz I'm sorry I didn't thanked you, now I'm using the Omega2+ for some projects with threads and semaphores and I wanted ask you how to add the flag -lpthread in linking (because I think it's for this that the run command gives me error in make)

  • @MarshalllGG Glad to see you are making progress. If you look at the attached screen shot, this is in the project properties and you can see I also have added pthread library to the link. Use the Add Standard Library Button


  • Oh thank you this works and it's very powerful! Thank you so much!

    I have just some other questions I hope you can ask...

    This NetBeans setup is the same as cross-compiling for omega? Means that I can run server programs binding to Omega's IP and the omega will run a tcp server?

    Another question, I tried all the combinations possible, but seems that the libonionoledexp.so can't work, I combined it with liboniondebug and libonion12c as it's suggested in documentation, and I also configured the project properties (now in compilation line the flags -l<lib> are added).. Did you use that library too?

  • @MarshalllGG The term "Cross Compiling" simply means that you are compiling on one system but the generated binary is targeted at a different system. Using Netbeans you are using the same compiler and linker as you would use if you are using the commandline compile and link steps. You can certainly develop an app that binds to a TCP port, some of my own apps run as Daemons/Services on Omega2S+ providing those services via TCP and UDP.

    You can certainly include libonionoledexp.so etc simply add them to the Libraries as you have done above with pthreads, just use the "Add Library" button instead and browse for the .so files. I recall I had an issue with this a couple of years ago but I don't recall what it was. Post your build log so I can look at it.

Looks like your connection to Community was lost, please wait while we try to reconnect.