Updated to 0.3.2 b218 two hours ago (Omega 2+). Problem remains. Additionally static ip network setup fails now. Worked with the delivery version.
Carst Dan
@Carst Dan
Best posts made by Carst Dan
Latest posts made by Carst Dan
-
RE: Wireless not working unless Ethernet cable plugged in
-
RE: Wireless not working unless Ethernet cable plugged in
This problem only occurs if the ethernet is plugged during the boot-up and is removed later. The wireless connection connection stops working at this moment.
If the ethernet cable is plugged after boot-up and is then removed, the wireless connection remains totally correct.
This seems to be a FIRMWARE-BUG.
-
Wireless not working unless Ethernet cable plugged in
Hi,
i am using ethernet and wifi station mode together. Unfortunately the wireless connection stops working if ethernet cable is unplugged.
Please have look at my network and firewall settings:root@Omega-DB4B:~# vim /etc/config/network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'config globals 'globals'
option ula_prefix 'fd1d:48c4:7633::/48'config interface 'wlan'
option type 'bridge'
option ifname 'eth0.1'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'config interface 'wan'
option ifname 'eth0'
option proto 'static'
option hostname 'OnionOmega'
option ipaddr '192.168.16.234'
option netmask '255.255.255.0'
option gateway '192.168.16.254'
option dns '192.168.16.254'config interface 'wwan'
option ifname 'apcli0'
option proto 'static'
option hostname 'OnionOmega'
option ipaddr '192.168.16.235'
option netmask '255.255.255.0'
option gateway '192.168.16.254'
option dns '192.168.16.254'root@Omega-DB4B:~# vim /etc/config/firewall
config defaults
option syn_flood '1'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'REJECT'
option disable_ipv6 '1'config zone
option name 'lan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option network 'wlan'config zone
option name 'wan'
list network 'wwan'
list network 'wan'
option input 'ACCEPT'
option output 'ACCEPT'
option forward 'ACCEPT'
option masq '1'
option mtu_fix '1'config forwarding
option src 'lan'
option dest 'wan'config rule
option name 'Allow-DHCP-Renew'
option src 'wan'
option proto 'udp'
option dest_port '68'
option target 'ACCEPT'
option family 'ipv4'config rule
option name 'Allow-Ping'
option src 'wan'
option proto 'icmp'
option icmp_type 'echo-request'
option family 'ipv4'
option target 'ACCEPT'config rule
option name 'Allow-IGMP'
option src 'wan'
option proto 'igmp'
option family 'ipv4'
option target 'ACCEPT'config rule
option name 'Allow-DHCPv6'
option src 'wan'
option proto 'udp'
option src_ip 'fc00::/6'
option dest_ip 'fc00::/6'
option dest_port '546'
option family 'ipv6'
option target 'ACCEPT'config rule
option name 'Allow-MLD'
option src 'wan'
option proto 'icmp'
option src_ip 'fe80::/10'
list icmp_type '130/0'
list icmp_type '131/0'
list icmp_type '132/0'
list icmp_type '143/0'
option family 'ipv6'
option target 'ACCEPT'config rule
option name 'Allow-ICMPv6-Input'
option src 'wan'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
list icmp_type 'router-solicitation'
list icmp_type 'neighbour-solicitation'
list icmp_type 'router-advertisement'
list icmp_type 'neighbour-advertisement'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'config rule
option name 'Allow-ICMPv6-Forward'
option src 'wan'
option dest '*'
option proto 'icmp'
list icmp_type 'echo-request'
list icmp_type 'echo-reply'
list icmp_type 'destination-unreachable'
list icmp_type 'packet-too-big'
list icmp_type 'time-exceeded'
list icmp_type 'bad-header'
list icmp_type 'unknown-header-type'
option limit '1000/sec'
option family 'ipv6'
option target 'ACCEPT'config include
option path '/etc/firewall.user'config rule
option src 'wan'
option dest 'lan'
option proto 'esp'
option target 'ACCEPT'config rule
option src 'wan'
option dest 'lan'
option dest_port '500'
option proto 'udp'
option target 'ACCEPT' -
RE: How to install GDBServer ?
Tried the following after adding the repos:
opkg update
opkg install gdbserverNow it works.
Thanks !
-
How to install GDBServer ?
Hi,
i am using LEDE-Buildsystem with Eclipse. The remote debugger requires gdbserver to be installed on omega. Searched the packages but found nothing.
How to install ?
Thanks in advance.
-
RE: Omega2+ Cross Compilation on Ubuntu 18.04 LEDE Build failing
I followed mawg's suggestion and compiled the latest stable release on Ubuntu 17.10. This works, but the the git-version did not.
I think i can live with this little disadvantage for the first.Thanks !!!
-
RE: Omega2+ Cross Compilation on Ubuntu 18.04 LEDE Build failing
Thanks for the fast reply.
Yes, i followed the instuctions from the mentioned link.
Yes, my Ubuntu runs in virtual box and so docker runs too.
Unfortunately the actual docker version runs only on win 10, I'am using win 7.
The network connection of the Ubuntu system is totally ok.By the way, it's not clear to me how to integrate the resulting toolchain of the docker procedure in an IDE like eclipse.
For the direct linux procedure exists a manual from mediatek.
So i would normally perfer the linux procedure.
I think this is a lack in onion docs.At moment i am contacting some colleagues, maybe they can help.
Thanks for first !
-
RE: Omega2+ Cross Compilation on Ubuntu 18.04 LEDE Build failing
Unfortunately there was no download link for ubuntu on docker website (only windows and mac), so
i used
sudo apt install docker.io
to install it. Installation process works fine, but make returns an error again.
Make-Debug fails too. See below.root@6f1e6fb7d4da:~/source# make -j1 V=s
WARNING: your configuration is out of sync. Please run make menuconfig, oldconfig or defconfig!
make[1]: Entering directory '/root/source'
make[2]: Entering directory '/root/source'- mkdir -p /root/source/staging_dir/target-mipsel_24kc_musl-1.1.16
- cd /root/source/staging_dir/target-mipsel_24kc_musl-1.1.16
- mkdir -p bin lib include stamp
mkdir -p /root/source/build_dir/target-mipsel_24kc_musl-1.1.16/stamp
touch /root/source/staging_dir/target-mipsel_24kc_musl-1.1.16/.prepared - mkdir -p /root/source/staging_dir/host
- cd /root/source/staging_dir/host
- mkdir -p bin lib include stamp
mkdir -p /root/source/build_dir/host/stamp /root/source/staging_dir/host/include/sys
install -m0644 /root/source/tools/include/.h /root/source/staging_dir/host/include/
install -m0644 /root/source/tools/include/sys/.h /root/source/staging_dir/host/include/sys/
ln -sf lib /root/source/staging_dir/host/lib64
touch /root/source/staging_dir/host/.prepared
make[3]: Entering directory '/root/source/tools/flock'
make[3]: Leaving directory '/root/source/tools/flock'
make[3]: Entering directory '/root/source/tools/flock'
make[3]: Leaving directory '/root/source/tools/flock'
make[3]: Entering directory '/root/source/tools/sed'
mkdir -p /root/source/dl
SHELL= flock /root/source/tmp/.sed-4.2.2.tar.bz2.flock -c ' /root/source/scripts/download.pl "/root/source/dl" "sed-4.2.2.tar.bz2" "f048d1838da284c8bc9753e4506b85a1e0cc1ea8999d36f6995bcb9460cddbd7" "" "@GNU/sed" '
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20539 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20535 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20537 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20532 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20545 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20543 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20546 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20539 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20543 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20545 milliseconds
Download failed.
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 1 seconds. 5 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 2 seconds. 4 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 4 seconds. 3 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 8 seconds. 2 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
Warning: Transient problem: timeout Will retry in 16 seconds. 1 retries left.
0 0 0 0 0 0 0 0 --:--:-- 0:00:20 --:--:-- 0
curl: (28) Resolving timed out after 20539 milliseconds
Download failed.
No more mirrors to try - giving up.
Makefile:46: recipe for target '/root/source/dl/sed-4.2.2.tar.bz2' failed
make[3]: *** [/root/source/dl/sed-4.2.2.tar.bz2] Error 2
make[3]: Leaving directory '/root/source/tools/sed'
tools/Makefile:147: recipe for target 'tools/sed/compile' failed
make[2]: *** [tools/sed/compile] Error 2
make[2]: Leaving directory '/root/source'
tools/Makefile:145: recipe for target '/root/source/staging_dir/target-mipsel_24kc_musl-1.1.16/stamp/.tools_install_yynyyyyynyyyyynyynnyyyynyyyyyyyyyyyyyyynyynynnyyynnny' failed
make[1]: *** [/root/source/staging_dir/target-mipsel_24kc_musl-1.1.16/stamp/.tools_install_yynyyyyynyyyyynyynnyyyynyyyyyyyyyyyyyyynyynynnyyynnny] Error 2
make[1]: Leaving directory '/root/source'
/root/source/include/toplevel.mk:198: recipe for target 'world' failed
make: *** [world] Error 2