@crispyoz Thanks for clarifying and thanks for all your effort helping me find a solution especially as volunteer.
You Rock!
@crispyoz Thanks for clarifying and thanks for all your effort helping me find a solution especially as volunteer.
You Rock!
So are you saying the warp-core driver is end-of-life or no longer supported by the developer?
And no plans to update it with the current OpenWRT release?
@crispyoz Thanks for following up.
I don't think I want to go down that road. I actually had started to do this originally before posting here following the instruction in this thread:
https://forum.openwrt.org/t/cannot-ping-devices-in-the-same-local-network/131988/58
It presented many new problems.
I'll keep with the work-around for now. I'm assuming there can be a trouble-ticket filed for getting the driver issue resolved in the mean time?
I appreciate all your help with this.
I understand the implications of this workaround and I realized this workaround also after the one command worked.
I can get by with this for now, but it would be nice to have a cleaner resolution to this
Thu Feb 29 14:01:54 2024 user.notice route: Starting interface hotplug device: l
o Action: ifup Interface: loopback
Thu Feb 29 14:02:07 2024 user.notice route: Starting interface hotplug device: b
r-wlan Action: ifup Interface: wlan
Thu Feb 29 14:02:09 2024 user.notice route: Starting interface hotplug device: a
pcli0 Action: ifup Interface: wwan
Thu Feb 29 14:02:09 2024 user.notice route: IFUP apcli0
Thu Feb 29 14:05:00 2024 user.notice route: Starting interface hotplug device:
Action: ifdown Interface: loopback
Thu Feb 29 14:05:01 2024 user.notice route: Starting interface hotplug device:
Action: ifdown Interface: wlan
Thu Feb 29 14:05:01 2024 user.notice route: Starting interface hotplug device:
Action: ifdown Interface: wwan
Thu Feb 29 14:05:08 2024 user.notice route: Starting interface hotplug device: l
o Action: ifup Interface: loopback
Thu Feb 29 14:05:09 2024 user.notice route: Starting interface hotplug device: a
pcli0 Action: ifup Interface: wwan
Thu Feb 29 14:05:09 2024 user.notice route: IFUP apcli0
Thu Feb 29 14:05:10 2024 user.notice route: Starting interface hotplug device: b
r-wlan Action: ifup Interface: wlan
That didn't work.
And I don't know where to retrieve the log from.
It didn't show up in the command line output
Not working with those options removed.
root@Omega-3DA9:/# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.240.0 U 0 0 0 apcli0
192.168.3.0 * 255.255.255.0 U 0 0 0 br-wlan
root@Omega-3DA9:/# cd etc/config
root@Omega-3DA9:/etc/config# cat network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1d:48c4:7633::/48'
config interface 'wlan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wwan'
option ifname 'apcli0'
option hostname 'Omega-3DA9'
option proto 'static'
option ipaddr '192.168.5.88'
option netmask '255.255.240.0'
option gateway '192.168.5.254'
option dns '8.8.8.8'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
config route 'default'
option interface 'wwan'
option gateway '192.168.5.254'
option metric '0'
root@Omega-3DA9:/etc/config# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
root@Omega-3DA9:/etc/config# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.240.0 U 0 0 0 apcli0
192.168.3.0 * 255.255.255.0 U 0 0 0 br-wlan
root@Omega-3DA9:/etc/config# cat network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1d:48c4:7633::/48'
config interface 'wlan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wwan'
option ifname 'apcli0'
option hostname 'Omega-3DA9'
option proto 'static'
option ipaddr '192.168.5.88'
option netmask '255.255.240.0'
option gateway '192.168.5.254'
option dns '8.8.8.8'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
config route 'default'
option interface 'wwan'
option gateway '192.168.5.254'
option target '0.0.0.0'
option netmask '0.0.0.0'
option metric '0'
That worked!
root@Omega-3DA9:/etc/config# ip route add default via 192.168.5.254 dev apcli0
root@Omega-3DA9:/etc/config# ip route get 8.8.8.8
8.8.8.8 via 192.168.5.254 dev apcli0 src 192.168.5.88
root@Omega-3DA9:/etc/config# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=117 time=21.440 ms
64 bytes from 8.8.8.8: seq=1 ttl=117 time=21.110 ms
64 bytes from 8.8.8.8: seq=2 ttl=117 time=24.762 ms
64 bytes from 8.8.8.8: seq=3 ttl=117 time=30.374 ms
64 bytes from 8.8.8.8: seq=4 ttl=117 time=39.886 ms
^C
--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 21.110/27.514/39.886 ms
root@Omega-3DA9:/etc/config# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.5.254 0.0.0.0 UG 0 0 0 apcli0
192.168.0.0 * 255.255.240.0 U 0 0 0 apcli0
192.168.3.0 * 255.255.255.0 U 0 0 0 br-wlan
Still no luck.
root@Omega-3DA9:/etc/config# cat network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1d:48c4:7633::/48'
config interface 'wlan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wwan'
option ifname 'apcli0'
option hostname 'Omega-3DA9'
option proto 'static'
option ipaddr '192.168.5.88'
option gateway '192.168.5.254'
option netmask '255.255.240.0'
option dns '8.8.8.8'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
config route 'default'
option interface 'wwan'
option gateway '192.168.5.254'
option target '0.0.0.0'
option netmask '0.0.0.0'
option metric '0'
root@Omega-3DA9:/etc/config# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.240.0 U 0 0 0 apcli0
192.168.3.0 * 255.255.255.0 U 0 0 0 br-wlan
root@Omega-3DA9:/etc/config# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
I thought I had done that. Am I missing something?
root@Omega-3DA9:/etc/config# cat network
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'
config globals 'globals'
option ula_prefix 'fd1d:48c4:7633::/48'
config interface 'wlan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.3.1'
option netmask '255.255.255.0'
option ip6assign '60'
config interface 'wwan'
option ifname 'apcli0'
option hostname 'Omega-3DA9'
option netmask '255.255.240.0'
option gateway '192.168.5.254'
option dns '8.8.8.8'
option ipaddr '192.168.5.186'
option proto 'static'
config interface 'wan'
option ifname 'eth0'
option proto 'dhcp'
And with dhcp:
round-trip min/avg/max = 19.924/24.932/32.018 ms
root@Omega-3DA9:/# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
default 192.168.5.254 0.0.0.0 UG 0 0 0 apcli0
192.168.0.0 * 255.255.240.0 U 0 0 0 apcli0
192.168.3.0 * 255.255.255.0 U 0 0 0 br-wlan
Oh sorry my mistake.
root@Omega-3DA9:/# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
192.168.0.0 * 255.255.240.0 U 0 0 0 apcli0
192.168.3.0 * 255.255.255.0 U 0 0 0 br-wlan
The output to traceroute is in there. It says 'Network unreachable'.
I just tried setting static ip to 192.168.5.186 and that also does NOT work.
Here are those outputs using static IP.
I also pinged the gateway at the end
root@Omega-3DA9:/# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
root@Omega-3DA9:/#
root@Omega-3DA9:/# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1traceroute: sendto: Network unreachable
root@Omega-3DA9:/#
root@Omega-3DA9:/# ifconfig
apcli0 Link encap:Ethernet HWaddr 88:1E:59:01:3D:AB
inet addr:192.168.5.88 Bcast:192.168.15.255 Mask:255.255.240.0
inet6 addr: fe80::8a1e:59ff:fe01:3dab/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:9316 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
br-wlan Link encap:Ethernet HWaddr 88:1E:59:01:3D:A9
inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
inet6 addr: fd1d:48c4:7633::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:28 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:5768 (5.6 KiB)
eth0 Link encap:Ethernet HWaddr 88:1E:59:01:3D:AA
inet6 addr: fe80::8a1e:59ff:fe01:3daa/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:2929 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:994005 (970.7 KiB)
Interrupt:5
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:294 errors:0 dropped:0 overruns:0 frame:0
TX packets:294 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:20510 (20.0 KiB) TX bytes:20510 (20.0 KiB)
ra0 Link encap:Ethernet HWaddr 88:1E:59:01:3D:A9
inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:6
root@Omega-3DA9:/# ping 192.168.5.254
PING 192.168.5.254 (192.168.5.254): 56 data bytes
64 bytes from 192.168.5.254: seq=0 ttl=64 time=11.243 ms
64 bytes from 192.168.5.254: seq=1 ttl=64 time=6.952 ms
64 bytes from 192.168.5.254: seq=2 ttl=64 time=10.411 ms
64 bytes from 192.168.5.254: seq=3 ttl=64 time=4.754 ms
64 bytes from 192.168.5.254: seq=4 ttl=64 time=5.466 ms
And here's the ifconfig output with DHCP:
root@Omega-3DA9:/# ifconfig
apcli0 Link encap:Ethernet HWaddr 88:1E:59:01:3D:AB
inet addr:192.168.5.186 Bcast:192.168.15.255 Mask:255.255.240.0
inet6 addr: fe80::8a1e:59ff:fe01:3dab/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:1595 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
br-wlan Link encap:Ethernet HWaddr 88:1E:59:01:3D:A9
inet addr:192.168.3.1 Bcast:192.168.3.255 Mask:255.255.255.0
inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
inet6 addr: fd1d:48c4:7633::1/60 Scope:Global
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:40 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:7305 (7.1 KiB)
eth0 Link encap:Ethernet HWaddr 88:1E:59:01:3D:AA
inet6 addr: fe80::8a1e:59ff:fe01:3daa/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:533 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:176870 (172.7 KiB)
Interrupt:5
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:65536 Metric:1
RX packets:286 errors:0 dropped:0 overruns:0 frame:0
TX packets:286 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:20014 (19.5 KiB) TX bytes:20014 (19.5 KiB)
ra0 Link encap:Ethernet HWaddr 88:1E:59:01:3D:A9
inet6 addr: fe80::8a1e:59ff:fe01:3da9/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
Interrupt:6
Sorry it's a habit to search threads for common issues before posting a question and the similar issue others had above weren't addressed.
Nevertheless, I had already set those parameters for the wwan interface and it didn't make any difference.
Here's the output from those commands.
root@Omega-3DA9:/# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd1d:48c4:7633::/48'
network.wlan=interface
network.wlan.type='bridge'
network.wlan.proto='static'
network.wlan.ipaddr='192.168.3.1'
network.wlan.netmask='255.255.255.0'
network.wlan.ip6assign='60'
network.wwan=interface
network.wwan.ifname='apcli0'
network.wwan.hostname='Omega-3DA9'
network.wwan.proto='static'
network.wwan.ipaddr='192.168.5.88'
network.wwan.netmask='255.255.240.0'
network.wwan.gateway='192.168.5.254'
network.wwan.dns='8.8.8.8'
network.wan=interface
network.wan.ifname='eth0'
network.wan.proto='dhcp'
root@Omega-3DA9:/# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='ralink'
wireless.radio0.variant='mt7628'
wireless.radio0.country='US'
wireless.radio0.hwmode='11g'
wireless.radio0.htmode='HT40'
wireless.radio0.channel='auto'
wireless.radio0.disabled='0'
wireless.radio0.device_mode='apsta'
wireless.radio0.op_mode='preference'
wireless.ap=wifi-iface
wireless.ap.device='radio0'
wireless.ap.mode='ap'
wireless.ap.network='wlan'
wireless.ap.ifname='ra0'
wireless.ap.encryption='psk2'
wireless.ap.key='12345678'
wireless.ap.disabled='0'
wireless.ap.ssid='Omega-3DA9'
wireless.sta=wifi-iface
wireless.sta.device='radio0'
wireless.sta.mode='sta'
wireless.sta.ifname='apcli0'
wireless.sta.encryption='psk2'
wireless.sta.network='wwan'
wireless.sta.led='omega2p:blue:wifi'
wireless.sta.disabled='0'
wireless.sta.key='<MY_PASSWORD>'
wireless.sta.ssid='<MY_SSID>'
wireless.@wifi-config[0]=wifi-config
wireless.@wifi-config[0].key='<MY_PASSWORD>'
wireless.@wifi-config[0].ssid='<MY_SSID>'
wireless.@wifi-config[0].encryption='psk2'
root@Omega-3DA9:/# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1traceroute: sendto: Network unreachable
root@Omega-3DA9:/# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
ping: sendto: Network unreachable
root@Omega-3DA9:/#
And here is the same with DHCP enabled:
root@Omega-3DA9:/# uci show network
network.loopback=interface
network.loopback.ifname='lo'
network.loopback.proto='static'
network.loopback.ipaddr='127.0.0.1'
network.loopback.netmask='255.0.0.0'
network.globals=globals
network.globals.ula_prefix='fd1d:48c4:7633::/48'
network.wlan=interface
network.wlan.type='bridge'
network.wlan.proto='static'
network.wlan.ipaddr='192.168.3.1'
network.wlan.netmask='255.255.255.0'
network.wlan.ip6assign='60'
network.wwan=interface
network.wwan.ifname='apcli0'
network.wwan.hostname='Omega-3DA9'
network.wwan.ipaddr='192.168.5.88'
network.wwan.netmask='255.255.240.0'
network.wwan.gateway='192.168.5.254'
network.wwan.dns='8.8.8.8'
network.wwan.proto='dhcp'
network.wan=interface
network.wan.ifname='eth0'
network.wan.proto='dhcp'
root@Omega-3DA9:/# uci show wireless
wireless.radio0=wifi-device
wireless.radio0.type='ralink'
wireless.radio0.variant='mt7628'
wireless.radio0.country='US'
wireless.radio0.hwmode='11g'
wireless.radio0.htmode='HT40'
wireless.radio0.channel='auto'
wireless.radio0.disabled='0'
wireless.radio0.device_mode='apsta'
wireless.radio0.op_mode='preference'
wireless.ap=wifi-iface
wireless.ap.device='radio0'
wireless.ap.mode='ap'
wireless.ap.network='wlan'
wireless.ap.ifname='ra0'
wireless.ap.encryption='psk2'
wireless.ap.key='12345678'
wireless.ap.disabled='0'
wireless.ap.ssid='Omega-3DA9'
wireless.sta=wifi-iface
wireless.sta.device='radio0'
wireless.sta.mode='sta'
wireless.sta.ifname='apcli0'
wireless.sta.encryption='psk2'
wireless.sta.network='wwan'
wireless.sta.led='omega2p:blue:wifi'
wireless.sta.disabled='0'
wireless.sta.key='<MY_PASSWORD>'
wireless.sta.ssid='<MY_SSID>'
wireless.@wifi-config[0]=wifi-config
wireless.@wifi-config[0].key='<MY_PASSWORD>'
wireless.@wifi-config[0].ssid='<MY_SSID>'
wireless.@wifi-config[0].encryption='psk2'
root@Omega-3DA9:/# ping 8.8.8.8
PING 8.8.8.8 (8.8.8.8): 56 data bytes
64 bytes from 8.8.8.8: seq=0 ttl=117 time=43.152 ms
64 bytes from 8.8.8.8: seq=1 ttl=117 time=27.060 ms
64 bytes from 8.8.8.8: seq=2 ttl=117 time=33.935 ms
64 bytes from 8.8.8.8: seq=3 ttl=117 time=43.808 ms
64 bytes from 8.8.8.8: seq=4 ttl=117 time=23.444 ms
^C
--- 8.8.8.8 ping statistics ---
5 packets transmitted, 5 packets received, 0% packet loss
round-trip min/avg/max = 23.444/34.279/43.808 ms
root@Omega-3DA9:/# traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 38 byte packets
1 192.168.5.254 (192.168.5.254) 8.139 ms 3.263 ms 3.386 ms
2 107-222-2-1.lightspeed.tpkaks.sbcglobal.net (107.222.2.1) 4.638 ms 5.771 ms 4.953 ms
3 99.164.208.50 (99.164.208.50) 23.434 ms 15.245 ms 7.470 ms
4 * * *
5 * * *
6 32.130.17.87 (32.130.17.87) 20.985 ms 23.270 ms 34.714 ms
7 12.255.10.122 (12.255.10.122) 57.814 ms 12.255.10.120 (12.255.10.120) 26.544 ms 12.255.10.124 (12.255.10.124) 31.061 ms
8 * * *
9 dns.google (8.8.8.8) 20.466 ms 19.858 ms 27.595 ms
root@Omega-3DA9:/#
Has anyone found a solution to this yet?
I've seen this on several different omega2+ modules now.
Wifi Client configured with static IP can ping local network, but cannot reach the internet.
It works fine when using DHCP, though.