Group Details Private

Moderator

User moderators

Member List

  • RE: How to move a file from Mac to Omega

    @Zonque The reason why you cannot ping or rsync to the Omega2 is that your Mac has no apparent route to the device. Your Mac is most likely routing everything through it's primary network connection on the 10.0.x.x network and that network has no route to the 192.168.x.x network.

    The simplest method is to connect your Omega2 to the same network as your Mac, that way both devices are on the same subnet and the routing ceases to be an issue.

    Alternatively you can add a route to yor Mac routing table. First find the name of the interface on Mac that is connected to the Omega2 wifi, use the ifconfig command to see the names, then from the command prompt of your Mac issue this command, replacing the interface name

    route add -host 192.168.3.1 -interface <name of the interface>

    posted in Omega Talk
  • RE: Original Image openwrt-22.03.3-ramips

    @Paolo-Moro Here is the configuration files to give you a functional OpenWrt 22 wifi network.

    /etc/config/network:

    config interface 'loopback'
            option device 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fdb2:2708:4969::/48'
    
    config device
            option name 'br-lan'
            option type 'bridge'
            list ports 'eth0'
    
    config interface 'lan'
            option device 'br-lan'
            option proto 'dhcp'
            option ip6assign '60'
    
    
    config interface 'wwan'
            option ifname 'apcli0'
            option proto 'dhcp'
            option hostname 'o2ptest'
    

    /etc/config/wireless:

    config wifi-device 'radio0'
            option type 'mac80211'
            option path 'platform/10300000.wmac'
            option channel 'auto'
            option band '2g'
            option htmode 'HT20'
            option log_level '1'
            option disabled '0'
            option country 'AU'
    
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'lan'
            option mode 'ap'
            option ssid 'OpenWrt'
            option encryption 'none'
            option disabled '1'
    
    config wifi-iface 'sta'
            option device 'radio0'
            option mode 'sta'
            option ifname 'apcli0'
            option encryption 'psk2'
            option network 'wwan'
            option led 'omega2p:blue:wifi'
            option disabled '0'
            option key '<your wifi password>'
            option ssid '<your wifi ssid>'
    
    posted in Omega Talk
  • RE: Changing the MAC addresses posted in Omega Talk
  • RE: AP maximum number of clients

    @stefanu The answer depends on a number of factors, if you are using the Wap Core wifi driver I have no idea, but its probably 16384.

    The standard OpenWrt driver has a maximum of of 16384 but suspect you'll get some performance issues long before you hit this volume.

    f you want to limit the maximum number of connections on your AP you can set it like so:

    option maxassoc '5'

    posted in Omega Talk
  • RE: Help getting into my Omega

    @Zonque As Lazar alluded to, I suspect your firmware deployment probably blew away your configuration so you should approach the device as if it were a new device and follow the docs on how to access a new device.

    https://docs.onion.io/omega2-docs/connecting-to-the-omega-terminal.html#connecting-to-the-omega-terminal

    posted in Omega Talk
  • RE: Original Image openwrt-22.03.3-ramips

    @Paolo-Moro @DumTux My understanding is that Openwrt 22 firmware is considered experimental by Onion Corporation so don't expect too much. We know the Onion utils have no been portd to later versions of OpenWrt, but since Omega2 is open source, it's really up to the user base to move things forward.

    I use OpenWrt 22 on some limited production devices, I recall some other users on here do also, I have to manually configure the wifi setup. Of ocurse this is done via the build system.

    posted in Omega Talk
  • RE: How to create a custom image and flash this image on Omega Onion Pro 2 posted in Projects
  • RE: Step-by-Step Video Instructions for Mobile Network File Server (Cloud)?

    @Amalee The permission error is becasue you are trying to execute /etc/config/samba, this is a configuration file not an executable file. Can you post the content of /etc/config/samba. Also post the results of ps command.

    I assume you installed samba server using opkg install samba36-server , what other steps have you taken? By default samba listens on all interfaces, you can modify /etc/config/samba to force it to listen only on a single interface by adding the line:

    option interfaces 'apcli0'

    or

    option interfaces '192.168.10.93'

    You will also need to add firewall rules to allow access to samba ports, take a look at /etc/config/firewall and add rules for all ports:

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'udp'
    option dest_port '137'
    option name 'SAMBA 137'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'udp'
    option dest_port '138'
    option name 'SAMBA 138'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'tcp'
    option dest_port '139'
    option name 'SAMBA 139'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'tp'
    option dest_port '445'
    option name 'SAMBA 445'
    option enabled '1'

    Probably easier to reboot then.

    Before setting up the firewall rules I usually just stop the firewall and troubleshoot the issue and then setup the rules and restart the firewall.

    Stopping the firewall: service firewall stop

    Let us know what steps you have taken and how you are trying to access your omega samba device, using a MAC/Windows/*nix??

    posted in Projects
  • RE: Original Omega

    @Andrew-Doherty I just tested the link:

    fb517741-19e8-4f15-8dae-274f62c9a738-image.png

    posted in Omega Talk
  • RE: Original Omega

    @Andrew-Doherty The firmware releases for the original Omega are available here: http://repo.onion.io/omega/images/

    posted in Omega Talk

Looks like your connection to Community was lost, please wait while we try to reconnect.