We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2 `apcli0` will not obtain ipv4 address



  • @William-Jones my next step would be to hard code the IP just to determine if the issue is with dhcp or the network/setup itself. To do this edit your /etc/config/network file and look for wlan section. Change the proto option to "static" (instead of dhcp) and then add option ipaddr '192.168.1.100' and add option netmask '255.255.255.0' , option gateway '192.168.1.1'. Of course these setting need to be changed to suit your own network configuration. Then restart and check ifconfig, ping the gateway etc.



  • Okay, this is interesting... by switching to a static IP address, I finally get an ipv4 address:

    root@Omega-E72B:/# cat /etc/config/network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wwan'
            option ifname 'apcli0'
    #       option proto 'dhcp'
            option proto 'static'
            option ipaddr 192.168.1.100
            option netmask 255.255.255.0
            option gateway 192.168.1.1
            option hostname 'Omega-E72B'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    root@Omega-E72B:/# ifconfig
    apcli0    Link encap:Ethernet  HWaddr 40:A3:6B:C0:E7:2C
              inet addr:192.168.1.100  Bcast:192.168.1.255  Mask:255.255.255.0
              inet6 addr: fe80::42a3:6bff:fec0:e72c/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:0 errors:0 dropped:1 overruns:0 frame:0
              TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
    ...
    
    root@Omega-E72B:/# iwconfig
    ...
    
    apcli0    RTWIFI SoftAP  ESSID:[redacted]
              Mode:Managed  Channel=6  Access Point: 00:90:A9:CB:3F:06
              Bit Rate=150 Mb/s
    ...
    

    It seems as if I should be connected to the router; the MAC address specified in the Access Point field of iwconfig is correct. However, pinging the router does nothing:

    root@Omega-E72B:/# ping 192.168.1.1
    PING 192.168.1.1 (192.168.1.1): 56 data bytes
    ^C
    --- 192.168.1.1 ping statistics ---
    3 packets transmitted, 0 packets received, 100% packet loss
    root@Omega-E72B:/#
    

    This indicates that there's something wrong with my network setup... but what?



  • I have attempted a factory reset and to use a separate radio on my router- with WPA2 encryption- using the following command line:

    wifisetup add -ssid [redacted2] -encr psk2 -password
    [redacted2]
    

    After the interfaces reset, apcli0 will refuse to associated with the router:

    root@Omega-E72B:/# iwconfig
    lo        no wireless extensions.
    
    apcli0    RTWIFI SoftAP  ESSID:""
              Mode:Managed  Channel=6  Access Point: Not-Associated
              Bit Rate:150 Mb/s
    
    br-wlan   no wireless extensions.
    
    eth0      no wireless extensions.
    
    ra0       RTWIFI SoftAP  ESSID:"Omega-E72B"
              Mode:Managed  Channel=6  Access Point: 40:A3:6B:C0:E7:2B
              Bit Rate=150 Mb/s
    

    If I attempt to set both networks up simultaneously, the Omega2 only ever attempts to associate with the WEP network. I'm very much stumped and about to give up. What is wrong here?!



  • @William-Jones most routers will have a debug log you can turn on, this should show you the process of association and where the wheels are falling off. WHat type and model router do you have?



  • @crispyoz Western Digital MyNet N750... older router that was discontinued a few years ago...

    Did another factory reset and then went back to WEP settings. The router log accessible from the admin panel shows no activity from the Omega2...

    But the Omega2 can clearly find it because the MAC address is correct.



  • By using the xfinity-wifi hotspot in my modem, which has no encryption enabled, I am able to connect the Omega2 to a network. I can't actually access the internet because I can't authenticate via a webpage, but at least this is a sign that the hardware is working... and maybe my router isn't...

    root@Omega-0000:/# wifisetup add -ssid xfinitywifi -encr none
    ...
    
    root@Omega-E72B:/# iwconfig
    ...
    
    apcli0    RTWIFI SoftAP  ESSID:"xfinitywifi"
              Mode:Managed  Channel=11  Access Point: 06:1D:D5:97:DC:10
              Bit Rate=150 Mb/s
    ...
    
    root@Omega-E72B:/# ip addr
    ...
    
    5: apcli0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc fq_codel state UNKNOWN qlen 1000
        link/ether 40:a3:6b:c0:e7:2c brd ff:ff:ff:ff:ff:ff
        inet 172.20.20.20/24 brd 172.20.20.255 scope global apcli0
           valid_lft forever preferred_lft forever
        inet6 fe80::42a3:6bff:fec0:e72c/64 scope link
           valid_lft forever preferred_lft forever
    ...
    
    root@Omega-E72B:/# ping 172.20.20.1
    PING 172.20.20.1 (172.20.20.1): 56 data bytes
    64 bytes from 172.20.20.1: seq=0 ttl=64 time=19.701 ms
    64 bytes from 172.20.20.1: seq=1 ttl=64 time=30.207 ms
    64 bytes from 172.20.20.1: seq=2 ttl=64 time=17.992 ms
    ^C
    --- 172.20.20.1 ping statistics ---
    3 packets transmitted, 3 packets received, 0% packet loss
    round-trip min/avg/max = 17.992/22.633/30.207 ms
    root@Omega-E72B:/#
    

    EDIT: I disabled encryption on my main router, connected in much the same manner, and I was able to access the Internet and ping Google. However, since the IP address is of the form 192.168.252.x instead of 192.168.1.x, I can't actually access the Omega2 from any of my other computers on the home network. The DHCP request also shows up in my router logs in this case:

    Fri Jan 3 22:11:33 2020	DHCP: Server sending ACK to 192.168.252.130. (Lease time = 604800)
    Fri Jan 3 22:11:33 2020	DHCP: Server receive REQUEST from 40:a3:6b:c0:e7:2c.
    Fri Jan 3 22:11:33 2020	DHCP: Server sending OFFER of 192.168.252.130.
    Fri Jan 3 22:11:32 2020	DHCP: Server receive DISCOVER from 40:a3:6b:c0:e7:2c.
    

    So it appears I'm not setting something up w/ WEP properly?



  • @William-Jones this is a bit of a long shot but I wonder if your router is not correctly negotiating the WEP type, there are 2 types of WEP, Open and Shared, you could try specifying your specific WEP type. From the docs:

    "Use wep+shared or wep+open to force a specific mode."



  • Manually specifying either shared or open has no effect. In wifisetup, the option wep+shared is interpreted as no encryption (fair enough).

    When I manually try to set the relevant options using uci or modify /etc/config/wireless directly, something is forcefully setting the encryption of config wifi-iface 'sta' (apcli0) back to wep in both /etc/config/wireless and uci show when apcli0 comes up. How can I figure out what is forcefully changing the string back?

    Also, has seriously nobody seen an error like this? I almost installed OpenWRT on my home router a few years back. This makes me want to stay far away.



  • @William-Jones that is an interesting turn of events. My suspicion is that the Warp driver is making these changes but this driver is not open source so there is no way to look at that code. Maybe @Lazar-Demin from Onion can comment on that.

    A quick fix might be to set the correct configuration manually then set the wireless config file to read only. I've never tried that before but it might be worth a try.

    This is not something I have heard of before and I have Omega2+ on a few hundred sites utilising a wide range of wifi APs.



  • Even when I set the wireless config file to read only, something is managing to change the string back to wep alone.

    This is not something I have heard of before and I have Omega2+ on a few hundred sites utilising a wide range of wifi APs.

    Do any of them use WEP shared :P?



  • @William-Jones yes I have 3 or 4 on WEP (reluctantly) all on one site and router. I would suggest you try another router, WEP is inherently insecure so I don't think anyone is going to fix an issue related to WEP.


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.