We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Disable AP and set static IP



  • Still no luck.

    
    root@Omega-3DA9:/etc/config# cat network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option hostname 'Omega-3DA9'
            option proto 'static'
            option ipaddr '192.168.5.88'
            option gateway '192.168.5.254'
            option netmask '255.255.240.0'
            option dns '8.8.8.8'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config route 'default'
            option interface 'wwan'
            option gateway '192.168.5.254'
            option target '0.0.0.0'
            option netmask '0.0.0.0'
            option metric '0'
    
    root@Omega-3DA9:/etc/config# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.0.0     *               255.255.240.0   U     0      0        0 apcli0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan
    root@Omega-3DA9:/etc/config# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: Network unreachable
    


  • @drmoeder try this:

    ip route add default via 192.168.5.254 dev apcli0
    ip route get 8.8.8.8
    ping 8.8.8.8



  • That worked!

    
    root@Omega-3DA9:/etc/config# ip route add default via 192.168.5.254 dev apcli0
    root@Omega-3DA9:/etc/config# ip route get 8.8.8.8
    8.8.8.8 via 192.168.5.254 dev apcli0  src 192.168.5.88
    root@Omega-3DA9:/etc/config# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    64 bytes from 8.8.8.8: seq=0 ttl=117 time=21.440 ms
    64 bytes from 8.8.8.8: seq=1 ttl=117 time=21.110 ms
    64 bytes from 8.8.8.8: seq=2 ttl=117 time=24.762 ms
    64 bytes from 8.8.8.8: seq=3 ttl=117 time=30.374 ms
    64 bytes from 8.8.8.8: seq=4 ttl=117 time=39.886 ms
    ^C
    --- 8.8.8.8 ping statistics ---
    5 packets transmitted, 5 packets received, 0% packet loss
    round-trip min/avg/max = 21.110/27.514/39.886 ms
    root@Omega-3DA9:/etc/config# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    default         192.168.5.254   0.0.0.0         UG    0      0        0 apcli0
    192.168.0.0     *               255.255.240.0   U     0      0        0 apcli0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan
    


  • @drmoeder ok but it will stop working when you restart the network, please post your entire /etc/config/network file



  • 
    root@Omega-3DA9:/etc/config# cat network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option hostname 'Omega-3DA9'
            option proto 'static'
            option ipaddr '192.168.5.88'
            option netmask '255.255.240.0'
            option gateway '192.168.5.254'
            option dns '8.8.8.8'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config route 'default'
            option interface 'wwan'
            option gateway '192.168.5.254'
            option target '0.0.0.0'
            option netmask '0.0.0.0'
            option metric '0'
    
    


  • @drmoeder In the default route, remove target and netmask options. Then use service network restart or reboot and check your routing table again.



  • Not working with those options removed.

    
    
    root@Omega-3DA9:/# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.0.0     *               255.255.240.0   U     0      0        0 apcli0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan
    root@Omega-3DA9:/# cd etc/config
    root@Omega-3DA9:/etc/config# cat network
    
    config interface 'loopback'
            option ifname 'lo'
            option proto 'static'
            option ipaddr '127.0.0.1'
            option netmask '255.0.0.0'
    
    config globals 'globals'
            option ula_prefix 'fd1d:48c4:7633::/48'
    
    config interface 'wlan'
            option type 'bridge'
            option proto 'static'
            option ipaddr '192.168.3.1'
            option netmask '255.255.255.0'
            option ip6assign '60'
    
    config interface 'wwan'
            option ifname 'apcli0'
            option hostname 'Omega-3DA9'
            option proto 'static'
            option ipaddr '192.168.5.88'
            option netmask '255.255.240.0'
            option gateway '192.168.5.254'
            option dns '8.8.8.8'
    
    config interface 'wan'
            option ifname 'eth0'
            option proto 'dhcp'
    
    config route 'default'
            option interface 'wwan'
            option gateway '192.168.5.254'
            option metric '0'
    
    root@Omega-3DA9:/etc/config# ping 8.8.8.8
    PING 8.8.8.8 (8.8.8.8): 56 data bytes
    ping: sendto: Network unreachable
    root@Omega-3DA9:/etc/config# route
    Kernel IP routing table
    Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
    192.168.0.0     *               255.255.240.0   U     0      0        0 apcli0
    192.168.3.0     *               255.255.255.0   U     0      0        0 br-wlan


  • @drmoeder hmmm not sure why this is not updating the routing table, perhaps someone else has an idea. But here is a workaround for you as I'm going to be offline for the next 24 hours so this will fix the issue for you.

    Put this script in /etc/hotplug.d/iface/40-wwan-up-route:

    #!/bin/sh
    TARGET_INTERFACE="wwan"

    logger -t route "Starting interface hotplug device: ${DEVICE} Action: ${ACTION} Interface: ${INTERFACE}"
    if [ "$ACTION" = "ifup" -a "$INTERFACE" = "$TARGET_INTERFACE" ]; then
    logger -t route "IFUP ${DEVICE}"
    /sbin/ip route add default via 192.168.5.254 dev "${DEVICE}" >/dev/null

    fi

    This scripts runs whenever the interface comes up and adds the route. I just wrote this for you based on another of my scripts so give it a test and let me know how you go. As you can see it logs the activity so if you have any issues post those log entries.



  • That didn't work.
    And I don't know where to retrieve the log from.
    It didn't show up in the command line output



  • @drmoeder

    logread | grep -i route | less



  • Thu Feb 29 14:01:54 2024 user.notice route: Starting interface hotplug device: l
    o Action: ifup Interface: loopback
    Thu Feb 29 14:02:07 2024 user.notice route: Starting interface hotplug device: b
    r-wlan Action: ifup Interface: wlan
    Thu Feb 29 14:02:09 2024 user.notice route: Starting interface hotplug device: a
    pcli0 Action: ifup Interface: wwan
    Thu Feb 29 14:02:09 2024 user.notice route: IFUP apcli0
    Thu Feb 29 14:05:00 2024 user.notice route: Starting interface hotplug device:
    Action: ifdown Interface: loopback
    Thu Feb 29 14:05:01 2024 user.notice route: Starting interface hotplug device:
    Action: ifdown Interface: wlan
    Thu Feb 29 14:05:01 2024 user.notice route: Starting interface hotplug device:
    Action: ifdown Interface: wwan
    Thu Feb 29 14:05:08 2024 user.notice route: Starting interface hotplug device: l
    o Action: ifup Interface: loopback
    Thu Feb 29 14:05:09 2024 user.notice route: Starting interface hotplug device: a
    pcli0 Action: ifup Interface: wwan
    Thu Feb 29 14:05:09 2024 user.notice route: IFUP apcli0
    Thu Feb 29 14:05:10 2024 user.notice route: Starting interface hotplug device: b
    r-wlan Action: ifup Interface: wlan
    


  • @drmoeder It seems that the routing configurations are not being read by the wifi system. I tried it on OpenWrt 22 and it works fine by placing routing entries in /etc/config/network. My guess is the issue is in the Warp driver but it;s closed source so it's just an assumption.

    The hotplug script I provided earlier is adding the route, but it's getting cleared out after network finishes loading.

    I found a workaround that works, but I'm not in love with it, it creates the required default route when you restart the device, but if you just restart the network the route is removed.

    Here is my entry in /etc/config/network, set your own ip's:

    config interface 'wwan'
    option ifname 'apcli0'
    option proto 'static'
    option ipaddr '192.168.1.85'
    option netmask '255.255.255.0'
    option gateway '192.168.1.1'
    option hostname 'Omega-1FE3'

    Then you need to add 2 lines to /etc/rc.local:

    sleep 15
    /sbin/ip route add default via 192.168.5.254 dev apcli0

    Another options may be to use dhcp but set an IP reservation on your router (if you can),



  • I appreciate all your help with this.
    I understand the implications of this workaround and I realized this workaround also after the one command worked.
    I can get by with this for now, but it would be nice to have a cleaner resolution to this



  • @drmoeder I've done some more testing and have concluded the issue is in the Warp Core driver(s). The solution is to switch to the standard OpenWrt wifi system but I'm not sure if that is something you are interested in pursuing. You'd need to learn to use the standard OpenWrt wifi configuration tools which are not as nice as the Onion tools.



  • @crispyoz Thanks for following up.
    I don't think I want to go down that road. I actually had started to do this originally before posting here following the instruction in this thread:
    https://forum.openwrt.org/t/cannot-ping-devices-in-the-same-local-network/131988/58
    It presented many new problems.

    I'll keep with the work-around for now. I'm assuming there can be a trouble-ticket filed for getting the driver issue resolved in the mean time?



  • @drmoeder I doubt this ill get fixed, the Warp Core stuff is closed source and the issues it was developed to address were resolved in the later releases of OpenWrt 18 and no longer are an issue in OpenWrt 19,20,21,22 and the current release 23.



  • So are you saying the warp-core driver is end-of-life or no longer supported by the developer?
    And no plans to update it with the current OpenWRT release?



  • @drmoeder I can't speak for Onion as I don't work for them. The reason Warp Core was developed was due to reliability and performance issues with the standard OpenWrt Mediatek driver and it has served its purpose well. As times passed some companies made significant investments into improving the Mediatek driver to the point that Warp Core is no longer needed. I think many of us have switched to the standard Mediatek driver for various reasons, one important reason for me is that I want to disable the AP but still use the STA, Warp Core can't do that, the Mediatek driver can.

    I'm using OpenWrt 22 these days and the Mediatek driver.



  • @crispyoz Thanks for clarifying and thanks for all your effort helping me find a solution especially as volunteer.

    You Rock!


Log in to reply
 

Looks like your connection to Community was lost, please wait while we try to reconnect.