@Amalee The permission error is becasue you are trying to execute /etc/config/samba, this is a configuration file not an executable file. Can you post the content of /etc/config/samba. Also post the results of ps command. I assume you installed samba server using opkg install samba36-server , what other steps have you taken? By default samba listens on all interfaces, you can modify /etc/config/samba to force it to listen only on a single interface by adding the line: option interfaces 'apcli0' or option interfaces '192.168.10.93' You will also need to add firewall rules to allow access to samba ports, take a look at /etc/config/firewall and add rules for all ports: config rule option target 'ACCEPT' option src 'wwan' option proto 'udp' option dest_port '137' option name 'SAMBA 137' option enabled '1' config rule option target 'ACCEPT' option src 'wwan' option proto 'udp' option dest_port '138' option name 'SAMBA 138' option enabled '1' config rule option target 'ACCEPT' option src 'wwan' option proto 'tcp' option dest_port '139' option name 'SAMBA 139' option enabled '1' config rule option target 'ACCEPT' option src 'wwan' option proto 'tp' option dest_port '445' option name 'SAMBA 445' option enabled '1' Probably easier to reboot then. Before setting up the firewall rules I usually just stop the firewall and troubleshoot the issue and then setup the rules and restart the firewall. Stopping the firewall: service firewall stop Let us know what steps you have taken and how you are trying to access your omega samba device, using a MAC/Windows/*nix??