We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Step-by-Step Video Instructions for Mobile Network File Server (Cloud)?

  • Hi Onioneers,

    Back in 2018 I purchased the Onion Omega 2+, but I have never done anything (i.e., project) successfully with it. I am a complete noob, with zero education or experience in this field. Moreover, trying to figure out how to use it has been anything but intuitive.

    Then life gets in the way, and I am always overwhelmed, or have something going on. For years I told myself with things slow down I'll figure out how to use the onion. It has been 5 years since I purchased this thing; life continues to be hectic. As such, despite everything going on I am determined to give this another go, and build my own cloud.


    Recently I am fired it back, up and it works. I can log in, and get to the home screen. I downloaded an app or two, but that’s it. I really want to create my own cloud (aka the Mobile Network File Server project found in Volume 1... is there a Volume 2?). Granted I have no idea how to use Samaba. I downloaded the Samba files hyperlinked under section titled ample configuration files, but I have no idea what to do now.

    If someone knows of a step-by-step instructional video, please let me know. I’ve searched YouTube and Reddit. Have not found anything.

    Thank you,

  • @Amalee welcome back 🙂

    I'm not aware of any such video however the steps look well written so perhaps you can elaborate on which steps you have completed, any specific probems you are experiencing or if you require any additional clarifications that would assist you.

  • This post is deleted!

  • Hi Crispyoz,

    Thank you for responding. I really appreciate it.

    Here is a snippet of what I tried.

    First, you can see that the apcli0 is does not have the most RX bytes and TX bytes as suggested in the instructions.

    Second, you can see in Step 4 when I tried to configure Samba an error message popped up that said permission denied.

    Any advice?

    Please & Thank You

    ![alt text](Screenshot of Onion Omega.PNG image url)

  • @Amalee The permission error is becasue you are trying to execute /etc/config/samba, this is a configuration file not an executable file. Can you post the content of /etc/config/samba. Also post the results of ps command.

    I assume you installed samba server using opkg install samba36-server , what other steps have you taken? By default samba listens on all interfaces, you can modify /etc/config/samba to force it to listen only on a single interface by adding the line:

    option interfaces 'apcli0'


    option interfaces ''

    You will also need to add firewall rules to allow access to samba ports, take a look at /etc/config/firewall and add rules for all ports:

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'udp'
    option dest_port '137'
    option name 'SAMBA 137'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'udp'
    option dest_port '138'
    option name 'SAMBA 138'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'tcp'
    option dest_port '139'
    option name 'SAMBA 139'
    option enabled '1'

    config rule
    option target 'ACCEPT'
    option src 'wwan'
    option proto 'tp'
    option dest_port '445'
    option name 'SAMBA 445'
    option enabled '1'

    Probably easier to reboot then.

    Before setting up the firewall rules I usually just stop the firewall and troubleshoot the issue and then setup the rules and restart the firewall.

    Stopping the firewall: service firewall stop

    Let us know what steps you have taken and how you are trying to access your omega samba device, using a MAC/Windows/*nix??

  • 3bb123c8-ad65-4688-a076-07a50fc9a548-Permission denied, full permissions, and no such file or directory.png

    Thank you for your patience. I had a lot to learn. and still have a lot to learn. I finally figured out how to properly download simba. I followed the instructions you provided, and even tried a much, much simple project. As you can see here, it's not working. As you can see, it says, "No such file or directory".

    Onion always tells me "permission denied". No matter what. It is not exclusive to the mobile network file server project. Permission is denied whenever I try any project or anything on my Onion Omega 2+.

    I made sure I had permission for simba (and whatever else is on the Onion), but it still says permission denied.

    It even says permission denied regarding the firewall, but I don't know what to do about that.

    Also, which isn't shown here but shown above the apcli0 is readings zeros across the board.

    Any ideas?

  • @Amalee you are receiving permission denied errors because you are trying to execute configuration files. The first command you execute is "/etc/config/samba" this a uci configuration file, you can see the content using the command cat /etc/config/samba

    Next you try to execute /etc/samba/smb/conf/conf/template which again will be a configuration file used by samba, although I think your path is wrong. Similarly /etc/config/firewall is the uci configuration file for the firewall, not a file you can execute.

    Take a look at this link SAMBA Documentation which explains how to run and configure SAMBA.

  • Install Fail.png
    Install Fail v2.png

    I know this is very noob, but I thought once I downloaded Samba (from the git hub link in https://docs.onion.io/omega2-project-book-vol1/network-file-server.html) and got RWX permissions, then I had the configuration files. (Re: my previous reply with screenshot.)

    After tried to install Samba in accordance to the documentation (https://openwrt.org/docs/guide-user/services/nas/cifs.server) as instructed. Didn't work. I included two additional pictures. They are the same, but one is marked up.

    Going to look up Sub-command-argument, but still trying to figure out a direction to solve the other parts.

    There was a page (which I regret not saving as a favorite that I followed for the firewall. I could not find it now. I did find this one though:

    Sharing Internet Access with Your Omega’s Access Point
    Out of the box, your Omega’s firewall is configured to share internet access coming from a WiFi network with devices that connect to the Omega’s AP.

    The firewall configuration file can be found at /etc/config/firewall. The contents can be modified to change your Omega’s firewall settings.

    Note that Your Omega is already configured to handle the most practical applications. You need not edit this file unless you know what you’re doing.

    To apply any firewall changes you’ll need to restart your firewall with the following command:

    /etc/init.d/firewall restart


Looks like your connection to Community was lost, please wait while we try to reconnect.