We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ fails to connect to wifi

  • I managed to make Omega2 connect my wireless network provided by Mikrotik RB951B and will share my knowledge with you guys. If you find anything wrong, please, correct me.

    Here we go:

    Mikrotik configuration:
    • Wireless
      • Frequency: auto
      • Band: 2GHz-B/G/N
      • Country: no_country_set
    • Wireless/Security Profiles
      • Authentication types: WPA2 PSK
      • Unicast Ciphers: aes ccm
    Build notes:
    • I use official LEDE sources to build the image
      • Target System: MediaTek Ralink MIPS
      • Subtarget: MT7688 based boards
      • Target Profile: Onion Omega2
    • I do not use Omega2 feeds (FTBFS during typing this post)
    • /etc/config/wireless:
    config wifi-device 'radio0'
            option type 'mac80211'
            option channel 'auto'
            option path 'platform/10300000.wmac'
            option disabled '0'
    config wifi-iface 'default_radio0'
            option device 'radio0'
            option network 'wwan'
            option mode 'sta'
            option encryption 'psk2'
            option key 'MyWPA2Key'
            option ssid 'MyWirelessNetworkSSID'
    • /etc/config/network:
    config interface 'loopback'                                                     
            option ifname 'lo'                                                         
            option proto 'static'                                                      
            option ipaddr ''                                                  
            option netmask ''                                                 
    config globals 'globals'                                                           
            option ula_prefix 'fd1d:48c4:7633::/48'                                    
    config interface 'default_radio0'                                                  
            option type 'bridge'                                                       
            option ifname 'eth0.1'                                                     
            option proto 'static'                                                      
            option ipaddr ''                                                
            option netmask ''                                             
            option ip6assign '60'                                                      
    config interface 'wan'                                                             
            option ifname 'eth0'                                                       
            option proto 'dhcp'                                                        
    config interface 'wwan'                                                            
            option proto 'dhcp' 

    Having changed those 2 configuration files, I restarted the wireless subsystem by wifi and I could read this:

    [ 1329.657946] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1331.436860] wlan0: authenticate with aa:bb:cc:dd:ee:ff
    [ 1331.459985] wlan0: send auth to aa:bb:cc:dd:ee:ff (try 1/3)
    [ 1331.468056] wlan0: authenticated
    [ 1331.475129] wlan0: associate with aa:bb:cc:dd:ee:ff (try 1/3)
    [ 1331.486320] wlan0: RX AssocResp from aa:bb:cc:dd:ee:ff (capab=0x401 status=0 aid=5)
    [ 1331.494544] wlan0: associated
    [ 1331.497749] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

    Then I verified that I obtained a network address from DHCP service running on Mikrotik:

    # ip a s dev wlan0
    8: wlan0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc noqueue state UP qlen 1000
        link/ether aa:bb:cc:dd:ee:ff brd ff:ff:ff:ff:ff:ff
        inet brd scope global wlan0
           valid_lft forever preferred_lft forever
        inet6 fe80::42a3:6bff:fec0:85e1/64 scope link 
           valid_lft forever preferred_lft forever

    The crucial part was to configure the wireless subsystem to use Client/Station (option mode 'sta') mode. The effect of this setting is following: OpenWRT/LEDE spawns a wpa_supplicant daemon for the configured interface which takes care of authentication and assiciation... See:

    $ cat /var/run/wpa_supplicant-wlan0.conf

    I can now reach my device! šŸ™‚

  • Hi Guys,

    let me add my 2 cents..

    The way I have solved my wifi issue:

    1. Check if you have issues already solved by the community, like
    • there isn't any collision going on,
    • there are no problems with the channels,
    • or the encryption,
    • or your router!
    1. wifisetup, and follow the guide
    2. vi /etc/config/wireless
    3. Focus on the ApCli settings in the wifi-iface block! It was not updated in my case and was also disabled (option ApCliEnable '0'). Add or update all the relevant ApCli options manually to your file! Like this:
    config wifi-device 'ra0'
            option type 'ralink'
            option mode '9'
            option channel 'auto'
            option txpower '100'
            option ht '20'
            option country 'US'
            option disabled '0'
    config wifi-iface
            option device 'ra0'
            option network 'wlan'
            option mode 'ap'
            option encryption 'psk2'
            option key '12345678'
            option ssid 'Omega-XXXX'
            option ApCliSsid 'MyID'
            option ApCliPassWord 'XXXXX'
            option ApCliEncrypType 'AES'
            option ApCliAuthMode 'WPA2PSK'
            option ApCliEnable '1'
    config wifi-config
            option ssid 'MyID'
            option encryption 'WPA2PSK'
            option key 'XXXXXX'
    1. wifi
    2. Enjoy your network! šŸ˜‰

    Hope this works for you!

  • How do I exit out of the config setup? So after I do the changes, how do I exit out of there to enter a new command? Thanks!

  • @Michelle-Esponda , i propose to install nano and use this instead.

    For now you can check out the manual of vi:

  • @Lazar-Demin As with T Lin, I was also only able to get this to work by downgrading my router's encryption to TKIP (and switching it to 802.11g/n mixed mode). Is it a known issue that the Omega 2+ doesn't work with AES?

  • @Narciso-Jaramillo

    as I meitoned in another thread: I can tell for sure that AES/TKIP is NOT an issue, because I was able to connect my Omega2 to my mobile (in hotspot mode) with WPA2PSK and AES. "APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!"
    All default configuration, by the way, no config files changes, etc. - problem is somewhere else (may be more than one place).
    Omega2 does NOT connect to 2 of my WiFi Routers (Mikrotik and ASUS) with the same WPA2PSK/AES

  • @Michael-Smith Same here. I've tried all the suggestions. If anybody figures it out, please let me know.

  • Yep, I also have this issue, i've made a post and gotten no help after going through every thread on this forum trying to find a solution for this issue. This is frustrating and needs to be resolved. Admins need to step up. maybe skip 2-bullet tuesday this week and address this issue.

  • Same problem here. I was unable to connect to an Mikrotik 2011UAS or a Cisco EPR2320R2. I tried everything on this post, change wifi mode, channels, AES, TKIP, no-security, edit the /etc/config/wireless and other files in console, update the module to last version (0.1.10 b160), tried Omega2 and Omega2+, exp-board, change country settings, address collisions, etc.. It works fine with my phone hotspot, but nothing with the routers, even a single DHCP request. What's wrong with this modules?

  • This post is deleted!

  • Admins please fix this issue! Is it even being investigated at all? Please let us know. I'm going to throw this thing in the trash and buy a Rasberry Pi lol

  • This is really frustrating, I have a Ruckus Router, I tried all the configuration combinations I could think of, it didn't work even with an Open Network. I used two different Ruckus Reuters R710 and R600, same result. I tried ESP8266,raspberry pi, phones , laptops..the Router works very well on the 2.4 , Not sure what to do now, should I just give up and get back to it in year or two..hoping the WiFi issues got fixed with Omega10.

  • I have exactly same issue, when connecting to my Android hotspot without any security its ok, when I try to connect it to Cisco router with WPA2PSK/AES its not working. Also LED keeps flashing and my Omega is overheating like hell (wifi-manager is using 100% of CPU). No need to post content of my configs, its the same as guys above.

    I have some ESPs, notebooks, phone etc. Everything connect just fine, but not my Omega. Could you please at least communicate where is the problem, or what are you doing to fix it? This thread is more than 3 months old and there is still problem with one of the main functions of Omega (I bought it especially for on-board WiFi support). Last admin message is 3 months old, I mean come on, guys. You screwed communication on IndieGoGo (and I got letter from you how you are making extra efford to communicate with us, the community) and now this šŸ™‚

  • @Jakub-Ludwig I solved it by changing router mode from 802.11n only to 802.11b/g/n mixed.
    Also you can play with wifi region especially if your channel on the router above 11.
    Maybe changing channel width between 20mhz and 40mhz can also help.

  • @M-S192 Thanks for tip, but unfortunately I have b/g/n already set, I have channel 3 and can't change channel width, because its router from my ISP with some customized firmware šŸ˜ž

  • @M-S192 This worked for me. Thanks! How did changing the router mode fix the issue?

  • @Nilay-Desai Well, I don't know about the mt76 driver from onion firmware but the one in official LEDE builds can disable 11n by setting htmode 'NONE' in wifi-device section. Maybe this is default behavior of onion driver.
    You can try to set htmode 'HT20' (or HT40 depending on your settings) and switch your router to 11n-only mode again.
    If this won't work I've no idea why it happens.

  • I try all solution but don"t work with my router mikrotik RB2011UiAS-2HnD-IN
    On other routers it works

  • @pvadam I had to change my country from US to CAN and that solved this whole thing
    I feel like this should be PINNED somewhere @administrators

  • I am just as disappointed, unhappy and annoyed as you guys.
    Fact is, I could not connect to any MikroTik router.
    (WPA1PSKWPA2PSK/AES, 802 b/g/n) - I am just not in the mood to play around with the settings yet.

    It did connect to my Cisco E2000 (WPA2PSK/AES)

Looks like your connection to Community was lost, please wait while we try to reconnect.