We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ fails to connect to wifi

  • @Michael-Smith Same here. I've tried all the suggestions. If anybody figures it out, please let me know.

  • Yep, I also have this issue, i've made a post and gotten no help after going through every thread on this forum trying to find a solution for this issue. This is frustrating and needs to be resolved. Admins need to step up. maybe skip 2-bullet tuesday this week and address this issue.

  • Same problem here. I was unable to connect to an Mikrotik 2011UAS or a Cisco EPR2320R2. I tried everything on this post, change wifi mode, channels, AES, TKIP, no-security, edit the /etc/config/wireless and other files in console, update the module to last version (0.1.10 b160), tried Omega2 and Omega2+, exp-board, change country settings, address collisions, etc.. It works fine with my phone hotspot, but nothing with the routers, even a single DHCP request. What's wrong with this modules?

  • This post is deleted!

  • Admins please fix this issue! Is it even being investigated at all? Please let us know. I'm going to throw this thing in the trash and buy a Rasberry Pi lol

  • This is really frustrating, I have a Ruckus Router, I tried all the configuration combinations I could think of, it didn't work even with an Open Network. I used two different Ruckus Reuters R710 and R600, same result. I tried ESP8266,raspberry pi, phones , laptops..the Router works very well on the 2.4 , Not sure what to do now, should I just give up and get back to it in year or two..hoping the WiFi issues got fixed with Omega10.

  • I have exactly same issue, when connecting to my Android hotspot without any security its ok, when I try to connect it to Cisco router with WPA2PSK/AES its not working. Also LED keeps flashing and my Omega is overheating like hell (wifi-manager is using 100% of CPU). No need to post content of my configs, its the same as guys above.

    I have some ESPs, notebooks, phone etc. Everything connect just fine, but not my Omega. Could you please at least communicate where is the problem, or what are you doing to fix it? This thread is more than 3 months old and there is still problem with one of the main functions of Omega (I bought it especially for on-board WiFi support). Last admin message is 3 months old, I mean come on, guys. You screwed communication on IndieGoGo (and I got letter from you how you are making extra efford to communicate with us, the community) and now this 🙂

  • @Jakub-Ludwig I solved it by changing router mode from 802.11n only to 802.11b/g/n mixed.
    Also you can play with wifi region especially if your channel on the router above 11.
    Maybe changing channel width between 20mhz and 40mhz can also help.

  • @M-S192 Thanks for tip, but unfortunately I have b/g/n already set, I have channel 3 and can't change channel width, because its router from my ISP with some customized firmware 😞

  • @M-S192 This worked for me. Thanks! How did changing the router mode fix the issue?

  • @Nilay-Desai Well, I don't know about the mt76 driver from onion firmware but the one in official LEDE builds can disable 11n by setting htmode 'NONE' in wifi-device section. Maybe this is default behavior of onion driver.
    You can try to set htmode 'HT20' (or HT40 depending on your settings) and switch your router to 11n-only mode again.
    If this won't work I've no idea why it happens.

  • I try all solution but don"t work with my router mikrotik RB2011UiAS-2HnD-IN
    On other routers it works

  • @pvadam I had to change my country from US to CAN and that solved this whole thing
    I feel like this should be PINNED somewhere @administrators

  • I am just as disappointed, unhappy and annoyed as you guys.
    Fact is, I could not connect to any MikroTik router.
    (WPA1PSKWPA2PSK/AES, 802 b/g/n) - I am just not in the mood to play around with the settings yet.

    It did connect to my Cisco E2000 (WPA2PSK/AES)

  • This post is deleted!

  • Think my problem is the same, but in my case I can connected to both my home access points (although I still haven't managed to set a fixed IP via dhcp), but it's my android phone's hotspot I can not connect to which is a shame as that's what I really want to connect to.
    Everything I can see suggests that all three SSIDs are using WPA2 with AES.

  • Same issue here (all those “solutions” recommended on forum – don’t work), cannot resolve for months.

    What pisses me of the most - all those "exciting news!" emails from Omega team about some new features and how cool omega 2 is. Sounds like a f%$%ing mockery, considering that basic functionality does not work (or does not work reliably).
    And what Omega team done? Correct answer – nothing, pretending the problem with WiFi does not exist.

    Don't buy Omega Onion, don't support them, may be losing money will make them do something, as civilized approach does not work.

  • As this seems to still be an ongoing issue and I've had my unit for some crazy amount of time, after testing the latest firmware every month or so I seem to have finally cracked this issue.

    No promises that this will work for everybody but it certainly worked for me.

    I have my MT set to some pretty vanilla standards

    0_1499251745653_Screenshot from 2017-07-05 20-48-35.png

    I have static channels configured

    0_1499252068013_Screenshot from 2017-07-05 20-54-06.png

    But again, all really normal bizwack.

    The only change required on my onion in order to connect cleanly was the following

    root@Omega-2EB7:/etc/config# cat wireless 
    config wifi-device 'ra0'
            option type 'ralink'
    #        option mode '9' # This doesn't seem to work on an MT
            option mode 'sta' # This works on an MT
            option channel '6' # This shouldn't be required to be a number and can be left as 'auto'
            option txpower '100'
            option ht '20+40' # Meh, 20, this works but so does 20 or 40 from memory
            option country 'AU' # Whatever your country is
            option disabled '0'

    I'm not going to say that this is the magic bullet but it certainly got me up and running.

    Caveat I still don't have network access other than ICMP. I think this is a firewall issue on the unit itself but I can't work it out yet. This is just my first step so sharing in case it corrects the problem for anybody else.

    Hope that helps somebody

  • @Scott-Horsley thanks! I wasn't able to reproduce your config - for me, the change from option mode '9' to 'sta' doesn't change a thing. I still get "wlan1: disconnected, unicast key exchange timeout" in router logs.

    However, I made some observations that might help you move forward:

    • with option mode 'sta' and security profile on Mikrotik set to default (open - no password), my Onion2 connects to wifi (!)
    • I also observed only ICMP traffic passing through
    • it seems to be a local firewall issue, as Mikrotik sniffing shows no outbound attempts
    • you can disable Onion firewall by /etc/init.d/firewall stop, but it doesn't change a thing - the only traffic that the router receives is ICMP and ARP, but not TCP


  • @Scott-Horsley further observations:

    • firewall is controlled by fw3 which in turn controls iptables
    • flushing iptables (iptables -F) does not solve the problem
    • a device connected to the Omega can connect to the Internet but DNS won't work (seems to be an issue with Omega's NAT config)
    • if you instruct iptables to log outbound traffic (iptables -t filter -A OUTPUT -o apcli0 -j LOG), then dmesg actually shows those missing packets that don't arrive to the router

    Seems like there is a second firewall layer after iptables are applied.


Looks like your connection to Community was lost, please wait while we try to reconnect.