We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ fails to connect to wifi

  • @Diego-Sueiro
    I finally seem to have got mine connecting to wifi now on each reboot (still can't quite believe it!).

    Here's my etc/config/wireless:

    config wifi-device 'ra0'
    	option type 'ralink'
    	option mode 'sta'
    	option channel 'auto'
    	option ht '20'
    config wifi-iface
    	option device 'ra0'
    	option network 'wlan'
    	option mode 'ap'
    	option ssid 'Omega-831B'
    	option encryption 'psk2'
    	option key '12whatevr'
    	option ApCliAuthMode 'WPA2PSK'
    	option ApCliEncrypType 'AES'
    	option ApAuthMode 'WPA2PSK'
    	option ApCliSsid 'ap7411'
    	option ApCliPassWord '123yadayada'
    	option ApCliEnable '1'

    I don't know what most of these do but they all seem to matter and the ORDER also seems to matter! (for some). Specifically ApAuthMode I tried right after key but it didn't like it!

    No "config wifi-config"...reqd info is in the iface.

    device mode 'sta' works for me. Could also try ap or adhoc. '9' just didn't do it for me!

    Anyway, now that I've posted this it'll probably break so speak to ya soon!

  • @Alex-Thow ,

    Changing option mode '9' to option mode 'sta' lets the option ApCliEnable '1' to persist across reboots.

  • This is beyond frustrating and idiotic . I have been modifying small routers with DD-WRT for years, setting up everything in config files, without the aid of any web or graphical interface.

    I have ~15 years experience with linux and unix systems , yet for the past four days i'm banging my head against the monitor , setting up a device that is supposed to be "beginner friendly" .

    This is bad engineering to say the least, and disrespect for the people who bought this device .
    Do not consider this post as a rant, but rather a wake up call for those who built and sell this device .
    Either stick to your claim that this device is beginner friendly, of say the goddam truth that even expert level will find this difficult and confusing.
    And for the love of god, write BIG on the disclaimer "WE DO NOT HAVE DOCUMENTATION" . Besides an youtube clip and some truly misleading tutorials, there is nothing useful.
    Advanced documentation on config files ? - We don't have that ! The documentation you published is NOT accurate !!

    Thank you, and please excuse my angry post, but your device got me on this level ..

  • @Alex-Thow I tried your config.. In my case, it doesn't work no matter what router i use ( i have 10 various routers, and i had the patience to test them all.. two times in a row ) .

    So can you please elaborate a bit on your setup ?

  • I have found the issue with the web setup and the real reason why no one seems to be able to connect the device to any wireless network. What i did, in steps, so anyone can reproduce .
    1 - Reset the device to factory defaults ( VERY IMPORTANT if you tested and failed to setup wireless before ).

    2 - immediately after successful boot, connect to the WIFI AP that Omega2+ sets up, but DO NOT connect to the web setup.

    3 - log-in to SSH or serial console, and edit /etc/config/wireless ( vi /etc/config/wireless ).

    4 - Remove the line 'option country 'US' . If you will read the OPENWRT documentation, you will see that this setting is NOT mandatory, but it has an adverse effect for anyone that has the router set to any NON-US country. Apparently, the devs from Onion live under the impression that there is only US in this world.....
    Save the file ..

    5 - reboot the device, connect to the wireless AP set by the device, and run the web setup. For me it was successful , but i will gladly help anyone, as the admins from Onion seem to be clueless ...

  • @Scott-Horsley I can confirm this working on my mikrotik router, after 48+ hours of frustration and head-banging against the monitor . Great job !!

  • @Michal-Rok Okay, you are a genius!

    That is working, however, still unsure why setting it after connection changes anything.

    Even more so, it appears that without setting mode sta it doesn't even appear to attempt to connect with the router.

    Would really love to know what the mode flags do to the ralink device!

    Using rc.local is of course the key to getting this working after the fact but I feel dirty leaving it as a proper solution.

    Thanks to anybody and everybody that put effort in here, I think we have a (albeit, not perfect) working solution.

    Can anybody else confirm this works on other MT units out in the wild?

    I'm doing this on a 2011UAS-2HnD but I believe it should work on any unit of them.

  • @Mikaël-PIRIO Thanks for all your efforts. After a day of frustration, I found your post. Following your advice, I was finally able to connect to my home wifi.

  • @Alex-Thow Yay - finally - worked for me. thanks.

  • @Michal-Rok
    I have spent hours on the "Omega2+ fails to connect to Wifi" issue (like many people ...)

    Starting from a fresh Omega2+ (with factory resetting if needed and without using the set up wizard), I have followed your http://community.onion.io/post/13769 post and added the following lines at the end of the /etc/config/wireless file :

    config wifi-config
    option ssid 'xxxxxxxx'
    option encryption 'WPAPSK'
    option key 'xxxxxxx'

    I have also replaced WPA1PSK by WPAPSK (twice in the config file) and removed the 'option country 'US' line (http://community.onion.io/post/13801).

    After rebooting the Omega2+, I have checked that the date and internet access are now correct :

    root@Omega-2771:~# date;ia
    Sun Sep 3 14:35:42 GMT 2017
    apcli0 Link encap:Ethernet HWaddr 42:A3:6B:01:27:71
    inet addr: Bcast: Mask:

    Thank you @Michal-Rok and @Ganescu-Theodor for postings your recipes.

    I also thank the people of http://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/ for their posts which also helped me in elaborating my own recipe.

    I hope that that my post will be helpful for people having this kind of issue.

    PS : I agree with @Ganescu-Theodor when he writes "This is bad engineering to say the least, and disrespect for the people who bought this device"(http://community.onion.io/post/13794)

    And now I am going to manually install the console.

  • I had to upgrade from 0.1.5 (b130) to 0.1.10 (b160) since uci get system.@led[0].sysfs gave onion:amber:system (wrong answer) instead of the expected answer : omega2p:amber:system.

    What I wrote in my previous post (http://community.onion.io/post/14346) remains valid since the config files (/etc/config/wireless and /etc/rc.local) have been kept unchanged during sys upgrade.

  • @Gerald-Schalek Hi, I've got the same issue with WPA2PSK/AES WiFi router with the password Zyx12abcd%
    It doesn't work on both Omega2 and Omega2+ with the latest firmware. Did you use some workaround to setup the password in /etc/config/wireless (i.e. some quotes or smth like 🙂 )?

  • By removing country and changing mode to sta in the wireless config and following @michal-Rok i could connect to my MT rb2011, however could not connect to the internet! In frustration i turned my laptop into a hotspot and connected/upgraded etc with few issues.
    I have upgraded to 0.1.10 B160 however that has not helped connection to MT. I too have wasted hours on this and will 'pause' in the hopes the Onion team will actually look into this and come up with a permanent solution.
    Concur with the sentiment about poor engineering/support when a product like this will attract users with MT routers. I'm not an expert on openwrt however would have thought there's a simple solution!

  • 6 months after I posted problem in this thread and its still not resolved. I have my Onion Omega 2+ with latest firmware 0.1.10b160 and LED is still blinking, web console shows directory listing of ".." and "/lib", wifimanager still takze 100% of CPU, Omega is overheating as hell and I can't connect it to any Wi-Fi (secured or android hotspot unsecured). I tried every dirty trick in this thread (sta mode, deleting country, factory reset).

    If I try to configure it from SSH after first reset all data are back (wifi settings etc), poweroff and reboot commands are doing nothing ...

    Any ideas? What is the money-back policy for IndieGOGO campaign? Because right now it is useless piece of hardware, every stupid ESP clone around is far more user friendly than this thing 😞

    @administrators Hm?

  • @pvadam wwujjuuu muchas gracias, funciono totalmente

  • After many hours, wasted on Wifi connection problem resolving, find solution for me.
    manually setup my Omega 2 WiFi network before start setup Omega2 (b160) in web mode after upgrade.

    My home WiFi Ap name is 'dd-wrt'
    Work usually in b/g mode with TKIP encription

    Most successfully variant for me at start point - has been set WEP and 'no password mode' on router for upgrade Omega2 to (b160) version of firmware.
    And I'd set back WPA-Personal mode and TKIP on Wifi router.
    After as I made this, I meet only the troubles with my Omega2 connections.

    My Omega 2 is:
    Firmware 0.1.10 (b160)
    Latest Firmware 0.1.10 (b160)

    Linux Omega-4C77 4.4.46 #0 Thu Feb 2 23:46:03 2017 mips GNU/Linux

    What I do for resolving connection problem:

    1. Made factory reset via web interface (

    2. Connect with Putty to (ssh, port 22) as root/onioneer

    3. root@Omega-4C77:~# vi /etc/config/wireless
      change your ssid and password AND COUNTRY! from 'US' to 'CAN'. It is needed for WiFi change channel restrictions (I'm not sure, but... it's work):
      warning: In Bold - options, which I changed from original values, but remember: it's must be in correlation with your wifi router settings. use omega2 linux command aps for router connect information. Something like a
      6 dd-wrt c8:3a:35:ea:29:58 WPAPSK/TKIP 52 11b/g NONE In in my case

    config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'CAN'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ApCliEnable '1'
    option ApCliSsid 'dd-wrt'
    option ApCliAuthMode 'WPAPSK'
    option ApCliEncrypType 'TKIP'
    option ApCliPassWord '0015081975'
    option ssid 'Omega-4C77'

    1. Save your work in vi: <esc> :wq
    2. root@Omega-4C77:~#service network restart, reconnect Putty
    3. check 'root@Omega-4C77:~# ping' - it must work now
    4. opkg update
    5. opkg install mc - it is not very important step 😉
    6. go again into web interface (, btw, after as I connected to my Omega-4C77 AP again, it's already works as router - internet on PC is exists now), and step by step complete setup procedure.
      But do not choose WiFi network setup, it's defined already at step 3. Choose "pass step".

    Sorry for my Martian

  • So here's a good one for y'all couldn't get it to connect tried accessing it several times through web interface then through SSH no luck on either end

    But then right as I was about to give up on it I took a smoke break and came back and low and behold the web interface worked... I really want to beat my head against the screen...

  • I must have read all these messages a hundred times without success and finally bought a new router that uses AES instead of TKIP and that was the breakthrough. So after owning two Omega2+ for 6-8 months and not being able to get past first base I started to build something useful. Then I connected an I2C device to one of them and found that the i2cdetect python command does not work There are many many messages devoted to this topic and again the developers of this product sit on their hands.

    Life is too short to spend playing around with a bug ridden immature device such as the Omega2 so you've lost me Onion Community. Bin your Omega2 and sleep again at night.

  • @David-Lochlin je suis d'accord, dommage sa petite taille été un super avantage mais bon les développeurs on tellement passé de temps a vouloir le vendre a tout prix en dénigrant les autres produits du même genre qu'ils ont oublié de finir leurs propre produit.
    Au suivant!!!

  • @pvadam
    Good. Really good answer. Enable appcli did the trick !

Looks like your connection to Community was lost, please wait while we try to reconnect.