We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Wifi connection problem with Omega2

  • @mehmet-bozkurt Could you post content of your /etc/config/wireless config file and aps command output?

  • @Mikaël-PIRIO ok here is it.

    ~~config wifi-device 'ra0'
    option type 'ralink'
    option mode '9'
    option channel 'auto'
    option txpower '100'
    option ht '20'
    option country 'US'
    option disabled '0'

    config wifi-iface
    option device 'ra0'
    option network 'wlan'
    option mode 'ap'
    option encryption 'psk2'
    option key '12345678'
    option ApCliEncrypType 'AES'
    option ApCliAuthMode 'WPA2PSK'
    option ssid 'Omega-A1AF'
    option ApCliSsid 'WoLFStationLVLm'
    option ApCliPassWord 'xxxxx'
    option ApCliEnable '1'

    config wifi-config
    option ssid 'WoLFStationLVLm'
    option encryption 'WPA2PSK'
    option key 'xxxxx'

    WRTnode AP scaner.
    Begin scaning APs, pls wait...
    APs available are...
    ra0 get_site_survey:
    Ch SSID BSSID Security Signal(%)W-Mode ExtCH NT
    6 WoLFStationLVLm 4e:66:41:56:b3:53 WPA2PSK/AES 100 11b/g/n NONE In
    6 ZyXEL fc:f5:28:f7:dd:6f WPA2PSK/AES 0 11b/g/n NONE In
    6 123efe e8:94:f6:fb:d9:2a WPA2PSK/AES 0 11b/g/n BELOW In
    7 AgaKa-2 f0:b4:29:59:fe:39 WPA1PSKWPA2PSK/TKIPAES 10 11b/g/n ABOVE In
    7 WoLFStationLVL4 4c:5e:0c:70:fd:b0 WPA2PSK/AES 94 11b/g/n ABOVE In
    10 Fiberhat_Balcioglu a4:2b:b0:fd:d4:12 WPA2PSK/AES 0 11b/g/n BELOW In
    11 Elin ec:08:6b:f0:33:f4 WPA2PSK/AES 0 11b/g/n NONE In
    11 agakax 18:28:61:f8:ab:3d WPA2PSK/AES 24 11b/g/n NONE In

  • @mehmet-bozkurt Your config file seems to be OK 😔 .

    Have you check your subnet: no collision (see here)?

    Perhaps could you try to force option channel to '6'? Run nr command after and check if you get an IP with ia command...

  • @Mikaël-PIRIO no collision. its on different subnet. how can i force channel to 6? on router side ?

  • @mehmet-bozkurt No. In your /etc/config/wireless config file, in the "config wifi-device 'ra0'" section.

  • @Mikaël-PIRIO same result. btw i found my "xiaomi mi router nano" and seems omega2 can connect this router too.
    seems something wrong on omega2 firmware side

  • Call me crazy, but I had a wifi password of 63 characters, including special characters like space, ',' and even '<'. I changed it to a normal 12-character password and now my Omega2 can connect.

  • Hi,
    Is there someone from Onion team working on this issue ?
    I've made upgrade to latest firmware and none of my two Omega2 boards doesn't connect to my WiFi (Mikrotik WPA2).
    Old Onion works OK.

    For now I have to small bricks on my desk..

  • Hello everyone,

    As far as I've noticed, there's something really weird happening. Since I got my Omega2+, I tried for a few hours to get it online, with no succes. Ultimately, by continuosly re-scaning for wifi networks, I stumbled upon my personal one. But when I tried to connect to it, it was unsuccesful, and when I re-scanned for SSID's, it was gone again. So I thought to myself, I'll just play for the lottery, and have patience...and yes, somehow, the omega seems to have connected for a few moments to my wi-fi network, allowing me to update it to the latest firmware, and afterwards, to connect to it...but ONLY locally. Right now, I am still unable to connect to my wi-fi network...and don't worry, I've been through every suggestion I could find on this community( there isn't any collision going on, there are no problems with the channels, or the encryption, or my router). It would seem that it just connects and disconnects as it pleases, whenever it pleases...it works perfectly fine as a local AP, but that's it...what is even more weird, is that, when I am connected to it, it implies that I do have internet access, although I don't. Well, anyway, don't know how much this helps...all I have to say is that I am quite disappointed...I've been waiting for this since August, and apparently it's full of bugs and I can't use it for anything, for now. I hope you guys figure it out soon, best of luck and kind regards!

  • Here is how I solved my wifi issue:

    Hope this helps!

  • Hello @Victor-Iriciuc , welcome to the club of "angry birds".
    Yea almost everyone can sing a song about something who is not working.

    First of all, you addressed your problem to the community, @administrators sometimes catch up here some troubles but first they let us, the community help you. So be patient with us 😉

    The devices and the Docks are very sensitive for current fluctuations. So if you do a photo-shooting of your installation/devices you have a bigger chance that the crack' s here can give you a good advice to solve currencies troubles (include the dock or your direct power-source in your pictures).

    Also if there would be a Hardware Problem the pictures would help to get an RMA ... see Guidelines on top of page.

    Then you said you could update, to witch version? There is a new online.

    I've been waiting for this since August, and apparently it's full of bugs and I can't use it for anything, for now. I hope you guys figure it out soon, best of luck and kind regards!

    I guess there where thousands of backers who waited as you ... and hundreds who are disappointed somehow (inclusive me ).

  • @Victor-Iriciuc
    I may be wrong, but I think Kickstarter type companies should change their policies. The prototype product should be 90% fully functional. The public funding should be for final testing, and all the manufacturing and supply chain details. After a predetermined period and fully funded, and 100% completed, the product should be ready to sell to the general public and hopefully will be a success. I know in the real world, it doesn't quite work that way. Just my opinion.

  • @Victor-Iriciuc
    Sympathize with you. I have almost the same problems. But my device just does not connect to Wi-Fi. At all!
    We see now a very bad attitude of developers to those who supported!

  • So... to get mine to connect I had to create a new SSID that ONLY provides 2.4GHz. My normal one does both 2.4 ad 5 on the same SSID which seems to confuse the Omega2.

  • Same problem with Omega2 - can not connect to Wifi router (ASUS RT-AC66U). Omega 1 connected perfectly under exactly the same conditions. Spent hours trying different solutions described on forum - no luck.

    Seems like I have to put my 4 Omegas in the box for some time and go back using ESP8266 based boards - may be Omega team will solve it some day. Guys, when basic/core functionality of the device is so buggy and unreliable - this is crap, I'm sorry to say that even if it disappoints all those people excited about KickStarter concept, "visionaries", "innovators", who is working hard, etc., etc.

    All the configs are pretty much default
    output from aps:
    ASUS_24G 74:d0:2b:3f:ce:f8 WPA2PSK/AES 63 11b/g/n

    uci show wireless

    root@Omega-379D:/# uci show network

  • @Michael-Smith

    Completely agree this is bullshit. Step 2 of the INITIAL setup should be bug free. Did it go through any QA at all?

  • @Nilay-Desai Bought the first Omega with the thought I would use it with the camera, guess what, they never got the camera working and dropped it all together. Some will say use a web cam not the original idea.

  • This post is deleted!

  • @Michael-Smith The fix for me was to downgrade my router from AES encryption to TKIP (which required me to also switch it from 802.11n to 802.11g/n mixed mode), and then follow the steps in https://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/25 to fix up /etc/config/wireless (although it's possible that after switching the router config the standard setup might have just worked).

    It's a bummer that AES isn't currently supported. Hopefully that will get fixed.

  • @Narciso-Jaramillo
    Thank you for suggestion, though it didn't work for me. Most likely there is more than one issue with WiFi (not only TKIP/AES matter). Also, TKIP is far less secure than AES (https://security.stackexchange.com/questions/123091/is-wpa-psk-aes-safer-than-wpa-psk-tkip-aes).

    I can tell for sure that AES/TKIP is NOT an issue, because I was able to connect my Omega2 to my mobile (in hotspot mode) with WPA2PSK and AES. "APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!"
    All default configuration, by the way - no config files changes, etc. - problem is somewhere else (may be more than one place).

    To summarize: no way to debug Omega2 Wifi (no meaningful logs) and no working solution at the moment to connect to 2 of my WiFi Routers (Mikrotik and ASUS).

Looks like your connection to Community was lost, please wait while we try to reconnect.