We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Wifi connection problem with Omega2

  • Here is how I solved my wifi issue:

    Hope this helps!

  • Hello @Victor-Iriciuc , welcome to the club of "angry birds".
    Yea almost everyone can sing a song about something who is not working.

    First of all, you addressed your problem to the community, @administrators sometimes catch up here some troubles but first they let us, the community help you. So be patient with us 😉

    The devices and the Docks are very sensitive for current fluctuations. So if you do a photo-shooting of your installation/devices you have a bigger chance that the crack' s here can give you a good advice to solve currencies troubles (include the dock or your direct power-source in your pictures).

    Also if there would be a Hardware Problem the pictures would help to get an RMA ... see Guidelines on top of page.

    Then you said you could update, to witch version? There is a new online.

    I've been waiting for this since August, and apparently it's full of bugs and I can't use it for anything, for now. I hope you guys figure it out soon, best of luck and kind regards!

    I guess there where thousands of backers who waited as you ... and hundreds who are disappointed somehow (inclusive me ).

  • @Victor-Iriciuc
    I may be wrong, but I think Kickstarter type companies should change their policies. The prototype product should be 90% fully functional. The public funding should be for final testing, and all the manufacturing and supply chain details. After a predetermined period and fully funded, and 100% completed, the product should be ready to sell to the general public and hopefully will be a success. I know in the real world, it doesn't quite work that way. Just my opinion.

  • @Victor-Iriciuc
    Sympathize with you. I have almost the same problems. But my device just does not connect to Wi-Fi. At all!
    We see now a very bad attitude of developers to those who supported!

  • So... to get mine to connect I had to create a new SSID that ONLY provides 2.4GHz. My normal one does both 2.4 ad 5 on the same SSID which seems to confuse the Omega2.

  • Same problem with Omega2 - can not connect to Wifi router (ASUS RT-AC66U). Omega 1 connected perfectly under exactly the same conditions. Spent hours trying different solutions described on forum - no luck.

    Seems like I have to put my 4 Omegas in the box for some time and go back using ESP8266 based boards - may be Omega team will solve it some day. Guys, when basic/core functionality of the device is so buggy and unreliable - this is crap, I'm sorry to say that even if it disappoints all those people excited about KickStarter concept, "visionaries", "innovators", who is working hard, etc., etc.

    All the configs are pretty much default
    output from aps:
    ASUS_24G 74:d0:2b:3f:ce:f8 WPA2PSK/AES 63 11b/g/n

    uci show wireless

    root@Omega-379D:/# uci show network

  • @Michael-Smith

    Completely agree this is bullshit. Step 2 of the INITIAL setup should be bug free. Did it go through any QA at all?

  • @Nilay-Desai Bought the first Omega with the thought I would use it with the camera, guess what, they never got the camera working and dropped it all together. Some will say use a web cam not the original idea.

  • This post is deleted!

  • @Michael-Smith The fix for me was to downgrade my router from AES encryption to TKIP (which required me to also switch it from 802.11n to 802.11g/n mixed mode), and then follow the steps in https://community.onion.io/topic/1149/omega2-fails-to-connect-to-wifi/25 to fix up /etc/config/wireless (although it's possible that after switching the router config the standard setup might have just worked).

    It's a bummer that AES isn't currently supported. Hopefully that will get fixed.

  • @Narciso-Jaramillo
    Thank you for suggestion, though it didn't work for me. Most likely there is more than one issue with WiFi (not only TKIP/AES matter). Also, TKIP is far less secure than AES (https://security.stackexchange.com/questions/123091/is-wpa-psk-aes-safer-than-wpa-psk-tkip-aes).

    I can tell for sure that AES/TKIP is NOT an issue, because I was able to connect my Omega2 to my mobile (in hotspot mode) with WPA2PSK and AES. "APCLI LINK UP - IF(apcli0) AuthMode(7)=WPA2PSK, WepStatus(6)=AES!"
    All default configuration, by the way - no config files changes, etc. - problem is somewhere else (may be more than one place).

    To summarize: no way to debug Omega2 Wifi (no meaningful logs) and no working solution at the moment to connect to 2 of my WiFi Routers (Mikrotik and ASUS).

  • First, Omega do not support 802.11ac, so please connect to 2.4GHz
    Second, Please use AES
    Third, please change option ht '20' to option ht '20+40'

  • Well, guys. I've had the same trouble with wifi but I solved it by changing router mode from 802.11n only to 802.11b/g/n mixed.
    That's f**king stupid because Omega 2 should support 802.11n according to the docs.

  • I have never been so frustrated by something this small. The good thing is it was cheap, so when I smash it with a hammer I wont feel so bad.

  • Hi,
    Ca we get any response from Omega team ?
    This is starting to be some kind of grotesque. I bought them in first kickstarter campain and never used since they can't connect to my WiFi router (Mikrotik).
    I've spend days playing with router settings, AES/TKIP, b/g/n every parameter you name it - I tried to change it and still I have two pieces that can't be even paper weight since they are so light 😕

    Guys do you have anyone in your team who is working on this or you just filled bug in LEDE and are waiting for someone to fix this ?

    I recomended you product to friends and now I have to explaing to some of them why they bought bricks..

  • Same issue here (all those “solutions” recommended on forum – don’t work), cannot resolve for months.

    What pisses me of the most - all those "exciting news!" emails from Omega team about some new features and how cool omega 2 is. Sounds like a f%$%ing mockery, considering that basic functionality does not work (or does not work reliably).
    And what Omega team done? Correct answer – nothing, pretending the problem with WiFi does not exist.

    Don't buy Omega Onion, don't support them, may be losing money will make them do something, as civilized approach does not work.

  • Me too I had problems to connect my Onion2+ to my router via WiFi. What I have concluded, apart from the advises of the other community members, is that the signal reception on Omega2+ is very very weak, it may detect the wifi network but it is unable to connect to it.

    So my 2 cents on this adventure is to make sure that your Omega2 and your router are very close to each other when you are trying to connect.

  • @elefas-GR said in Wifi connection problem with Omega2:

    So my 2 cents on this adventure is to make sure that your Omega2 and your router are very close to each other when you are trying to connect.

    For the same reason, connecting an external antenna can help a lot, I recently learned!

    I had a case where connecting the Omega to the access point was really impossible. By chance I had a 2.4GHz WiFi antenna plus connector cable lying around (belonging to other equipment) that matched the Omega2's antenna connector. I connected it without expecting too much, but - wow! The signal strength as shown by iwinfo was 30db better. That's a huge improvement! And that Omega works fine since, in the exact same environment where I wasn't able to even establish a connection a single time before.

  • @luz Did you remove the resistor as suggested by Ken Konrad, so as to disable the internal antenna?


  • @Venet said in Wifi connection problem with Omega2:

    @luz Did you remove the resistor as suggested by Ken Konrad, so as to disable the internal antenna?

    No, I didn't.

    Now as you mention it, I remember having read that suggestion a while ago. Sounds like a logical thing to do - but as good as the WiFi is now as-is, I feel no immediate urge to treat my Omega2 with the soldering iron 😉

Looks like your connection to Community was lost, please wait while we try to reconnect.