We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Drag and Drop programming from Video

  • In the video for the Omega 2 kickstarter, they show some kind of "drag and drop" programming. How is this accomplished and what is needed for this? I havent seen anything regarding this at all. Was is smoke and mirrors for the video?

  • hey

    that was 'node red' running on the omega

    i'm currently going through the process of installing it, it requires a usb flash drive as node red requires more ram that what the omega has and more storage than what the omega has, you then have to go through a process of utilizing the usb to create this

    im going to see though ( i asked on another thread no response yet) if i can instead do this with the sd card slot to free up the usb port

    good luck as it looks like a bit of a process

  • @Shanan-Clark I strongly suspect that using an SD card rather than a USB drive will work - I am all set up with extra disk space and effective extra RAM space via swap partition using a USB drive.I can't see why it wouldn't work on an SD card but haven't had tiem to try it yet - I hope it does work

  • hi

    i am attempting to utilize the micro sd card (as i have an omega2+ built in micro sd card) to create extra storage and virtual ram
    so frustrating everything seems super fragile, takes lots of attempts
    again took me along time to even identify the sd card, following the tutorial to format ext4 didn't work
    i had to download a windows formater stick the card direct into my pc to do it

    but anyways sorry about the rant
    i found the sd card (not where documentation directed me) but by typing in 'df' into command line
    found the command 'df' by randomly googling it, i couldn't find command 'df' in help docs
    now for some reason my omega keeps dropping the mounted sd
    i can see it, i can see where the file is, then i try and do something to it and it can't access that file
    i do 'df' again and it is gone!!!
    so i eject it and reinsert if 'df' and its back ... sometimes
    super frustrating
    finally got to creating swapfile (extending the built in ram this is to get enough ram to run node red)
    by following documentation

    following the documentation i get to this point
    the command 'swapon' (which was the next tutorial step) to initiate the swap file comes up as an error !!

    -ash: swapon: not found

    here is the command i typed in
    swapon /tmp/run/mountd/mmcblk0p1/swap.page

    can someone please help ? what is wrong with that command and why is the micro sd constantly dropping ? when i say constantly it can stay up for 2 minutes or10 seconds - not sure if it doesn't like a failed command and it drops it, or it just drops by itself, from what i can see it seems to be random

    sorry guys i really want this to work

  • thinking about this logically
    if i have a micro sd card inserted in the builtin dock of omega 2+ and i can see it by typing 'df' into command prompt
    and then not do anything but wait 2 minutes, type 'df' again and i can't see the sd card
    is this right or wrong ( only reason i can think of, of why it would automatically not show is if it was automatically dismounting because of no activity) otherwise i think its broken, which im guessing it is

    secondly, command 'swapon' i don't think according to the documentation should come up with swapon: not found
    i mean to get to the point of initiating the swap file i used 'mkswap' which worked, swap file is working i just can't get that one command to work, why

    i just don't know if im doing something wrong, the documentation is wrong, or the device is broken
    so frustrating for new users, not one step has worked correctly yet

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.