We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

[SOLVED] Omega can't connect to WiFi

  • Hi,

    I unpacked my Omega, connected it via USB and tried the setup wizard. Typed my Wifi data and all i got was "cannot connect to wifi". Unfortunately i have no ethernet expansion...

    Thanks for helping šŸ™‚


  • update: it's silent now... no wifi network detected (the Onion Access Point) and the connection via serial will only bring a dark empty console... Amber LED never flashed since I switched it on the very first time.

  • @Nito-Weber So you were able to connect to the serial console? Can you take a screenshot so that we can figure out what's going on? Did you press ENTER after getting into the serial console to activate the command prompt?

  • I WAS able but now i'm not anymore... i tried another cable but there isn't even the bright green LED lit. my serial console was just black. tried enter but no reaction.


  • weird things are happening: I touched the small 8 pin chip on the omega and the amber light began flashing šŸ˜® now it's light. but i still can't set up serial connection via PuTTY and the Setup Wizard isn't working either. BUT i can see it's access point again, although the green LED is still off

  • seems to be a slack joint between the onion and the expansion dock.

    set up serial:


  • upload-a89b8eae-8012-448d-9f3e-fdb76bfb8e61

  • @Nito-Weber I think i see what's going on now. There seems to be a bug with our wifisetup script. Do you see how it says wlan0: link becomes ready? that shows the wifi was correctly connected. After the wifi connects, the wifisetup scripts tries to ping the Onion server to see if the device is actually on the Internet. When it cannot ping our servers, it will revert the settings back to the default setting.

    What you should do now is to run wifisetup again. As soon as you see

    wlan0: link becomes ready
    wlan0-1: link becomes ready

    press Ctrl+C to terminate the wifisetup script. And your Omega should still be connected to your wifi networks.

  • Thanks a lot!!


    how can i check if my onion is connected to the internet?

    and can i fix this bug? i guess this will repeat everytime i try to access a new wifi network, right?

  • well, i tried to update the firmware... didn't work šŸ˜ž


  • any suggestions, @Boken-Lin ? šŸ™‚

  • administrators

    @Nito-Weber it looks like the Omega doesn't have access to the internet, can you try running wifisetup -checkconnection and post the output?

  • @Nito-Weber Or can you try to do ping google.com to see if you can connect to the google servers?

  • I had a similar hiccup, but managed to work though it.

    I setup the Omega with just a USB charger to power the Omega, and my Chromebook to connect to it via wireless. First I connected to the Omegs'a WiFi network. After logging in and entering the details for my wireless network I clicked the connect button. It said that it had failed to connect. I had a suspicion that it did connect (I typed the password correct) and was sitting on the network. I loaded up Fing on my Android phone and did a network scan. Any network scanner will do though. I found a new device named Omega-ABCD on my network.

    My Chromebook had already reconnected to my previous network, so I typed in the IP address of the Omega I found during the network scan. Once typing in the IP in my browser (Chrome, it's a Chromebook), I was presented with the Omega's login page. I logged in again, and was slightly surprised to be asked for the WiFi password again. Not a big deal, as I entered the wireless network's password again and clicked connect. This time it proceeded to the next page and began to update the Omega.

    Once the update page's status read "Done". I visited the IP of the Omega again. Note, I didn't press F5 to refresh. I just visited the root address of the IP/URL Your IP address will most definitely be different than mine is. You'll have to do a network scan to find the Onion on your network.

    I'm was then able to login to the Onion Console., update settings, visit terminal, etc..

  • Thank you very much for all the kind tips @Lazar-Demin @Boken-Lin and @Mike šŸ™‚ !

    Unfortunately none of them worked BUT i have an idea about the cause now: i live in a student dormitory and normally we need a code/password for every device to access the network (not the wifi). however in my room there is no code needed normally (seems to be a friendly bug there) so i can connect every device to the house's network through my own wifi. since the onion connects to the wifi but then aborts because it won't find a connection to any server i think i need to type in that network password too. but where? I hope you will understand this confusing way of network security here šŸ˜„

  • @Nito-Weber This wiki might be helpful to you: https://wiki.onion.io/Tutorials/Connecting-Omega-to-Wifi-Hotspot-that-Requres-Login. Please let me know if this helps!

  • When I received my Omega I could not connect it to my WiFi network. However I could with my Android phone see Omega-1D1D as a hotspot access point so I connected to it , noted the IP address then used the browser on my Android to connect (can't remember if I had to login) then it offered the setup wizard and updated the firmware. Sorry can not remember the full sequence but a bit hassled at the time trying to get it to go. My private WiFi network was on 10.0.x.x once the wizard had finished and I had added my network Omega was given a new IP in the 10.x.x.x range and now connects OK every time.

  • Thank you for your help @Anthony-Wakefield and @Boken-Lin !

    I tried the wiki and thought it might work but it didn't... Just to get it right: I log in to the omega AP and then browse whereever to get a site to log in to the network THROUGH the omega? at least, that is what i tried now and it didn't really work. I get an IP adress but there's still no network/internet connection.

    I tried @Anthony-Wakefield 's version both with Android and iOS but i cannot access the IP through the phone's browser. "This website isn't available"...

  • upload-6dafabc8-21d6-4f56-bba8-01c533573201

    that's how far i got with the wiki...

  • @Nito-Weber Ah, you need to edit that file. With the command you entered, you were trying to execute the file as a program. Try vi /etc/config/wireless or nano /etc/config/wireless. Although you'll need to install nano first.

Looks like your connection to Community was lost, please wait while we try to reconnect.