We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Expansion Dock LEDs seem not to work. (O2+)

  • When I first power on the Omega 2+ in the Expansion dock, the dock's LED comes on (Red) for a moment, then goes out. The Omega + continues to boot up, working just fine. I get all my connections, the GPS chip works, OLED works, but the Expansion dock's LED never comes back on until I turn off the power and turn it back on again.

    I have tried multiple values in for 'expled' but none seem to do anything. No errors are returned, it just doesnt light up at all. Even using the example from the documentation.

    Am I missing something? Is there a package that needs to be installed that isnt obvious?

  • I have the same problem here, I just tested the example from the oficial page but nothing happens.. Example:
    root@Omega-####:~# expled 0xf21133
    Setting LEDs to: f21133
    Duty: 6 94 80

  • I had the same problem, but you can operate the LEDs by writing to the relevant GPIO addresses. Set direction then set to 0 to switch on the relevant colour LED.

  • This is not a problem. This is by design to protect the GPIOs. The docs provide LED use examples here:

    PS: I'll admit that the expled command should be more intelligent, and ask the user to switch the GPIO LED pins to OUTPUT if it notices they are in INPUT mode (and the WARNING about switching to OUTPUT mode too, especially for cases where the Expansion Dock is not used).

  • Tnks Alan and fossette, setting the GPIO LED pins to low worked.

  • After manually setting the three GPIOs to Output the LED turned on.

    However neither using the expled command on the CLI nor using the attached command from the onion cloud seems to have any influence on the RGB LED. What am I missing?


  • So, has there been any movement on getting the expled to actually work? I can use the gpioctl but those are on/off, cannot control the amount of color to come through. All that comes back is "Segmentation Fault".

Looks like your connection to Community was lost, please wait while we try to reconnect.