We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Omega2+ DHCP, and Ethernet expansion

  • I have the Ethernet expansion, and since I'm not using a wifi enabled laptop (I have a desktop that's hard wired!) I don't have an easy way to connect to my Omega2.

    I, ideally, want to connect it to my LAN, via the ethernet interface. However, because there's a Wifi AP built in, I'm aware there must be a DHCP daemon running.

    So, before I upset my network administrator, I need to ensure that the DHCP server doesn't respond to requests on the Ethernet port. It's fine if it continues to respond on the Wifi side, when it's acting as an AP... but I can't take a risk of damaging our network, if the DHCP server is still enabled.

    Can anyone point me somewhere to do this easily? Command line doesn't bother me, and I know SSH to it is working fine.

    Thank you!

  • For the omega1 was it so, that you had first to config the lan (adapter) and then give access over the firewall to use the wifi & lan.

    In your case it looks like that you just have to activate lan (Ethernet Dock) and deactivate the wlan (putting # in front of Statements) in /etc/config/wireless.

    As long as you not give access between wlan & normal lan, i guess you not have to be worried. On lan you best use Static IP Adress ... so DHCP must be deactivated.

    About the firewall you have to check out the document how to use omega as Router.

  • I was having similar issue, then I tried to use omega as a router from below link:

    It is now working fine for me, and ethernet is getting IP by dhcp.
    But I also need a static ip on ethernet, so if in any case, dhcp is not working, it should be having the static ip.
    I tried to create one more connection name as 'eth1' with interface as 'wan' as below:
    config interface 'wan'
    option ifname 'eth1'
    option proto 'static'
    option ipaddr ''
    option netmask ''
    option ip6assign '60'

    But it is not working and one more interface 'eth1' is not being created. I tried with using interface as 'lan', it is also not working. Can anybody tell me how it can be done.
    Again, my requirement is to have a static ip on ethernet, in case dhcp is not working.

Looks like your connection to Community was lost, please wait while we try to reconnect.