We have upgraded the community system as part of the upgrade a password reset is required for all users before login in.

Unable to flash image

  • I think I have the 'test' image reported by some people. I tried to flash with omega-v0.0.4-b229.bin using flash new image webpage at but it says 'The uploaded image file does not contain a supported format. Make sure that you choose the generic image format for your platform. '

    I really don't want to send the chip back isn't there anything I can do here to get the new image on?

  • @Christiaan-Scholtz Can you take a screen shot of your flash new image webpage?

  • omegascreenshot.jpg
    I tried it without 'keep current settings' as well to no avail.

    Should I try building that Ethernet thing?

  • Hi @Christiaan-Scholtz, Hope everything is going well at 1Worx!

    I see what's going on. No this is not a test image. This is the default OpenWRT image that we used to develop on (because you guys have a prototype board). To flash this, you simply need to do the following:

    • Connect to the Omega via serial terminal
    • cd to /tmp directory
    • Use wget to fetch one of the new firmware binaries
    • Use sysupgrade -f <binary file name> to force update the Omega with the new firmware.

    Please let me know if this works.


  • That worked, thank you very much šŸ™‚

  • I have a new problem I cant seem to connect to the wireless. I disabled authentication, but still get the command not found error.

    Select from the following:

    1. Scan for Wifi networks
    2. Type network info
      q) Exit

    Selection: 1
    Scanning for wifi networks...

    Select Wifi network:

    1. wireless
    2. NETGEAR

    Selection: 1
    Network: wireless
    Authentication type: none

    Connecting to wireless network using intf 1...
    [ 1333.320000] IPv6: ADDRCONF(NETDEV_UP): wlan0-1: link is not ready
    [ 1333.560000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1334.440000] wlan0: authenticate with c8:6c:87:f1:fc:44
    [ 1334.460000] wlan0: send auth to c8:6c:87:f1:fc:44 (try 1/3)
    [ 1334.470000] wlan0: authenticated
    [ 1334.480000] wlan0: associate with c8:6c:87:f1:fc:44 (try 1/3)
    [ 1334.480000] wlan0: RX AssocResp from c8:6c:87:f1:fc:44 (capab=0x401 status=0 aid=2)
    [ 1334.490000] wlan0: associated
    [ 1334.490000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1334.520000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready
    Command failed: Not found
    Failed to parse message data
    sh: 1: unknown operand
    Checking wwan device status...
    wwan is sh: 1: unknown operand
    not up!!
    Checking internet connection...
    ERROR: request timeout, internet connection not successful
    Disabling network on iface 1 ...
    root@Omega-0103:/# [ 1370.060000] wlan0: deauthenticating from c8:6c:87:f1:fc:44 by local choice (Reason: 3=DEAUTH_LEAVING)
    [ 1372.760000] IPv6: ADDRCONF(NETDEV_UP): wlan0: link is not ready
    [ 1372.820000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready

  • @Christiaan-Scholtz The reason that You cannot connect to wireless is because after connecting to the wireless network, wifisetup does a test to see if it can ping our server. If it's unable to do that, it will reset the wifi setting to the original setting. If you just want the Omega to connected to your router, which is not connected to the Internet, you can still run the wifisetup command, but use Ctrl+C to terminate the script as soon as you see:

    [ 1334.490000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
    [ 1334.520000] IPv6: ADDRCONF(NETDEV_CHANGE): wlan0-1: link becomes ready

    Please let me know if this allows you to connect the Omega to your router.

  • Hi Boken

    Which missing command might the script be trying to run just after wlan becomes ready?

    The router is connected to the internet and I was able to connect to it and to the net with the previous image.
    Even if I abort early it seems like no IP is assigned.

    config wifi-iface
            option device 'radio0'
            option mode 'sta'
            option network 'wwan'
            option ssid 'wireless'
            option encryption 'psk2'
            option key 'xxxxxxxxx'
    wlan0     Link encap:Ethernet  HWaddr 00:23:CD:05:01:04
              inet6 addr: fe80::223:cdff:fe05:104/64 Scope:Link
              UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
              RX packets:3 errors:0 dropped:0 overruns:0 frame:0
              TX packets:20 errors:0 dropped:0 overruns:0 carrier:0
              collisions:0 txqueuelen:1000
              RX bytes:334 (334.0 B)  TX bytes:5150 (5.0 KiB)

  • Ah I've fixed it. There were left over settings from the previous image, I had changed the name of the interface in etc/config/network so the 'ubus call network.interface.wwan status' line in wifisetup was failing because it wasn't called wwan.

  • @Christiaan-Scholtz Ah, i see. Yeah, that makes sense. Firmware updates usually overwrite everything except for files in /etc directory.

  • @Boken-Lin

    Hi am having the same situation I can't flash back to my original firmware from openwrt can you help me I got the same massage

Log in to reply

Looks like your connection to Community was lost, please wait while we try to reconnect.